Unable to see copied images in trunk



  • I was using FOG 1.2 but ran into machines that I could not register. I have built a new trunk server using Kubuntu 14 and the install went smooth. I can register machines, copied my FOG settings and hosts over, but am unable to get my images to show up. I copied them over to the new server with scp. I checked the wiki and used chown and chmod to change permissions. I went through and verified I was using all the correct passwords. I am still unable to see the images in the web client.0_1469021623507_fog.PNG



  • Attached is the screenshot of what is happening when i try to image using one of my copied images.0_1469042166199_ntfsflag.jpg



  • @Wayne-Workman Yes, they are all Single Disk - Resizable.0_1469041498676_admin 2013.PNG


  • Moderator

    @Matthew-Zagaeski said in Unable to see copied images in trunk:

    Something else I’ve noticed while looking through the forums. Do we still need to encrypt the password via FOGcrypt in trunk? I have all my passwords in the web client and in the .fogsettings file encrypted.

    Passwords should not be encrypted in the .fogsettings file, everything in there is plain text.
    There’s a lot to it, this article explains all passwords:
    https://wiki.fogproject.org/wiki/index.php?title=Password_Central

    Are all your images really resizable?

    The NTFS flag thing, please give us a photo.



  • Something else I’ve noticed while looking through the forums. Do we still need to encrypt the password via FOGcrypt in trunk? I have all my passwords in the web client and in the .fogsettings file encrypted.



  • I have built the new Image definitions using the exact names on the old server. I have also ran the permission commands to verify that ownership is set correctly. I just sent a test image to a machine and it quickly restores under 100MB of data and states it is complete. It then gets stuck after clearing the ntfs flag. So it appears that the images did not associate with the files, as well as the imaging process itself not completing.0_1469027067680_Newimages.PNG


  • Moderator

    You have to create a definition per image. Web Interface -> Image Management -> Create New Image

    Linux is case sensitive, one wrong capital or lower case and it won’t work. This is for the image path. Set the image type exactly as it was on the old server (resizable, non-resizable, etc), set the OS exactly correctly.

    Sadly, 1.2.0 cannnot export image definitions. However FOG 1.3.0 RC1 can so this will never be an issue in the future for users using FOG 1.3.0+

    Since you copied the files manually, you’ll also need to ensure ownership and permissions are correct. If your images are located on /images then these commands will do it:
    chown -R fog:root /images
    chmod -R 777 /images


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.