Has something changed with UEFI?


  • Moderator

    So after looking over this thread, I have to ask the question, why are you using dnsmasq? What dhcp server do you have? Is it restricted so you can’t make changes?


  • Moderator

    @svalding Not sure I understand, but the dnsmasq.conf is the old style/way to setup dnsmasq. The newer way is for each dnsmasq service to place its config file in /etc/dnsmasq.d directory. When the dnsmasq process starts it reads through the dnsmasq.conf file (which is commented out) and then it processes the config files in the dnsmasq.d directory. Think of the dnsmasq.conf file is for global dnsmasq settings (for all dnsmasq services) and the individual files for service specific settings. Understand the dnsmasq can do a lot more than just proxyDHCP.



  • I want to put this out there that I got that information from a file called ltsp.conf in /etc/dnsmasq.d.

    There is an /etc/dnsmasq.conf file, but it is completely commented out like it is not being used for anything.



  • I’m going to switch the config to ipxe.efi and see what happens.


  • Moderator

    @svalding said in Has something changed with UEFI?:

    I have updated to the latest version that was linked here earlier.

    OK, just wanted to make sure you weren’t using your linux distro’s version which may be a few releases behind. Version 2.76 or newer is where you want to be.snponly.efi should work or you can use ipxe.efi (contains all known drivers) if you have issue with snponly.efi.



  • I have updated to the latest version that was linked here earlier.


  • Moderator

    @svalding You need to ensure you have the latest version of dnsmasq since earlier versions do not support efi very well (at all). Even if their configs say they do. You need the release that was created since (about) may 2016



  • I lied, I am looking at my dnsmasq config now. It’s snponly.efi

    0_1468966861510_pxe settings.png


  • Senior Developer

    @svalding UEFI should not be using ipxe.pxe, it should be using ipxe.efi.



  • I’ve got BOOTP settings as follows:

    Boot File: undionly.kpxe
    Next Server: Fog server IP address
    Boot Server: Fog server IP address

    Legacy clients are using the undionly.kpxe, while UEFI devices are using ipxe.pxe (I believe, this could be flip flopped, going from memory at the moment)



  • @svalding The problem specifically, I think is the boot file you’re using. What file do you have set for this machine? Keep in mind different files for different architectures via dnsmasq.

    After knowing what file you’ve always used for UEFI, we can then back track, trying different versions of that file, until we find a version that is working. After that, we can begin to move forward to find the version where it breaks, and figure out what changed. Do you understand?



  • So I did a whole lot of testing today. It seems to be specific to this Dell 7440 AIO and UEFI network booting.

    I have several Dell 9030 AIO and Microsoft Surface machines booting pxe via UEFI just fine. However, this one just won’t work.

    It starts trying to boot, and then flashes Downloading NBP file very quickly across the screen, and then goes to a F1 to retry boot menu. Updated to the latest BIOS available, if that helps. Perhaps an older version would be better in this case? I dunno. FoG and UEFI are definitely functioning properly though, as I have other UEFI devices that are fine.



  • Well that sheds a lot of light on things, thank you very much!


  • Senior Developer

    @Wayne-Workman Remember, it is also globally defined as well. In the case a host has not been registered, or the exit type has not been defined, there’s a fallback. My guess is under FOG Configuration->iPXE Boot Menu, the Exit to Hard Drive Type(EFI) is selected for rEFInd?



  • @svalding rEFInd is an exit type, that’s defined per-host in host management, or via groups. It has nothing to do with dnsmasq.



  • I found it here! Still not making heads or tails of it yet.

    /var/www/fog/service/ipxe



  • That has done nothing. It is still pointing at this rEFInd thing, and I can’t figure out where. Are there any snippets of files I can post that could provide insight?



  • @svalding Well, the dnsmasq available in your FOG Server’s repos is likely older, and doesn’t even support UEFI in ProxyDHCP mode at all, so I’m not sure how this was working with strictly UEFI machines previously (support simply was not there).

    There is a new version of dnsmasq released that supports UEFI in ProxyDHCP mode. Here’s a thread about it, with links to binaries and such. There may be newer available as well, but you’ll have to hunt them down on ‘thekellys’ website.
    https://forums.fogproject.org/topic/7424/dnsmasq-to-support-proxydhcp-for-uefi



  • We are actually using dnsmasq, and we have our DHCP options set on our Infoblox appliance. I just find it odd that pre-trunk update we were pulling everything correctly on UEFI machines, and now we are getting these weird menus. I just wasn’t sure where to look to see where that is getting pulled from, if it was a setting in some FOG file, or what have you. We didn’t touch any of our other settings as far as TFTP or DNSMASQ.

    I’ll give this link you posted a read so I can have a little better understanding of the boot process.



  • Maybe you should start your reading here: https://wiki.fogproject.org/wiki/index.php?title=BIOS_and_UEFI_Co-Existence

    If you’re using FOG Trunk for DHCP, then this is already done for you.


Log in to reply
 

373
Online

6.2k
Users

13.5k
Topics

127.5k
Posts