Snapins do not replicate to storage node



  • Using the latest FOG server (8540) and client (0.11.3). One storage group with two nodes: the main server and one slave.

    On the client, in C:\fog.log:

    ------------------------------------------------------------------------------
    ---------------------------------SnapinClient---------------------------------
    ------------------------------------------------------------------------------
     2016/07/13 09:18 PM Client-Info Client Version: 0.11.3
     2016/07/13 09:18 PM Client-Info Client OS:      Windows
     2016/07/13 09:18 PM Client-Info Server Version: 8540
     2016/07/13 09:18 PM Middleware::Response Success
     2016/07/13 09:18 PM SnapinClient Snapin Found:
     2016/07/13 09:18 PM SnapinClient     ID: -1
     2016/07/13 09:18 PM SnapinClient     Name: 
     2016/07/13 09:18 PM SnapinClient     Created: -1
     2016/07/13 09:18 PM SnapinClient     Action: 
     2016/07/13 09:18 PM SnapinClient     Hide: False
     2016/07/13 09:18 PM SnapinClient     TimeOut: -1
     2016/07/13 09:18 PM SnapinClient     RunWith: 
     2016/07/13 09:18 PM SnapinClient     RunWithArgs: 
     2016/07/13 09:18 PM SnapinClient     File: 
     2016/07/13 09:18 PM SnapinClient     Args: 
     2016/07/13 09:18 PM SnapinClient ERROR: Snapin hash does not exist
    ------------------------------------------------------------------------------
    

    The ID is NOT -1 in the database. In my experience, error messages relating to FOG are usually confusing or misinforming, which is unfortunate. However, after reading this, I started investigating:

    http://mymainserver/fog/status/getsnapinhash.php?filepath=/opt/fog/snapins/res1360x768.ps1 returns a hash, but http://mystoragenode/fog/status/getsnapinhash.php?filepath=/opt/fog/snapins/res1360x768.ps1 returns 0.

    There were no files in /opt/fog/snapins/ on the storage node. The Snapin Replicator log reported:

    [07-13-16 10:18:36 pm] * Starting Sync Actions
    [07-13-16 10:18:36 pm] | CMD:
    			lftp -e 'set ftp:list-options -a;set net:max-retries 10;set net:timeout 30; mirror -c -R -i res1360x768.ps1 --ignore-time -vvv --exclude 'dev/' --exclude 'ssl/' --exclude 'CA/' --delete-first /opt/fog/snapins /opt/fog/snapins; exit' -u fog,[Protected] ip.ip.ip.ip
    [07-13-16 10:18:36 pm] * Started sync for Snapin Resolution 1360x768
    mirror: Access failed: 553 Could not create file. (res1360x768.ps1)
    

    Then I read this and tried:

    # chown -R fog:root /opt/fog/snapins
    

    So it works now.

    BUT: This was on a fresh install of the latest trunk on a brand new Debian Jessie machine, following the installation instructions and “best practices” (sudo -i and what not) as best I could. So maybe that chown command should go in the installer?


  • Senior Developer

    I’m pretty sure it does fall on the installer already.

    I’ll double check just to be sure:

       1 configureSnapins() {                                                                         
       2     dots "Setting up FOG Snapins"                                                            
       3     mkdir -p $snapindir >>$workingdir/error_logs/fog_error_${version}.log 2>&1               
       4     if [[ -d $snapindir ]]; then                                                             
       5         chmod -R 775 $snapindir                                                              
       6         chown -R fog:$apacheuser $snapindir                                                  
       7     fi                                                                                       
       8     errorStat $?                                                                             
       9 } 
    

    That’s the script portion in the installer’s functions.sh file.

    I see what’s wrong now. Thanks for leading me to it. Yes, Servers were getting the information set, but plain nodes were not. Should be fixed in latest. Thanks for reporting. Also fixed a few minor issues while I was there.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.