Intel I219-V NIC Not Getting Address VIA DHCP

  • I have been running for for some time now and just got a new batch of HP Probook 650G2’s for deployment. I have not had a problem with any of the other 250 hosts I have imaged (mostly workstations).

    I’m running FOG version 8415 (GIT).
    Kernel Versions are 4.6.2.

    The fog menu comes up just fine. If I manually register a host, the menu says, this host has been registered as “Name I Manually Created”. Any menu choice from the fog menu comes up with a udhcpc started, sending discover X 3, no lease, failing. This seems to be a problem specifically with this network card as all of my other workstations and laptops that I have previously cloned still work fine. I was using tftpboot option undionly.kkpxe on my Windows DHCP server for all other successes. I have tried every boot option without success.

    Any ideas?

  • Moderator

    @jphillip5 Ok the dumb switch resolved (masked) your issue.

    Your building switch, is it an advanced switch like the Catalyst series?

    Do you have fast STP, port fast, or RSTP enabled on the ports that go to these HP targets?

    Do you have green ethernet or 802.1az enabled on these switches? (if so turn it off).

  • It did not get an IP address from the command prompt (ip addr show).

    The unmanaged switch between the two seems to have resolved the problem at least for now.

    Just for kicks:
    Driver Provider: Intel
    Driver Date 8/13/2015

    Hardware Ids

  • Moderator

    If you put a dumb (unmanaged switch) between the HP Probook 650 and the building switch does it pickup an IP address?

    The trouble sounds like the FOS engine is not picking up the dhcp address (which could be a driver issue or something else). If you schedule a debug deployment (select debug when you schedule a task). Does it pickup an IP address after a bit from the command prompt ip addr show?

    If you have one of these target computers already running windows, can you get the vendor and hardware ID of this NIC?

Log in to reply