Will not capture Windows 10 image



  • hi all,
    Quick background:
    I am helping my child’s school use FOG for a reimage of all computers on the campus. I have been using FOG for about a month. We’ve successfully imaged 64 laptops, 2 different models, with no issues. Works great so far!

    We have a computer lab that uses Lenovo M72z systems that we are trying to image with Windows 10. I have my Master Image machine ready to go.

    • It boots the ipxe image and I am able to do a “Quick Registration and Inventory” correctly.
    • I created the image name and assign it as I have with the past 2 images.
    • I create the capture task as with the past 2 images

    Problem:
    When I boot the system to capture the image, it boots the ipxe image then gets the handoff to the bzImage. I get the FOG project ASCII splash and then the list of steps. It is stopping on or after “Saving original disk/parts UUIDs”

    I checked the inventory in FOG and it shows the hard disk model and firmware.

    I’ve downloaded the latest kernel from the kernel updates page and it appears to be using the latest kernel but still stops at the same place.

    Any suggestions on where to start?

    -Roy



  • @Wayne-Workman:
    The GPT was the issue. I am now able to capture the image from the M72z. Thanks for the help.

    -Roy



  • Thanks Wayne. I hadn’t looked at the part table (GPT vs MFT). Will check and post back.

    -Roy


  • Moderator

    Typically, when FOS (fog operating system) hangs at the “Saving original disks” step, this is due to GPT remnants being present.

    This is becoming more and more common, as systems are shipped with GPT formatted disks, but users revert to Legacy and doing a scratch install because they have not configured Bios and UEFO Co-Existence yet.

    Typically, this is solved by doing a debug-upload and running fixparts /dev/sda and then issuing the fog command.

    Hope this helps. For further help, please post screenshots of where it’s hanging, and perhaps after booting to debug, post the output of lsblk and fdisk -l Of course please respond back with the outcome, we don’t want to leave you hanging, we want FOG to work for you.

    Also - historically, the Lenovo M72 model has been very troublesome with FOG. We have these models at work, we’ve not successfully deployed them as far as I’m aware of. Others have had issues too, here on the forums. However if you work with us and provide details and pictures, we will do our very best to help.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.