Database Schema Fresh Install Revision: 8273

  • Fresh install of Centos 6.7. Running PHP 5.6 and Mysql as the database.

    Follow the instructions to install the trunk version after downloading via SVN and have hit a road block. Left Mysql password blank during install and have not run the mysql script yet. Getting direction by the Fog install to install/update database schema and receiving this message when navigating:

    Database Schema Installer / Updater
    Your database connection appears to be invalid. FOG is unable to communicate with the database. There are many reasons why this could be the case. Please check your credentials in /var/www/html/fog/lib/fog/config.class.php. Also confirm that the database is indeed running. If credentials are correct, and the Database service is running, check to ensure your filesystem has enough space.

    I’ve checked all of the recommended locations - password is blank in the config.class.php. I’ve also followed even though its for Ubuntu but I’m getting a syntax error with the ALTER USER command I cant seem to rectify.


  • @Tom-Elliott Thanks Tom. I’m not really sure what the issue was with Centos 6.7. Iptables was disabled, SELinux was disabled. It didn’t throw any specific error messages and nothing in any of the logs caught my eye.

    Either way, Wayne’s suggestion to move to CentOS 7 worked and I now have the trunk up and running. Thanks for the help folks!

  • @Tom-Elliott said in Database Schema Fresh Install Revision: 8273:

    Why repave and go through again?

    7 will be supported longer than 6, just makes no sense to use 6 for a new install. Plus there is an up to date tutorial for 7. The others for older CENTOS are outdated.

  • For example, was SELinux running? IPTables? Anything in the error logs?

  • I’m not understanding what the problem IS.

    Why repave and go through again? What’s the actual issue right now?

  • @Wayne-Workman Definitely! Thanks for the reply. Will give it a shot and let you know how it works out!

  • @ahooks Since this is a new install, can you use CentOS 7 instead? Don’t upgrade, just nuke and repave.

  • Update: I changed the root password for mysql and then updated that in the config.class.php. Still receiving the same error. Ran the rest of the fog install script and it finished out the other steps but its still halting me at the database schema installer/updater.