Fog and Intel NUC 6i5SYK : i8042 no controller found



  • Hi,

    I’ve got a problem when i boot on Fog pxe ( version 1.2) with an Intel NUC 6i5SYK.
    The Nuc is booting correcly until everything stop with te message :

    i8042 : NO CONTROLLER FOUND.

    Do you know what this errors means and how to resolve this problem ?

    Thanks for your help


  • Moderator

    @sloeckle Just for clarity I was wrong in my post. If you are running FOG 1.2.0 the newest kernels you can run must be less than version 4.4. That means you will need 4.1.X and less than 4.4.0. The kernels 4.4 and newer requires code that only exists in FOG 1.3.0.

    Your final answer may be to upgrade to the 1.3.0-rc7 (or what ever is the latest in the 1.3.0 series.



  • Hey Everyone,

    Posting this to help anyone else out with this box. I have NUC 6i3SYH, pretty much the same box. Using 1.2.0 with old kernels, I could not upload an image to fog. Upgrading the kernels manually with George’s suggestion unfortunately did not help me either. I got a little further but would timeout when attempting to mount the remote NFS volume. The only thing that worked was to upgrade to trunk. Not only do I have all the new features, I can image these 6th gen NUCs!

    Thanks for starting the thread. It helped me greatly!

    Stephen



  • Thanks a lot

    I upgraded to fog trunk and everything is OK

    Thanks for your help
    Friendly



  • Thank you very much for all this informations.
    I’ll try to upgrade to fog Trunk on monday.

    I’ll give you the result

    Thanks a lot

    Friendly

    Laurent Morel


  • Developer

    @morelo There is a search feature in this forum. Please feel free to make use of it. Doing it you’d find things like this:

    The i8042: No controller found error is probably nothing. The fact that it finds the drive and doesn’t do anything after that is the factor I’m worried about. The i8042 is just the kernel reporting it’s loaded the driver, but can’t find a controller for the driver itself. it’s nothing to be overly concerned about.

    For the hang you might want to follow George’s suggestion on trying newer kernels or even update to FOG trunk (search the wiki on how to do this).


  • Moderator

    Do I know what that error means? Yes I do, but its because I’m old.

    The keyboard controllers on the early mobos used an embedded intel controller 8051. The 8042 is just a newer and significantly smaller version of the 8051. So the FOS kernel has thrown the error above because it can’t find something that resembles it.

    In simple english, the FOS kernel can’t find the keyboard controller.

    I assume you are using fog 1.2.0 stable. (You should see 1.2.0 posted on the FOG Cloud on the WebGUI management page).

    How to fix: One way would be to upgrade to the trunk version of FOG to get the latest kernels. The other way is to manually update the kernels on 1.2.0 to the trunk version. NOTE: Only update the kernels not the kernels + inits.

    1. You can download the new kernels from here. The latest ones are 4.6.2 (or newer)
      https://fogproject.org/kernels/bzImage
      https://fogproject.org/kernels/bzImage32

    2. Rename the existing files in /var/www/html/fog/service/ipxe

    3. Then place the downloaded files in that folder path

    4. Reboot your target computer


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.