Stop at boot.php when creating capture task



  • Hey folks,

    i update on the current trunk (like 1 hour ago) and now the bootloader stucks at “http://fogserver//fog/service…” , Mind the “//”, i cannot make it bold unfortunately. Is this an error in my configuration or is this a bug in the trunk?

    Thanks
    Chris

    edit: a capture task is created for this machine - with the task cancelled the boot menu shows up without any issues



  • You can actually solve this issue - the problem was the wrong ip address - thanks guys for the support :)



  • Yeah the settings are completely gone … even with the colors :D


  • Developer

    @christianu said:

    On a side note - your boot menu config is gone (no bg nothing just blue and red) where can i restore this with bg and all?

    In the code you posted below you can see that the image filename is missing:

    :get_console
    console --picture http://192.168.22.76/fog/service/ipxe/ --left 100 --right 80 && goto console_set || goto alt_console
    :MENU
    

    Check FOG_IPXE_BG_FILE in the FOG configuration on the web GUI.



  • Actually this is strange

     parameter 1 to be resource, null given, Host: fogserver, Username: fog
    

    “fogserver” is in this case the old fogserver ip instead of the new one - where can i change this?

    Update: Found it - the nfsGroubmembers where still using the old ip.

    On a side note - your boot menu config is gone (no bg nothing just blue and red) where can i restore this with bg and all?


  • Moderator

    @christianu said in Stop at boot.php when creating capture task:

    This comes when creating the task

    PHP Warning: curl_setopt_array() expects exactly 2 parameters, 1 given in /var/www/html/fog/lib/fog/fogurlrequests.class.php on line 107, referer: http://fog.mgmt.offber/fog/management/index.php?node=host&sub=deploy&id=2&type=2

    That may be what is know and an unexpected programming occurrence. @Senior-Developers ?



  • And this when calling the url

    PHP Fatal error: Uncaught exception ‘Exception’ with message ‘Type: 2, File: /var/www/html/fog/lib/fog/fogurlrequests.class.php, Line: 108, Message: curl_multi_add_handle() expects parameter 1 to be resource, null given, Host: fogserver, Username: fog’ in /var/www/html/fog/lib/fog/fogftp.class.php:51\nStack trace:\n#0 /var/www/html/fog/lib/fog/storagenode.class.php(102): FOGFTP->connect()\n#1 /var/www/html/fog/lib/fog/fogcontroller.class.php(245): StorageNode->loadImages()\n#2 /var/www/html/fog/lib/fog/fogcontroller.class.php(48): FOGController->loadItem(‘images’)\n#3 /var/www/html/fog/lib/fog/storagenode.class.php(41): FOGController->get(‘images’)\n#4 /var/www/html/fog/lib/fog/storagegroup.class.php(44): StorageNode->get(‘images’)\n#5 [internal function]: StorageGroup->{closure}(Object(StorageNode))\n#6 /var/www/html/fog/lib/fog/storagegroup.class.php(52): array_map(Object(Closure), Array)\n#7 /var/www/html/fog/lib/fog/bootmenu.class.php(641): StorageGroup->getOptimalStorageNode(‘1’)\n#8 /var/www/html/fog/lib/fog/bootmenu.class.php(1 in /var/www/html/fog/lib/fog/fogftp.class.php on line 51

    I call it a night and will continue tomorrow :)



  • This comes when creating the task

    PHP Warning: curl_setopt_array() expects exactly 2 parameters, 1 given in /var/www/html/fog/lib/fog/fogurlrequests.class.php on line 107, referer: http://fog.mgmt.offber/fog/management/index.php?node=host&sub=deploy&id=2&type=2


  • Moderator

    @christianu When you get these 4 lines. What does the apache error log say. Not sure where it is on debian, let me see if I can find Sebastian’s signature.

    [edit]Web GUI issue? Please take a look at your apache error log file (debian/ubuntu: /var/log/apache2/error.log, centos/fedora/rhel: /var/log/httpd/error_log)

    Tail the above log file. My bet there is an error thown.



  • Yeah just the first 4 lines

    #!ipxe
    set fog-ip 192.168.22.76
    set fog-webroot fog
    set boot-url http://${fog-ip}/${fog-webroot}
    

  • Moderator

    @christianu Does the issue only happen on upload/download? Can you queue a task for this MAC and then see what this URL produces?



  • This is what i get when i call it without capture task

    #!ipxe
    set fog-ip 192.168.22.76
    set fog-webroot fog
    set boot-url http://${fog-ip}/${fog-webroot}
    cpuid --ext 29 && set arch x86_64 || set arch i386
    goto get_console
    :console_set
    goto MENU
    :alt_console
    goto MENU
    :get_console
    console --picture http://192.168.22.76/fog/service/ipxe/ --left 100 --right 80 && goto console_set || goto alt_console
    :MENU
    menu
    item --gap Host is registered as BPY-LAP-028!
    item --gap -- -------------------------------------
    item fog.local Boot from hard disk
    item fog.memtest Run Memtest86+
    item fog.keyreg Update Product Key
    item fog.quickimage Quick Image
    item fog.multijoin Join Multicast Session
    item fog.quickdel Quick Host Deletion
    item fog.sysinfo Client System Information (Compatibility)
    choose --default fog.local --timeout 0 target && goto ${target}
    :fog.local
    sanboot --no-describe --drive 0x80 || goto MENU
    :fog.memtest
    kernel memdisk iso raw
    initrd memtest.bin
    boot || goto MENU
    :fog.keyreg
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param username ${username}
    param password ${password}
    param keyreg 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :fog.quickimage
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param username ${username}
    param password ${password}
    param qihost 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :fog.multijoin
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param username ${username}
    param password ${password}
    param sessionJoin 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :fog.quickdel
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param username ${username}
    param password ${password}
    param delhost 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :fog.sysinfo
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 keymap= web=192.168.22.76/fog/ consoleblank=0 rootfstype=ext4 loglevel=4 mode=sysinfo
    imgfetch init_32.xz
    boot || goto MENU
    :bootme
    chain -ar http://192.168.22.76/fog/service/ipxe/boot.php##params ||
    goto MENU
    autoboot
    

  • Moderator

    @christianu said in Stop at boot.php when creating capture task:

    okay i will change the default.ipxe (it should not help)

    Ah - its a Debian and completely fresh.

    @george1421 A screen full of text ;)

    Can you copy/paste this so we can see it?


  • Moderator

    Does the apache error log give you any indication of the error? It sounds like the deploy is failing to create the required ipxe fog menu.

    Because this is wrong, it should give you the full path to something

    set fog-ip 192.168.22.76
    set fog-webroot fog
    set boot-url http://${fog-ip}/${fog-webroot}
    


  • Yeah but the management console is running :)


  • Moderator

    Make sure apache2 is running. I had an instance this morning on one server where it (very unusually) did not start up automatically after a reboot.



  • When i create a new capture task its the same error again. But i have to change the title apparently :D


  • Moderator

    @christianu So its solved or just different results?



  • Yes to all of it - the “//” was not the problem. Yes the servers owns a static ip and is behind a dhcp - all options are set (i already saw your bootmenu)

    But i found something else for now

    I called the url with the MAC address the not working host and i got just these lines

    #!ipxe
    set fog-ip 192.168.22.76
    set fog-webroot fog
    set boot-url http://${fog-ip}/${fog-webroot}
    

    Than i remembered that i created an image pull task for this host - deleted the task and the boot menu is back again.


  • Moderator

    Before you installed fog, did you set the fog server to have a static IP address?

    And the ip address listed in the /tftpboot/default.ipxe points to the IP address of your fog server?


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.