PXE not working. Getting error



  • Good Morning!
    I am getting the following error on PXE boot
    TFTP
    PXE-T01: File not found
    PXE-E3B: TFTP Error - File Not found
    PXE -M0F: Exiting PXE ROM

    I have Verified Option 66 and 67 on Server 2012 DHCP server.

    I have verified i can TFTP from Windows.
    and get the file
    I have undionly.kpxe as the file.
    Just at a loss as to what is incorrect.
    Searched forums and have tried all I can find (i Think)
    Thanks in advance!!!



  • You guys are awesome!!!
    OK, So here is what was happening.
    WDS was still running on an old server (I am trying to decommission but it has our lunchroom software)
    Stopped WDS and Boom!!! Now I have PXE boot.
    I still have to move my datastores for image locations but now can at least boot into PXE.
    Lots of tweaking and I am sure questions. But I feel I am moving in the correct direction.
    Thanks!
    Rob
    Please mark as closed.


  • Moderator

    @george1421 I don’t really see how that would cause his current issues though.

    And I’m fairly certain UEFI pxe boot would give an error about snp.

    I’m guessing it’s in UEFI with CSM enabled and the PXE is in legacy mode.

    However, this still raises the question about what’s going on with his setup.

    @maveriick This is a shot in the dark, but check your FOG server if there’s a DHCP server running.

    The fact that two different computers try to contact two different IPs sounds like multiple DHCPs on your network.


  • Moderator

    @maveriick OK I see conflicting settings then.

    The undionly.kpxe is a bios boot file, for uefi booting you want ipxe.efi.

    If you have a windows 2012 dhcp server you can set it up to issue the correct boot file based on the target computer.

    [edit] Inserted link to wiki page: https://wiki.fogproject.org/wiki/index.php?title=BIOS_and_UEFI_Co-Existence

    OR just switch the computer back to (legacy) bios mode.



  • The computer in question is a Lenovo Twist.
    0_1466434694444_upload-0dcf5e43-5285-48d0-bc2f-014babf044a3
    Here is option 66 and 67
    I just tested on a Dell 3020 and it PXE’s but to a different IP.
    I just know this is something simple but can not find it.
    I have UEFI enabled.
    I am running trunk version 8038 i believe
    Thanks,
    Rob


  • Moderator

    Use this wiki page to help troubleshooting

    https://wiki.fogproject.org/wiki/index.php/Unable_to_connect_to_TFTP

    Also, I don’t know if it’s necessary on Server 2012, but did you restart the DHCP server after applying the DHCP options?


  • Moderator

    It looks like you did all of the basic checks.

    What version of FOG are you using?

    Can you post a screen shot of dhcp options 66 and 67?

    What target computer are we talking about (make and model)?

    Is the target computer in bios or uefi mode?

    Having a screen shot of the actual error may help identify the issue too.


Log in to reply
 

480
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.