Custom ISO (centos 6/7 ) installation issues.



  • Hi ,
    I was able to create a custom boot menu for any ubuntu distribution ( sample trusty menu )

    :fog.trusty
    set path /fog/OS_IMAGES/ubuntu-14.04.3-DVD
    set nfs_path /images/OS_IMAGES/ubuntu-14.04.3-DVD
    kernel http://fogsrv/fog/OS_IMAGES/ubuntu-14.04.3-DVD/install/netboot/ubuntu-installer/amd64/linux || read void
    initrd http://fogsrv/fog/OS_IMAGES/ubuntu-14.04.3-DVD/install/netboot/ubuntu-installer/amd64/initrd.gz || read void
    imgargs linux root=/dev/nfs boot=casper live-installer/net-image=http://fogsrv/fog/OS_IMAGES/ubuntu-14.04.3-DVD/install/filesystem.squashfs ks=http://fogsrv/fog/OS_IMAGES/kickstarts/precise_ks.cfg ip=dhcp splash quiet – || read void
    boot || read void
    goto start
    

    Now I am trying to create the same type for centos

    :fog.centos
    set path /fog/OS_IMAGES/CENTOS-6.8-DVD
    set nfs_path /images/OS_IMAGES/CENTOS-6.8-DVD
    kernel http://fogsrv/fog/OS_IMAGES/CENTOS-6.8-DVD/images/pxeboot/vmlinuz || read void
    initrd http://fogsrv/fog/OS_IMAGES/CENTOS-6.8-DVD/images/pxeboot/initrd.img || read void
    append ks=http://fogsrv/fog/kickstarts/centos6.cfg ramdisk_size=100000 ksdevice=eth0 root=/dev/rd/0 ip=dhcp url --url http://10.0.28.24/fog/OS_IMAGES/CENTOS-6.8-DVD  || read void
    boot || read void
    goto start
    

    When trying to boot the client through centos. It boots and complains on “append” option.
    “APPEND options not recognized”

    Did anyone create a centos iso installation menu with kickstart?

    Thank you
    Chakri


  • Senior Developer

    @Tom-Elliott that said I think it does need the mode arg aka linux


  • Moderator

    @Tom-Elliott iPXE seems to claim it’s mandatory from what I can tell

    http://ipxe.org/cmd/imgargs

    But it does basically the same thing as what you said, so it doesn’t really matter.


  • Senior Developer

    @Quazz I don’t think the kernel has to be specified as its the args but I could be wrong


  • Moderator

    @Tom-Elliott I think he simply forgot to put vmlinuz after imgargs.


  • Senior Developer

    @csa I think you could still use imgargs just call it before initrd. Glad it’s working though.



  • With my special thanks to Tom Elliott and team. Please resolve this ticket.

    Thank you
    Chakri



  • @Tom-Elliott said in Custom ISO (centos 6/7 ) installation issues.:

    @csa I believe you need to move it to the “kernel” section, not the initrd

    Tom,
    You are simply awesome. Yes moving all the options to kernel worked like a champ. So for RHEL / Centos the following ipxe configuration menu works

    :fog.centos
    set path /fog/OS_IMAGES/CENTOS-6.8-DVD
    set nfs_path /images/OS_IMAGES/CENTOS-6.8-DVD
    kernel http://fogsrv/fog/OS_IMAGES/CENTOS-6.8-DVD/images/pxeboot/vmlinuz ks=http://fogsrv/fog/kickstarts/centos6.cfg  ramdisk_size=100000 ksdevice=eth0 root=/dev/rd/0 ip=dhcp splash quiet – || read void
    initrd http://fogsrv/fog/OS_IMAGES/CENTOS-6.8-DVD/images/pxeboot/initrd.img || read void
    goto start
    
    

    Thank you so much
    Chakri


  • Senior Developer

    @csa I believe you need to move it to the “kernel” section, not the initrd



  • Team,
    I tried all the following options but didn’t have any success. This is happening with any centos or RHEL distribution. With ubuntu “kernel, initrd and imgargs” are working like champ.
    The issue seems to be unable to pass the following option through ipxe.
    ramdisk_size=100000 ksdevice=eth0 root=/dev/rd/0 ip=dhcp
    using imgargs or moving to initrd.

    Option 1.

    Error --> boots and complains on "ks=… No such file or directory"
    Moved “ramdisk” before ks=. Errors out saying "ramdisk=100000… no such file or directory

    :fog.centos
    set path /fog/OS_IMAGES/CENTOS-6.8-DVD
    set nfs_path /images/OS_IMAGES/CENTOS-6.8-DVD
    kernel http://fogsrv/fog/OS_IMAGES/CENTOS-6.8-DVD/images/pxeboot/vmlinuz || read void
    initrd http://fogsrv/fog/OS_IMAGES/CENTOS-6.8-DVD/images/pxeboot/initrd.img || read void
    imgargs ks=http://fogsrv/fog/kickstarts/centos6.cfg ramdisk_size=100000 ksdevice=eth0 root=/dev/rd/0 ip=dhcp url --url http://10.0.28.24/fog/OS_IMAGES/CENTOS-6.8-DVD  || read void
    boot || read void
    goto start
    

    Option II
    Removed imgargs section and moved everything to “initrd” section. Boots further but errors out saying " Cannot open root device "(null) … Please append a correct “root=” boot option ". Which means its the options in initrd section are getting ignored.

    :fog.centos
    set path /fog/OS_IMAGES/CENTOS-6.8-DVD
    set nfs_path /images/OS_IMAGES/CENTOS-6.8-DVD
    kernel http://fogsrv/fog/OS_IMAGES/CENTOS-6.8-DVD/images/pxeboot/vmlinuz || read void
    initrd http://fogsrv/fog/OS_IMAGES/CENTOS-6.8-DVD/images/pxeboot/initrd.img ks=http://fogsrv/fog/kickstarts/centos6.cfg ramdisk_size=100000 ksdevice=eth0 root=/dev/rd/0 ip=dhcp || read void
    boot || read void
    goto start
    

    Thank you
    Chakri


  • Moderator

    Ok I see a red flag here.

    What version of FOG are you running? What do you have set for dhcp option 67 {boot file}.

    And to refer to your OP. Why does the top one work WITH imgargs and the bottom one does not if you replace append with imgargs? The only thing I see in the top one is you are calling out the kernel with linux then adding in the args.


  • Moderator

    @csa You replaced APPEND with imgargs vmlinuz ?



  • @Quazz
    Thank you the “imgargs” also didn’t work. Trying without it.

    Thank you
    Chakri



  • @george1421 said in Custom ISO (centos 6/7 ) installation issues.:

    at issue. FOG passes a number of kernel parameters to the FOS client engine. You can also use that method to ensure what you are entering in the webgui ends up correctly in the assembled iPXE menu.

    Thank you for the tip. I see there is no “imgargs” option too. Let me give a try.

    Thank you
    Chakri


  • Moderator

    APPEND is a PXELinux option, not an iPXE option.

    Use the imgargs argument instead.


  • Moderator

    Oops I missed that at first glance, append is not a supported iPXE statement. You do need to use the imgargs statement instead.


  • Moderator

    If you open a browser to http://<fog_server_ip>/fog/service/ipxe/boot.php?mac=00:00:00:00:00:00 You can see how the fog developers solved that issue. FOG passes a number of kernel parameters to the FOS client engine. You can also use that method to ensure what you are entering in the webgui ends up correctly in the assembled iPXE menu.


Log in to reply
 

338
Online

38727
Users

10554
Topics

99921
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.