Windows 7 Post Imaging Steps Breaking Image Deploy



  • Something that FOG does after deploying an image to a client is breaking sysprep.

    The following manual steps successfully deploy an image every time:

    fdisk /dev/sda - partition type 7 bootable yadda yadda

    dd if=/images/misc/bootloader.img of=/dev/sda bs=446 count=1 ; zcat d1p1.img | partclone.ntfs -r -o /dev/sda1 ; echo “y” | ntfsresize -f /dev/sda1 ; partclone.ntfsfixboot -w /dev/sda1 ; reboot -n -f

    If I do that, sysprep operates correctly; machine comes up to log in prompt; fog service joins domain; all is well.

    However, if I deploy the image to the client via Fog Task then I see “The Computer Restarted unexpectedly or encountered an unexpected error”. I have to do a Shift+f10 at that point and regedit the ChildCompletion key.

    The clients are iMacs and the version of Fog is Running : 8064 and SVN : 5661.

    I’ve also disabled the post image Hostname Changer registry edit in favor of just using the Fog Client to handle that. It doesn’t make any difference. Fog sets up the partition map and bootloader sanely because if I manually partclone the image into the partition then all works.

    I’m guessing that the image Deploy is making a registry or disk change that my unattend.xml is not coping with well.


  • Senior Developer

    @davemaxwell FOG, I doubt, is the culprit. See FOG, while fast, doesn’t “break” things, not in the sense I think you’re thinking.

    The Client might interrupt an otherwise normal post-imaging step, but it is not FOG in any form destroying the sysprep information. I’ve run into things as simple as the host is restarting due to hostname change or ad join (directly client related but not “FOG’s” fault persay), to AVG/Antivirus, to drivers causing the image to not load properly on “first boot”.



  • That’s an answer. I’ll try this tomorrow and let this topic know how it goes.


  • Moderator

    If you’re using the fog client + sysprep, you must complete the sysprep steps at the bottom of this article: https://wiki.fogproject.org/wiki/index.php?title=FOG_Client


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.