another init.xz issue



  • @george1421 said in another init.xz issue:

    Just for clarity, if you are booing with the FOS USB stick, you need to update the image args in the /boot/grub/grub.cfg file. The FOG server is not part of the booting process at this level.

    Just for clarity too: I put “has_usb_nic=1 mdraid=true” at the end of the line "linux $myimage loglevel=7 … " near the bottom of the file?



  • @Quazz said in another init.xz issue:

    I actually took the time to look through the spec sheet this time, seems like the Ethernet port is located on the dock you plug the device in.

    I don’t think that makes it a USB NIC, not sure how much support there is for such docks to be honest.

    Of course that doesn’t make it a USB NIC, but if the readme file that comes with the drivers say that it’s a USB NIC, then I tend to believe that :-) The device itself doesn’t have any connections, so I assume that the dock is a “close extension” of the device, and we can see it as one.


  • Moderator

    @bmaster001 said in another init.xz issue:

    No idea if it’s using a raid controller. There’s no option like that in the bios anyway…
    I tried “has_usb_nic=1 mdraid=true” in the kernel arguments field for the host, but it keeps hanging on “init.xz…ok” when I create a capture-task for it.

    Just for clarity, if you are booing with the FOS USB stick, you need to update the image args in the /boot/grub/grub.cfg file. The FOG server is not part of the booting process at this level.


  • Moderator

    I actually took the time to look through the spec sheet this time, seems like the Ethernet port is located on the dock you plug the device in.

    I don’t think that makes it a USB NIC, not sure how much support there is for such docks to be honest.



  • No idea if it’s using a raid controller. There’s no option like that in the bios anyway…
    I tried “has_usb_nic=1 mdraid=true” in the kernel arguments field for the host, but it keeps hanging on “init.xz…ok” when I create a capture-task for it.

    Correction… I found the AHCI/IDE option. Will try that as well…


  • Senior Developer

    And it appears this is using a raid controller? Maybe change the BIOS hdd controller to AHCI or IDE, or set mdraid=true to the hosts kernel arguments.




  • Moderator

    @bmaster001 You need to add a kernel argument to this host. I believe it’s hasusbnic=1



  • Disabling TPM does not change anything.

    Then, I tried your image. I see “loading the kernel”, “loading the virtual hard drive” and “booting the kernel…”. Then it halts. The TPM setting in the bios doesn’t change anything.

    I guess this is bad news… ?

    EDIT: When I disable “uefi boot” in the bios, I get more text, but it hangs again before I get a prompt (see screenshot below)
    EDIT2: After a few hours of searching, I found a driverset of the VM3 device. It seems that the NIC used here is some sort of USB network device. The readme.txt mentions LAN95XX. Don’t know if that might help debugging this? I tried booting with a ipxe.iso that I created on rom-o-matic.eu, with all network drivers, but it can’t find any NIC. So I guess this driver isn’t included (yet)…

    0_1466057677458_IMG_20160616_081120.jpg


  • Moderator

    @bmaster001 After you follow Sebastian’s request to disable TPM all together, if it still is having trouble booting…

    I want you to try something. This is a bit self serving, but I’ve been working on a PXE less boot for the FOS engine (the software that runs on the target system that captures and deploys images). If you are willing to try, I would like you to build one and try to boot this device using a USB drive. If it doesn’t boot FOS then you are out of luck.

    I will send you a link to the image via IM. Of course I would be skeptical about some chap from the internet telling me to download and run something so the instructions for building it yourself are here: https://forums.fogproject.org/topic/7727/building-usb-booting-fos-image

    You can write the fos-usb.img file to usb using dd in linux or Win32DiskImager from sourceforge https://sourceforge.net/projects/win32diskimager The image creation tool need to be run with “Run as Administrator” to have access to write the image to USB. You need a small USB for this 256MB or larger will work. The last thing you need to do is edit the file in \boot\grub\grub.cfg on the flash drive with Windows Write or better notepad++ (not MS notepad) and change the very first line so the ip address points to YOUR fog server.

    Now insert this usb into this target computer and boot from it. At the grub menu pick the very last item to launch the debug kernel. After a few seconds you should see some text, press enter twice and you should be at a command prompt. If you get here, then we can run some debug commands.


  • Developer

    @bmaster001 Great you posted the BIOS settings pictures. Try disabling the TPM Support completely!


  • Senior Developer

    @george1421 I think it’s the boot file specifically.

    I don’t know which one is working.



  • @Wayne-Workman said in another init.xz issue:

    Can you boot it to a live linux disk successfully? If you can, what is the output of lsblk and lspci ? You could also turn up fogs kernel debug level so that maybe we see some errors.

    I wrote Ubuntu on a usb stick, and tried booting. When I choose “try ubuntu” from the grub menu, the screen goes black, and stays black. So that doesn’t seem to work very well…



  • @Tom-Elliott said in another init.xz issue:

    @bmaster001 based on this replied post, it would appear to me the file you’re currently using is pxelinux.0 and not undionly it snp

    I tried to put ipxe.efi in the filename, but that showed me the same boot-menu. When I disable uefi boot, it’s not even trying to network-boot. I get that boot-menu immediately after power-on. Nothing else is displayed.

    I’m pretty sure that pfsense is setup correctly (see screenshot). 0_1465995258878_IMG_20160615_144702.jpg


  • Moderator

    @bmaster001 I think what Tom’s asking is for you to…

    No that’s not the case here. The OP has to be getting ipxe.efi or iPXE would not boot. You can not boot a bios iPXE kernel on a uefi system. It has to be some flavor of .efi kernel.

    Tom: Would it say bzImage32 if fog sent the 32 bit version of FOS to the target? I still think there is something up with the hardware.


  • Senior Developer

    @bmaster001 based on this replied post, it would appear to me the file you’re currently using is pxelinux.0 and not undionly it snp



  • @Wayne-Workman said in another init.xz issue:

    @bmaster001 Then that means the kernel isn’t even loading. You could try a different boot file.

    Can you not put this computer into BIOS mode somehow? I know computers are beginning to come out that are UEFI only, but if this machine can be set to BIOS and works that way, that’d be the route I’d recommend.

    I tried disabling “uefi boot”: I then get some weird “boot menu” with no menu-items in it. I don’t really see any other option in the bios (maybe you see something on the screenshots that rings a bell?)

    Another boot file? Not sure what you mean… please treat me like a newbie :-)


  • Senior Developer

    Can you try the ipxe.efi or ipxe.pxe file as the filename/option 66?



  • Sorry to get stuck on this, but you are sure in pfsense that you have the next server pointint to your new FOG server?

    Very sure :) I get to the fog menu, and on our old server we added some items to the advanced part, and that menu-item didn’t show up with the newly installed fog. Also, see the following screenshot, where 10.1.6.51 is the ip of the new centos server:

    0_1465994251908_IMG_20160615_075122.jpg

    It appears that there are different hardware configurations for the different OS versions (disk size and such). I got the impression that the CPU also changed with the OS (WinCE vs WinPro). But maybe I was mistaken.
    That’s very well possible. I wasn’t involved in the selection of the hardware, so I don’t know about the options. I’m just the guy that tries to get the imaging working :-)



  • @bmaster001 Then that means the kernel isn’t even loading. You could try a different boot file.

    Can you not put this computer into BIOS mode somehow? I know computers are beginning to come out that are UEFI only, but if this machine can be set to BIOS and works that way, that’d be the route I’d recommend.


Log in to reply
 

506
Online

6.3k
Users

13.7k
Topics

129.2k
Posts