Unable to connect to tftp server.



  • I just moved a FOG server onto different hardware. The IP address remains unchanged.

    After restoring from the backup, attempting to deploy through the web interface gets me: Unable to connect to tftp server.

    Looking at the restore steps, I think I may have missed something. I’ll try that and check back here.



  • Its seemed like a silly thing that all the passwords must be the same :) but it actually worked … After changing all the passwords everything works like it should !!! god dam it !


  • group:cid:11:privileges:mods:members

    Same problem here Faith. I created my Ubuntu user as “fog,” which conflicts with Fog’s user “fog.” Thought I was keeping it simple o_O



  • This post is deleted!


  • [quote=“RuralIT, post: 320, member: 155”]I just moved a FOG server onto different hardware. The IP address remains unchanged.

    After restoring from the backup, attempting to deploy through the web interface gets me: Unable to connect to tftp server.

    Looking at the restore steps, I think I may have missed something. I’ll try that and check back here.[/quote]
    Hi guys.
    I had same problem a couple days ago… I resolve it.
    But, first of all, it was my fault. Because when I log in to my computer (also, it is my FOG server), everytime I see two different users.
    As like you guess, my user name and "fog"
    Then I closed this account for logging on, with this command.
    [I]sudo usermod -s / bin/false fog[/I]
    After one days, When I press to “start the deploy”, I always got same error [I]“Unable to Connect to TFTP Server”[/I].
    Now I cahenged the fog users shell, I can do everything what I want!
    May be it might help for someone… :)


  • Developer

    Great work :D



  • It worked. In a nutshell, my procedure for moving FOG to a new server was as follows:
    [LIST=1]
    []Install Ubuntu 10.04 LTS (server) on the new hardware, using whatever IP address DHCP offers.
    [
    ]Install FOG on the new hardware, making sure to configure FOG with the IP address that will get used. In my case, this was the IP of the old FOG server.
    []Copy images from the old server to the new.
    [
    ]Backup the database on the old server, restore it on the new.
    []Shutdown the old server or move it to a different IP address.
    [
    ]Move the new server to the old server’s IP address.
    []Set the password for the fog user to whatever FOG_TFTP_FTP_PASSWORD is on the new FOG server’s web interface.
    [
    ]Confirm that everything works as expected.
    [/LIST]



  • Cool. And as luck would have it, I’m in the position to try this out today. Fingers crossed.


  • Developer

    [quote=“JosephJ, post: 357, member: 156”]I just did something similar, but was on FOG .029. I copied the web root Fog server over and installed fog .029 on the new fog server. I then used the MYSQL create Fog database and import commands to bring in the backed up fog database (these instructions can be found in the Restoring Fog from Backup in theFog user guide.). The FOG linux user account should have the same password as the FOG_TFTP_FTP_PASSWORD in the FOG Settings in the Web UI. This is what I found to fix the que problem. Also make sure to put a blank .mntcheck file in the images folder. I then did the upgrade to Fog 0.32. I am testing out the system now, but all seems to be working. Changing the linux Fog user account password should be done with care.[/quote]

    Correct. The ‘fog’ users password MUST MATCH ‘FOG_TFTP_FTP_PASSWORD’

    To make sure they do:
    [LIST=1]
    []Get the value from FOG_TFTP_FTP_PASSWORD
    [
    ]SSH into your FOG server as root (google putty)
    []Type: passwd fog
    [
    ]Paste in the value from FOG_TFTP_FTP_PASSWORD (right click once on the console screen)
    [*]It will say ‘success’
    [/LIST]
    Be aware you might also need to update the password in Storage Management for that particular node.



  • I just did something similar, but was on FOG .029. I copied the web root Fog server over and installed fog .029 on the new fog server. I then used the MYSQL create Fog database and import commands to bring in the backed up fog database (these instructions can be found in the Restoring Fog from Backup in theFog user guide.). The FOG linux user account should have the same password as the FOG_TFTP_FTP_PASSWORD in the FOG Settings in the Web UI. This is what I found to fix the que problem. Also make sure to put a blank .mntcheck file in the images folder. I then did the upgrade to Fog 0.32. I am testing out the system now, but all seems to be working. Changing the linux Fog user account password should be done with care.


  • Developer

    The error ‘Unable to connect to tftp server’ is 100% related to being unable to connect to the TFTP FTP server and upload the PXE file.
    This error will be triggered if it 1) fails to connect to the FTP server, 2) fails to login.

    If the backup data has incorrect passwords in it, then there will defiantly be a problem.

    I would be updating all of your passwords to make 100% sure…



  • Just scheduled an image from a stock FOG 0.32 install. Unsurprisingly, it worked fine. So there must be something in the backup/restore process that I’ve munged.

    Is there an authoritative backup/restore procedure somewhere? That is something I’d really like to have in my pocket.

    In my case, I’m not even changing the IP address. So this should be as simple as it can get.



  • Blackout,

    Thanks for the explanation and suggestion. I’ve verified those details and logged in to the fog account using ftp. It works. The problem must lie elsewhere.

    The strange thing is that everything else works. Machines can PXE boot just fine, but scheduling a deploy using the web interface fails. What I mean by this is that, when the “Image all computers” button is pressed, there is a longer than normal pause (maybe two seconds) before the web interface complains:

    [CODE]None of the machines were able to be queued!

    [delld620-12] Unable to connect to tftp server.[/CODE]

    This is happening with FOG 0.32, with the backup data coming from a 0.30 server.

    I’ve wiped FOG from the new machine and am reinstalling it. I’ll confirm that it works from scratch (ie. adding a user, image, and workstation by hand before doing a test deploy). If that works, I can point the finger at something coming from the backup data.

    Mark


  • Developer

    The FTP details in your TFTP settings are not correct.

    FOG uses the user ‘fog’ to FTP the TFTP PXE files into place. The ‘fog’ users password will be different from your old setup.
    [LIST=1]
    []Go to: Web UI > Other Information > FOG Settings
    [
    ]Look for: FOG_TFTP_HOST, FOG_TFTP_FTP_USERNAME and FOG_TFTP_FTP_PASSWORD
    [*]Verify these details are correct
    [/LIST]



  • Just to be clear, I used FOGBackup.sh to generate the backup of the existing FOG server.



  • The restore instructions I’m following ([url]http://fogproject.org/wiki/index.php?title=Restoring_FOG_from_Backup[/url]) talk about removing/restoring the FOG stuff under www and opt directories. However, the backup I made doesn’t contain anything for those directories.

    Maybe the backup didn’t complete?


Log in to reply
 

376
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.