Kernel Panic on Quick Register



  • Hi All,

    Trunk version 7985

    I got a kernel panic when I tried to do a quick register with the following systems:

    • Optiplex 780 A6
    • Optiplex 780 A8
    • VM Hyper-V

    But the upload or download in unicast mode is working once I registered on the web management. Strange ?!

    I tried some kernels but the same.

    Here is the result of the following link http://x.x.x.x/fog/service/ipxe/boot.php?mac=xx

    #!ipxe
    set fog-ip x.x.x.x
    set fog-webroot fog
    set boot-url http://${fog-ip}/${fog-webroot}
    cpuid --ext 29 && set arch x86_64 || set arch i386
    goto get_console
    :console_set
    colour --rgb 0x00567a 1 ||
    colour --rgb 0x00567a 2 ||
    colour --rgb 0x00567a 4 ||
    cpair --foreground 7 --background 2 2 ||
    goto MENU
    :alt_console
    cpair --background 0 1 ||
    cpair --background 1 2 ||
    goto MENU
    :get_console
    console --picture http://x.x.x.x/fog/service/ipxe/bg.png --left 100 --right 80 && goto console_set || goto alt_console
    :MENU
    menu
    colour --rgb 0xff0000 0 ||
    cpair --foreground 1 1 ||
    cpair --foreground 0 3 ||
    cpair --foreground 4 4 ||
    item --gap Host is NOT registered!
    item --gap -- -------------------------------------
    item fog.reginput Perform Full Host Registration and Inventory
    item fog.reg Quick Registration and Inventory
    choose --default fog.reg --timeout 3000 target && goto ${target}
    :fog.reginput
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 keymap= web=x.x.x.x/fog/ consoleblank=0 debug rootfstype=ext42 loglevel=4 mode=manreg
    imgfetch init_32.xz
    boot || goto MENU
    :fog.reg
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 keymap= web=x.x.x.x/fog/ consoleblank=0 debug rootfstype=ext42 loglevel=4 mode=autoreg
    imgfetch init_32.xz
    boot || goto MENU
    :bootme
    chain -ar http://x.x.x.x/fog/service/ipxe/boot.php##params ||
    goto MENU
    autoboot
    

    I’m not an expert but the rootfstype is set to ext42 and I don’t know this file system.

    Hope it helps and thank for any help to fix the problem.

    Zaza


  • Senior Developer

    https://wiki.fogproject.org/wiki/index.php?title=Upgrade_to_trunk

    Follow the guide for the git method, dev-branch IS currently RC-1 on it.



  • @Tom-Elliott Thanks Tom how do I go about this? I’m very very new to Linux.


  • Senior Developer

    @tkindle83 Please try updating to rc-1.



  • @george1421 said in Kernel Panic on Quick Register:

    @Bob-Henderson Understand this is not an official comment, but if you are at a road block until the devs can resolve this issue, I have a way to hack around it.

    You need to have access to the linux console and edit the following file.
    /var/www/html/fog/lib/fog/bootmenu.class.php

    Search for rootfstype There should be two in that file. The first one is what we need to edit.

    It should look something like this

    $this->kernel = sprintf('kernel %s %s initrd=%s root=/dev/ram0 rw ramdisk_size=%s keymap=%s web=%s consoleblank=0%s rootfstype=ext4%s%s',
    

    Just insert a space between ext4%s%s making it look like this

    $this->kernel = sprintf('kernel %s %s initrd=%s root=/dev/ram0 rw ramdisk_size=%s keymap=%s web=%s consoleblank=0%s rootfstype=ext4  %s%s',
    

    Save the file and you should now be able to boot into the FOS kernel. Of course we should wait for an official fix, but this will get you going.

    Hello new to linux here, trying to get fog up and running in my Windows environment I have came across the Kernel Panic issue after installing a newer kernel to try to get my HP 600 G2’s to register. I tried to follow this solution however when i look at the BootMenu.class.php with vi and search for rootfstype nothing comes up so I’m at a big stand still here. Any help would be much appreciated.



  • 8036 as well. Thank for your work. Topic can be closed.

    Zaza.


  • Moderator

    Version @ 8034 appears to be working fine now, thanks



  • Trunk version 8030 not solving the problem.


  • Moderator

    Version @ 8030 and I too receive the kernel panic when selecting from the pxe menu, deploy tasks set from the web work



  • I ran into this same issue, just updated trunk to git 8022 (latest) and got the same kernel panic. I manually changed the file and was able to run though the host registration, but no host was registered at the server.


  • Senior Developer

    Pushed into current to have a space.


  • Moderator

    This post is deleted!


  • @george1421 Confirmed, that works. Gotta love spaces!


  • Moderator

    @Bob-Henderson Understand this is not an official comment, but if you are at a road block until the devs can resolve this issue, I have a way to hack around it.

    You need to have access to the linux console and edit the following file.
    /var/www/html/fog/lib/fog/bootmenu.class.php

    Search for rootfstype There should be two in that file. The first one is what we need to edit.

    It should look something like this

    $this->kernel = sprintf('kernel %s %s initrd=%s root=/dev/ram0 rw ramdisk_size=%s keymap=%s web=%s consoleblank=0%s rootfstype=ext4%s%s',
    

    Just insert a space between ext4%s%s making it look like this

    $this->kernel = sprintf('kernel %s %s initrd=%s root=/dev/ram0 rw ramdisk_size=%s keymap=%s web=%s consoleblank=0%s rootfstype=ext4  %s%s',
    

    Save the file and you should now be able to boot into the FOS kernel. Of course we should wait for an official fix, but this will get you going.



  • @george1421 Yep, that’s exactly what @Zaarin noticed in his first post. Looks like a fat finger kind of thing that we all do every once in a while.


  • Moderator

    @george1421 I may have found the issue with the menu. This is the output from http://192.168.1.88/fog/service/ipxe/boot.php note the rootfstype=ext42

    :fog.reginput
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 keymap= web=192.168.1.88/fog/ consoleblank=0 debug rootfstype=ext42 loglevel=4 mode=manreg
    imgfetch init_32.xz
    

  • Moderator

    @george1421 Issue confirmed with r7985.

    @Developers
    Console displays:

    Early console in setup code
    Kernel-panic...
    Unable to mount root fs on unknown-block(1,0)
    

    Cross linking same issue: https://forums.fogproject.org/topic/7686/kernel-panic-after-upgrade


  • Moderator

    I just updated my dev box to 7985, let me see if I can duplicate the error.



  • @Bob-Henderson Yes, right, I forget to mention that full register is not working as well.



  • Getting the same thing here, same version. Boots up, can image machines already registered in the UI, but if I attempt to quick register or full register, I get the

    Kernel panic - not syncing: VFS Unable to mount root fs on unknown-block(1.0) Kernel Offset : disabled


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.