Installing FOG on Debian



  • Having issues installing FOG.
    I get it to run but it is constantly stuck at Installing Package: Apache2
    I feel like it is something simple but not sure what it could be.
    Thanks!


  • Senior Developer

    @maveriick Just ask?



  • Last stupid question… How do I mark this solved?



  • Awesome!!! Thanks to all! I now have FOG installed… now i just have a few house keeping things i have to work on like getting my raid array to show up for storage.
    And then find the guide on getting started capturing etc…
    Once again Thank you all soo much !!!
    Rob


  • Moderator

    @maveriick

    The package is subversion on Debian.

    sudo apt-get update && sudo apt-get install subversion



  • Here is what it says now

    root@HRS-FOG:/home/rob# /etc/apt/sources.list
    bash: /etc/apt/sources.list: Permission denied
    root@HRS-FOG:/home/rob# cat /etc/apt/sources.list
    deb http://httpredir.debian.org/debian jessie main
    deb-src http://httpredir.debian.org/debian jessie main
    
    deb http://httpredir.debian.org/debian jessie-updates main
    deb-src http://httpredir.debian.org/debian jessie-updates main
    
    deb http://security.debian.org/ jessie/updates main
    deb-src http://security.debian.org/ jessie/updates main
    

    but i get this when I run sudo apt-get update && sudo apt-get install svn

    root@HRS-FOG:/home/rob# sudo apt-get update && sudo apt-get install svn
    Hit http://security.debian.org jessie/updates InRelease
    Ign http://httpredir.debian.org jessie InRelease 
    Hit http://security.debian.org jessie/updates/main Sources
    Hit http://httpredir.debian.org jessie-updates InRelease                       
    Hit http://security.debian.org jessie/updates/main amd64 Packages              
    Hit http://security.debian.org jessie/updates/main Translation-en              
    Hit http://httpredir.debian.org jessie Release.gpg                             
    Hit http://httpredir.debian.org jessie-updates/main Sources
    Get:1 http://httpredir.debian.org jessie-updates/main amd64 Packages/DiffIndex [3472 B]
    Get:2 http://httpredir.debian.org jessie-updates/main Translation-en/DiffIndex [1720 B]
    Hit http://httpredir.debian.org jessie Release                  
    Hit http://httpredir.debian.org jessie/main Sources
    Hit http://httpredir.debian.org jessie/main amd64 Packages
    Hit http://httpredir.debian.org jessie/main Translation-en
    Fetched 5192 B in 3s (1442 B/s)
    Reading package lists... Done
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    E: Unable to locate package svn
    

    Thank you all sooo much for the help!!!


  • Developer

    Well you still got the old CDROM repo entries while the CDs are probably not loaded anymore. You want to use the official online repos. Edit that file to make it look like this:

    deb http://httpredir.debian.org/debian jessie main
    deb-src http://httpredir.debian.org/debian jessie main
    
    deb http://httpredir.debian.org/debian jessie-updates main
    deb-src http://httpredir.debian.org/debian jessie-updates main
    
    deb http://security.debian.org/ jessie/updates main
    deb-src http://security.debian.org/ jessie/updates main
    

    Remove all the other stuff.



  • Here is the results.

    root@HRS-FOG:/home/rob# cat /etc/apt/sources.list                 
    # 
    
    # deb cdrom:[Debian GNU/Linux 8.4.0 _Jessie_ - Official amd64 DVD Binary-1 20160402-14:46]/ jessie contrib main
    # deb cdrom:[Debian GNU/Linux 8.4.0 _Jessie_ - Official amd64 DVD Binary-1 20160402-14:46]/Disk 2/ jessie contrib jessie main
    # deb cdrom:[Debian GNU/Linux 8.4.0 _Jessie_ - Official amd64 DVD Binary-1 20160402-14:46]/Disk 3/ jessie contrib jessie main
    
    deb cdrom:[Debian GNU/Linux 8.4.0 _Jessie_ - Official amd64 DVD Binary-1 20160402-14:46]/ jessie contrib main
    deb cdrom:[Debian GNU/Linux 8.4.0 _Jessie_ - Official amd64 DVD Binary-1 20160402-14:46]/Disk 2/ jessie contrib jessie main
    deb cdrom:[Debian GNU/Linux 8.4.0 _Jessie_ - Official amd64 DVD Binary-1 20160402-14:46]/Disk 3/ jessie contrib jessie main
    
    deb http://security.debian.org/ jessie/updates main contrib
    deb-src http://security.debian.org/ jessie/updates main contrib
    
    # jessie-updates, previously known as 'volatile'
    # A network mirror was not selected during install.  The following entries
    # are provided as examples, but you should amend them as appropriate
    # for your mirror of choice.
    #
    # deb http://ftp.debian.org/debian/ jessie-updates main contrib
    # deb-src http://ftp.debian.org/debian/ jessie-updates main contrib
    

    The upgarde to trunk directions are missing the second sudo. That is why I did not use it.
    Thanks,
    Rob


  • Developer

    @maveriick Seems like your /etc/apt/sources.list is corrupt. Please post what you get from cat /etc/apt/sources.list.

    As well you need to run sudo apt-get update && sudo apt-get install svn (see the second sudo command?) after we fixed your sources.list



  • OK, here is what I get when I go to Xterm and run sudo apt-get update && apt-get install svn
    root@HRS-FOG:~# sudo apt-get update && apt-get install svn
    E: Malformed line 8 in source list /etc/apt/sources.list (absolute dist)
    E: The list of sources could not be read.
    Being a Reforming windows Sys admin I am very open to open source and trying to learn.
    Thanks!!!


  • Moderator

    @maveriick You don’t need to install any of that stuff manually.

    You simply need to install svn, and then pull the trunk repo. Then the FOG installer will do everything else for you when you run it.

    There are step-by-step instructions in the upgrade to trunk article, here:
    https://wiki.fogproject.org/wiki/index.php?title=Upgrade_to_trunk



  • OK, feeling really stupid… Trying to install subversion. When I am trying to install pre-requisites i can not get them to install… I am such a Noob at Linux… Here is the guide i am using to get them installed. https://www.howtoforge.com/installing-apache2-with-php5-and-mysql-support-on-debian-wheezy It can not find Debian GNU/Linux 8.4.0 Jessie - Official amd64 DVD Binary-1 20160402-14:46 Haaaaaalp!!!



  • I use SVN subversion, it’s really simple.



  • @URfog said in Installing FOG on Debian:

    I can certainly say that there is no problem installing FOG 1.3.0 over Jessie

    Awesome! I will try that first AM.
    Use Git method?



  • I can certainly say that there is no problem installing FOG 1.3.0 over Jessie



  • I’ve never passed through 1.2.0, so I cannot help you with that release, but you can try the new one. If you have not installed any.



  • FOG 1.2.0 then will update to trunk.
    On 8.4.0 Debian



  • And what release of FOG? I’ve got now 1.3.0 r7945



  • @maveriick said in Installing FOG on Debian:

    I have it on Jessie… I am new to both Linux and FOG.
    I followed a guide but keep getting stuck

    Re-phrase… I am trying to install it on Jessie.



  • I have it on Jessie… I am new to both Linux and FOG.
    I followed a guide but keep getting stuck


Log in to reply
 

453
Online

38998
Users

10717
Topics

101747
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.