SOLVED Updating database ... freezed screen after upload task


  • As requested by the administrator, here is a new topic with my specific problem.

    On SVN 7695, there was no problem. It was possible to upload a new image on the server.

    After migrating (today is SVN 7863), but even after the first update after 7695, uploading is impossible.

    “Updating database… failed
    Reattempting to update database”
    –> The client reboot and the task begins again (because still active on the server).

    Linux version on the server: 14.04 LTS
    Seems the Mysql database is OK: i can connect through command line, and navigate through it.

    thanks for your help.


  • @Sebastian-Roth This is what I am seeing:
    Enter new UNIX password: Retype new UNIX password: passwd: password updated successfully
    Failed to get D-Bus connection: Operation not permitted
    Failed to get D-Bus connection: Operation not permitted
    Failed to get D-Bus connection: Operation not permitted
    Failed to get D-Bus connection: Operation not permitted
    Failed to get D-Bus connection: Operation not permitted
    Synchronizing state of mysql.service with SysV init with /lib/systemd/systemd-sysv-install…
    Executing /lib/systemd/systemd-sysv-install enable mysql
    Failed to get D-Bus connection: Operation not permitted
    Failed to get D-Bus connection: Operation not permitted
    Failed to get D-Bus connection: Operation not permitted
    Operation failed: No such file or directory
    Failed to get D-Bus connection: Operation not permitted
    Failed to get D-Bus connection: Operation not permitted
    Failed to get D-Bus connection: Operation not permitted
    Operation failed: No such file or directory
    Failed to get D-Bus connection: Operation not permitted
    Failed to get D-Bus connection: Operation not permitted
    Failed to get D-Bus connection: Operation not permitted


  • @Tom-Elliott For me, everything is ok now with 7959. I reran the installer as you asked.
    THX a lot for your help.

  • Moderator

    @nickkcsd Take a look at the installer logs in the same directory where the installer script is (fogproject/bin/error_logs/...).


  • @Sebastian-Roth I was able to test the MySQL database with the credentials setup in the .fogsettings and was successful. I checked the status of MySQL and it is running. I then restarted MySQL and re-ran the fog installer, still failing on “Setting up and starting MySQL”. I also checked what was in /var/www/fog/lib/fog/Config.class.php as well to make sure it matched. Any suggestions?

  • Moderator


  • @Sebastian-Roth I updated the password to match up and now when I re-run the installer it is failing on “Setting up and starting MySQL”. Unless what I am putting in the snmysqluser and snmysqlpass password fields are incorrect. How can I confirm if the mysql username and password are correct?

    Thanks

  • Moderator

    @nickkcsd Please re-read what Tom posted and make sure you match up all the passwords.


  • Hi,

    I am having the same issue after updating to 7959 on Ubuntu 15.10. I changed the password information in the .fogsettings to reflect the web GUI, same issue.

    Thanks


  • @hernani Change the .fogsettings file password thing to match what everything else has it stored as. Then rerun the installer. THe installer, now, reset’s the FOG User’s password every time the installer is run and it uses the value in the .fogsettings file to make sure it is maintained what the installer expects.


  • @Tom-Elliott
    Yes, i was reading this article in fact and isa comparing all this. The password is the same everywhere BUT in the config file of fog, i replaced the old password when i moved from 1.2 to SVN and at the end of password i put " instead of ’ for the password value… maybe it’s my fault… 😞


  • @hernani I’ve fixed the in_array error.

    That said, we have a wiki article about Troubleshooting FTP. I think it’s actually called: Troubleshoot FTP.

    https://wiki.fogproject.org/wiki/index.php?title=Troubleshoot_FTP

    The user is the linux user named fog and can be found in Storage Management->List All Nodes->Your relevant Node->Management Username and Management Password.


  • @Tom-Elliott i noticed that the image is upload in /tmp/MacAdress but is not moved to the final destination, so you’re probably right when you say it’s FTP issue.
    For doing FTP, same question: which account is used ‘fog’, ‘fogstorage’ (because we’ve got one node for our images)?

    This error is here now:
    [Wed Jun 01 11:27:04.814918 2016] [:error] [pid 50751] [client 172.16.40.27:61269] PHP Warning: in_array() expects parameter 2 to be array, null given in /var/www/html/fog/lib/client/fogclient.class.php on line 19
    [Wed Jun 01 11:27:04.819914 2016] [:error] [pid 50751] [client 172.16.40.27:61269] PHP Warning: in_array() expects parameter 2 to be array, null given in /var/www/html/fog/lib/client/fogclient.class.php on line 19


  • @hernani I’m thinking this is more a “FTP Login” issue as opposed to a database issue. The Database will only be updated after the FTP Upload happens.


  • @Tom-Elliott ok so it’s correct because i can explore the mysql database with a terminal using root and the password is ok in ./fogsettings.


  • @hernani Root is typically used.


  • @Tom-Elliott the ‘root’ created during the install of MySql or ‘fog’?


  • @hernani The database user is used.


  • @Tom-Elliott I’ve just updated to 7935. Same bug at the end of an upload task.
    My question is: what is this operation of “updating database”? Which user is used to to this operation?
    thx


  • @hernani I don’t know what the problem is/was all I can think it was from the node losing contact. The requests had a ridiculous timeout value which might cause the issue you were seeing. I’ve lowered the timeout to a slightly lower value, though it is still pretty long. It should, hopefully, give a better experience I hope.

265
Online

9.6k
Users

16.0k
Topics

147.9k
Posts