Dell PCs Can't Boot From Hard Drive - Press A Key to Reboot



  • Hi everyone,

    I’ve just installed FOG 1.2.0 on an Ubuntu 14.04 VM. It’s working great so far - I’ve already registered a host which is a lot further than what I was able to do yesterday. However, I have an issue where the systems won’t boot from the hard drive if nothing is pressed - it just says ‘Press a key to reboot’. I’ve done some research into this and I believe it’s something to do with the chainloader (you’ll have to forgive me - I am new to this).
    I’ve linked unidonly.kpxe to undionly.0 using:
    sudo ln -s -r undionly.kpxe undionly.0

    I’ve created the pxelinux.cfg folder:
    mkdir /tftpboot/pxelinux.cfg

    and the file /tftpboot/pxelinux.cfg/default, with:
    vi /tftpboot/pxelinux.cfg/default

    I’ve then written in the default file the following:

    DEFAULT vesamenu.c32
    MENU TITLE Fog Reimage Menu
    MENU COLOR TITLE 1;36;44 #ffffffff #00000000 std
    LABEL iPXE Boot
    MENU DEFAULT
    KERNEL ipxe.krn
    APPEND dhcp && chain http://10.1.0.102/fog/service/ipxe/boot.php?mac=${net0/mac}
    PROMPT 0
    TIMEOUT 3000

    Interestingly, I thought the timeout setting would cause the menu to not cancel out so fast (going by a Google result), but it hasn’t changed anything, which makes me think that FOG isn’t reading the pxelinux.cfg/default file for some reason.

    The only way to boot from the hard drive is to either press F12 at the beginning of the system booting and select the hard drive from the boot menu, or to press F8 whilst it’s loading from the network and then tell it to boot from the hard drive. I’ve read this: https://wiki.fogproject.org/wiki/index.php/Boot_looping_and_Chainloading and have tried adding the last section mentioned into my cfg/default file to no avail. Maybe I can’t just add it on and it needs to go somewhere specific? I’m not entirely sure.

    Any help with this would be greatly appreciated :)



  • @george1421 Upgrading to trunk has resolved this issue - thank you! :)



  • @Quazz Thanks! I’ve already done that (as per my initial message) so I should be good to go. I’ll update to trunk later this morning and then see how the booting into the hard drive from the fog menu issue goes.


  • Moderator

    @RobTitian16 Dnsmasq needs undionly.0 to boot. Just create a symbolic link to it like indicated on the wiki and then whenever you update FOG and it has PXE binaries updates the file will automatically be updated.



  • No - not discouraged at all! Thanks for the help!

    I’m currently using dnsmasq so I guess it’s a simple solution of going into that config file and ensuring that undionly.kpxe is the boot file (which I’m pretty sure it is anyway)? How would I go about unlinking undionly.kpxe to undionly.0? Or is it a case of redownloading undionly.kpxe and overwriting the one in the tftpboot folder?

    I’ll upgrade to Trunk later today if I can and see how it goes.


  • Moderator

    Well don’t be discouraged by this but you are going about this the entirely wrong way.

    First of all FOG 1.1.x and on doesn’t use this method any more. So if you try to set it up with pxelinx.0 you will get unpredictcable results. Well I can predict them, they will fail.

    For dhcp option 67 {boot file} you should now be using undionly.kpxe for bios systems and ipxe.efi for uefi systems.

    I can also tell you that if you intend to deploy win10, gpt disks, or uefi systems you will want to be on the trunk build of 1.2.0. Understand this is a development build so there are frequent updates (and a few bugs), but in the end you will be happier with the results. I would not continue down the route you have started since it is not supported and may not work without a lot of messing around.

    And with your booting to hard drive issue, it may be you exit action out of the fog menu. You can adjust this on a per device basis in 1.2.0 trunk.


Log in to reply
 

499
Online

39193
Users

10845
Topics

103221
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.