Gzip: stdin: not in gzip format... error on ubuntu server 12.04



  • Hi all…

    First of all im new to Linux so im struggling with the most basic stuff, but i guess you need to start somewhere right?..

    The error:

    after downloading fog_0.32.tar.gz from sourceforge using wget I can’t seem to unpack it using tar with the command “tar -xzf fog_0.32.tar.gz”. I get the error:

    Gzip: stdin: not in gzip format
    tar: Child returned status 1
    tar: error is not recoverable: exiting now

    what i have:

    I have a vmware set up where i have installed a ubuntu server 12.04.

    What i have tried:

    I tried starting the tar command with sudu - did nothing
    Tried to install updates with the command “sudo apt-get update” and then run the tar command- did nothing
    Tried to install Build essentials using the command “sudo apt-get install build-essential” and then run the tar command - did nothing

    I have downloaded the same tar file from sourceforge onto my windows 7 and unpacked it with winrar which went OK

    I have reinstalled my ubuntu server and tried the above- did nothing

    I have been on the net for hours to find a solution but from what i can see the error can mean anything. but i really don’t see what im missing…

    I need some help here… im at a loss…

    And since i condsider this a learning experince please don’t give me workaround…atleast not without and explenation as to why its not working… else i won’t learn anything…

    Thanks!!

    Casper



  • Just to help out my fellow Foggers (couldn’t help myself) who might have the same issues this is what i did.

    The problem was indeed that i didn’t have have vmware tools installed… I stopped trying to get that installed from VMware and tried virtualbox instead where i found solution.

    Allso i went from Ubuntu to Fedora so this works for fedora …

    In order to to install the VirtualAdditions in Fedora i used this guide:

    [url]http://www.if-not-true-then-false.com/2010/install-virtualbox-guest-additions-on-fedora-centos-red-hat-rhel/[/url]

    i found though that i need to do this step again after i completed the guide:

    [COLOR=#d8d8d8][COLOR=#0000ff][B]mkdir[/B] /media/VirtualBoxGuestAdditions [B]mount[/B] -r /dev/cdrom /media/VirtualBoxGuestAdditions[/COLOR][/COLOR]
    [COLOR=#d8d8d8][COLOR=#000000]Remember to do “yum install bzip2” because it would be needed. I my have forgot the name but when you try and install VG it will complain and give you the correct name… [/COLOR][/COLOR]
    [COLOR=#d8d8d8] [/COLOR]
    [COLOR=#d8d8d8][COLOR=#000000]Hope this helped… [/COLOR][/COLOR]
    [COLOR=#d8d8d8] [/COLOR]



  • thanks for your help chad… im not going through any proxies…

    I will try to retrive the tar.gx file in another way… ftp or something…

    again thanks for your help!


  • Moderator

    most likely. if you are going through a proxy or web filter, you might try using ftp, https, or sneakernet.



  • Hi Chad,

    sorry for my late answer :) busy busy busy…

    I tried the checksum thing and go ff911abc07ff6f714f21c2829192aeb so i guess I have a corrupt download right?


  • Moderator

    I just found the md5 hash info on the sourceforge download page. You have to click the cirlce with the [I]i [/I] in it to view details. the hash matches what I posted. You can check yours by doing
    [CODE]md5sum fog_0.32.tar.gz[/CODE] and see what you get.


  • Moderator

    for my download: md5sum = 45b323d4150690b9c1aa8288c33830c9 fog_0.32.tar.gz


  • Moderator

    just try to gunzip it, then untar it.

    [CODE]gunzip fog_0.32.tar.gz[/CODE]

    should give you fog_0.32.tar file

    [CODE]tar xzvf fog_0.32.tar[/CODE]

    should untar to the current working directory.



  • atlast someone answers!! thank you :)

    Im not that experinced with all this Linux stuff but as i see it there are no MD5…

    I have tried to download the file againg but not without deleting the original first… I don’t know if Ubuntu does any thing “smart” if you want to download the same file again without deleting the one you downloaded before… do you know?

    I must say thought that the download went pretty quick but i am on a company line with 50/50 Mbits and its only around 35-45 in size so… i did check the size because i did have the same concern you mention but i couldn’t see any real difference in filesize… i suspect it will never be spot on…


  • Moderator

    silly question, but did you try to download the file again. Maybe your tarball is corrupt. check the size and if a MD5 hash is provided on the download site, you can check that also.



  • can no one help me?? it should be really easy and quick to recreate in a virtual box



  • ok i don’t get why this isn’t working… not i have tried with Debian with everything as above and it did nothing. I even tried to do it like root and still the same error… christ…



  • I get the same error with a fresh debian install…



  • could it be because im using 64 bit ubuntu server?



  • Im gonna try a Debian installation instead and see if that fairs better…


Log in to reply
 

354
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.