unable to boot HP z240 in UEFI



  • Hi there,

    We are trying to boot a HP z240 from iPXE to Fog, in UEFI mode.
    It downloads the bzImage and Init.xz, but freezes after that.

    I am on version 4.5.3 of the bzImage kernel; but I am unable to pinpoint the exact problem.
    I assume it is a kernel panic… but who knows?


  • Moderator

    @csurepair You should really start your own thread because the conditions could be different.

    Things that we would need to know is the version of FOG you have installed (on or about the cloud on the management home page).

    What is your dhcp server?

    Is the HP in uefi or bios (legacy) mode?

    Since you are getting to the download of bzImage, it probably safe to assume you have the correct iPXE kernel loaded into dhcp option 67.

    Are you using dnsmasq in your environment?



  • We are having this same exact issue when attempting to boot Z240’s. Has there been any progress with addressing this? We can get around it somewhat by manually registering the workstations but that really isnt a soulution.

    Any config hacks/bios tweaks/kernal updates for the Z240 would be greatly aptreatiated.

    Thanks all!


  • Developer

    Some (minor) news on this. Talked to someone on the iPXE IRC channel and it seems to not be a known issue and there is no special iPXE UEFI video foo magic switch that we can use.

    Quoting some parts of the chat here:

    me: Hey, I am wondering if anyone ever saw a linux kernel chainloaded from iPXE not showing any output - this is happening for us on a HP z240 (UEFI)
    me: The kernel seems to boot up fine (system comes up properly) but not displaying anything on the console/screen!
    ipxe: do you have any framebuffer devices enabled, have you tried something like vga=791 ?
    ipxe: maybe an dmesg dump could sheed some light on what the issue might be?
    me: tried video=efifb but no change. Thanks for the suggestion on dmesg… will check that out
    ipxe: I’m assuming that efifb implementation in the HP EFI firmware is broken (like most of the rest of the HP firmware implementation)
    ipxe: (this is based on the number of problems reported about HP boxes in this channel)
    me: just wondered if there are any special ipxe options for UEFI video/fb?
    ipxe: indeed not, there is not much in ipxe to do efi configurations, the only thing ipxe specific i can think of is enabling the ipxe console which supports an background image. (so as long as you are not seeing an backround image in ipxe you should be “safe”)

    FOG is not doing any background image stuff if tasks are scheduled - not using the iPXE console command either I think. So this shouldn’t be an issue. Although I am wondering if the menu is working fine when there is no task scheduled, @abos_systemax?!?!

    note to myself: dmesg dump could help in finding the issue! So try booting in debug mode and connect via SSH to get dmesg output!


  • Developer

    @abos_systemax Can you please try the USB key in a different UEFI PC? Just to see if it is really screwed or what. Definitely good to be prepared with a known good USB key to boot from for when new z240’s coming in. Really looking forward to hear if you can boot other machines with it and how we go on the new ones in the future.



  • @Sebastian-Roth

    I used the command as stated above (dd, on linux).
    However; I can no longer test the devices because they really had to be shipped to the customer.

    For now this thread is solved (it ‘works’), but as soon as I can get my hands on a new device; I will test the ISO mentioned above.

    Thanks all for the support!


  • Developer

    @abos_systemax Are you sure you used dd to write the ISO to your USB key? Don’t use other tools than dd or rawrite32 if on windows! Did you dump it to the first partition (of=/dev/sdb1)? Need to go straight onto the disk (destroying any data and the partition table!): dd if=debug_v2.iso of=/dev/sdb

    I just tried the ISO on a Lenovo x230 laptop, set to UEFI only, boots perfectly! GRUB rescue mode usually means that the GRUB modules are missing or not found. Possibly the ISO download was corrupt? Should be about about 60MB in size and md5sum is: 2d637e97e85c96f553da7f8436c5862c


  • Moderator

    @abos_systemax Here is a bit longer way to get to a grub bootable (FOS-L) usb. https://forums.fogproject.org/topic/6532/usb-boot-target-device-into-fog-os-live-fosl-for-debugging/19

    Follow the method #4 option.



  • @Sebastian-Roth
    I must be doing something wrong, but this ISO does not create a bootable USB stick (in fact, the dd command renders my USB completely useless)…

    As far as I can see in the root of the stick, is that I am missing the BOOTX64.efi file, does that have to be created with ‘make’?

    – edit: the USB sticks boots into Grub Rescue mode now, but booting to bzImage and init.xz results into unknown filesystem errors


  • Developer

    @abos_systemax Thanks again for the quick response. Then I guess I am lost for now. Will contact the iPXE developers to see what they might know about it. Most probably this won’t be before the weekend I’m afraid.

    @george1421 said:

    … efi_gop, efi_uga … It might be interesting to see if usb booting into FOS-L environment provided any video output.

    Yeah, I remember those GRUB modules were needed for UEFI machines. Definitely a good idea to check out if booting the kernel via GRUB makes a difference. Please download debug_v2.iso and dump it to your USB key (dd if=debug_v2.iso of=/dev/sdX). Do you see anything on screen after selecting 64 bit from the GRUB menu?


  • Moderator

    @Sebastian-Roth said in unable to boot HP z240 in UEFI:

    So we are back to this being an ipxe-to-kernel-handoff problem as it does not seem to be an issue when booting the same kernel from USB! You were right and I shall listen to what you say! :-)

    What, wait, what did I say. I have an idea it was really brilliant, but I think I missed it ;-)

    (just a lucky choice of words on my part, i fear)

    I remember when I was documented the FOS_L grub boot drive. https://forums.fogproject.org/topic/6532/usb-boot-target-device-into-fog-os-live-fosl-for-debugging I had to enter these commands into grub to get the video to work [insmod efi_gop, efi_uga, font]. I think I had a black screen to. Maybe it WAS working. It might be interesting to see if usb booting into FOS-L environment provided any video output.



  • @Sebastian-Roth

    none of the kernel options above yielded other results than no kernel options at all


  • Developer

    @abos_systemax Wow, great finding! I am wondering if other people who have similar issues are also just not seeing anything on screen or if it really hangs. Searching for an explanation on the net I found those two things: https://bugzilla.redhat.com/show_bug.cgi?id=496134 and https://www.kernel.org/doc/Documentation/fb/efifb.txt

    Can you please try adding video=efifb (and the various variations like video=efifb:mini) as the host’s kernel parameter option?

    @george1421 said:

    … transition between iPXE and bzImage

    So we are back to this being an ipxe-to-kernel-handoff problem as it does not seem to be an issue when booting the same kernel from USB! You were right and I shall listen to what you say! :-)



  • @george1421 This is acceptable for the devices at this stage. The Task management window actually displays the current task status so that is ‘enough’ vision for us.

    Although i’d be happy to help in the debug process, these 3 devices really have to go asap; so maybe we’d be able to run some more tests tomorrow, or else we have to wait till new machines get ordered.


  • Moderator

    @abos_systemax Well that is interesting. In uefi mode there is no video output from the kernel, but actually it is working.

    I had a similar experience with a different project where we attempted to uefi boot a linux kernel from a usb drive and use grub as a boot loader. The system would run but there was no output form the kernel on the console.

    This kind of sounds like a buggy firmware issue or the bzImage doesn’t have the proper kernel level drivers for interacting with this HP video controller (I doubt).

    I guess you have to decide is this acceptable to you (working but no video) or try to continue to debug this problem.



  • I’ve noticed the weirdest things of all: The Capture task is actually running while the display stays black.
    So, in fact the kernel and init.xz is just running as usual, but the display is not displaying anything

    :edit: the display is not completely Black, it is ‘frozen’ in the iPXE output; so the last data displayed is

    bzImage…OK
    Init.xz…OK



  • Hi @Sebastian-Roth
    I’ve tried the bzImage_epk with the specified host settings, but I still receive no messages; only ‘bzImage…OK!, init.xz…OK!’ and then nothing



  • @Sebastian-Roth
    Same goes for your responses. We are very happy with your quick responses.

    Sadly, I just got kicked out of the company because we’re closing for the night. But I will try the suggested option when I’m back tomorrow. Will post back as soon as I can.


  • Developer

    @abos_systemax said:

    Did that, received the same output as when I booted to it from USB

    Ok, then I need a bit more time to think about the next debugging steps. Thanks for being extremely responsive so far. Makes it a lot easier when I don’t have to wait days for answers and pictures. From what I see this is not an issue with the handoff from iPXE to the kernel as we see the very early debug messages…

    Here is another quick one I just remembered. Using one of the mentioned debugging kernels (or maybe bzImage_epk found in the same gdrive) you should be able to enable the so called early print messages in the kernel by adding earlyprintk=efi to the host kernel parameter settings field. Any more output with this?



  • @Sebastian-Roth said in unable to boot HP z240 in UEFI:

    @abos_systemax Can you please try the mentioned old/bzImage_ad via PXE boot? So instead of copy it to the USB key you put it onto your FOG server (/var/www/fog/service/ipxe/bzImage). Rename the current bzImage yo sou can easily switch back later on. Leave DEBUG options on.

    Did that, received the same output as when I booted to it from USB


Log in to reply
 

460
Online

38710
Users

10539
Topics

99781
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.