Can't connect to TFTP



  • Hi,
    I’ve looked around the forum and tried all suggestions. This is fog_0.32 on a centos 6.2_x64.
    Everything appears ok. However the front page says “unable to connect to XXXX Storage Node” under disk management.
    I’ve changed:

    1. the password for the linux user fog
    2. checked to make sure its the same in /var/www/html/fog/commons/config.php
    3. checked to make sure the TFTP password is the same under other information > fog settings

    I’ve restarted the services, ensure that iptables are off and selinux is disabled although I do have both configured for fog.
    I’ve checked that I can log in with putty to the tftp server and with filezilla for the ftp server and all appears OK. There are no errors in the logs and I still can’t connect. Im running out of ideas and was wondering if anybody has managed to get fog_0.32 up and running under Redhat 6.2, Centos 6.2 or Scientific Linux 6.2

    Cheers,
    Louis



  • [LIST=1]
    []Storage Management --> All Storage Nodes and click on the storage node that doesn’t display in the landing page
    [
    ]Make sure the IP address matches the address of wherever it is being stored
    [/LIST]

    Had this same issue today and that is how i fixed mine



  • Tell me more about your setup.
    is the Storage node on the same machine as fog? or is it an external storage node?

    In my case, mine is external and it says “[URL=‘http://192.168.1.63/fog/management/index.php?node=hwinfo&id=1’]Failed to connect to DefaultM[/URL]ember” on my home page.
    So although I dont get the information regarding disk space to show on the home /dashboard, everything else still works.

    Found this on the wiki:
    [QUOTE]

    [LIST]
    [*][B]3.[/B] Edit your storage-node definition:
    [/LIST]
    … After that your “[B]Disk Information[/B]” (Free / Used / Total) at the dashboard may not be correct anymore. Edit the file [B]freespace.php[/B]in your web-root (/var/www/fog/status/):
    define( “SPACE_DEFAULT_STORAGE”, “/home/fog/images/” );
    [/QUOTE]
    [url]http://www.fogproject.org/wiki/index.php/Change_NFS_location[/url]



  • Got to admit that I’m stuck here. Tried everything. Reinstalled, deleted database. It all goes in. Log onto web gui and can’t connect to default storage node. All passwords, encrypted or not confirmed the same but it still doesn’t work.



  • [CODE]define( “IS_INCLUDED”, true );
    define( “TFTP_HOST”, “192.168.1.63” );
    define( “TFTP_FTP_USERNAME”, “fog” );
    define( “TFTP_FTP_PASSWORD”, “password” );
    define( “TFTP_PXE_CONFIG_DIR”, “/tftpboot/pxelinux.cfg/” );
    define( “TFTP_PXE_KERNEL_DIR”, “/tftpboot/fog/kernel/” );
    define( “PXE_KERNEL”, “fog/kernel/bzImage” );
    define( “PXE_KERNEL_RAMDISK”, 127000 );
    define( “USE_SLOPPY_NAME_LOOKUPS”, “1”);
    define( “MEMTEST_KERNEL”, “fog/memtest/memtest” );
    define( “PXE_IMAGE”, “fog/images/init.gz” );
    define( “PXE_IMAGE_DNSADDRESS”, “192.168.1.105” );
    define( “STORAGE_HOST”, “192.168.1.63” );
    define( “STORAGE_FTP_USERNAME”, “fog” );
    define( “STORAGE_FTP_PASSWORD”, “password” );
    define( “STORAGE_DATADIR”, “/images/” );
    define( “STORAGE_DATADIR_UPLOAD”, “/images/dev/” );
    define( “STORAGE_BANDWIDTHPATH”, “/fog/status/bandwidth.php” );
    define( “CLONEMETHOD”, “ntfsclone” ); // valid values partimage, ntfsclone
    define( “UPLOADRESIZEPCT”, 5 );
    define( “WEB_HOST”, “192.168.1.63” );
    define( “WEB_ROOT”, “/fog/” );
    define( “WOL_HOST”, “192.168.1.63” );
    define( “WOL_PATH”, “/fog/wol/wol.php” );
    define( “WOL_INTERFACE”, “eth1” );
    define( “SNAPINDIR”, “/opt/fog/snapins/” );
    define( “QUEUESIZE”, “10” );
    define( “CHECKIN_TIMEOUT”, 600 );
    define( “MYSQL_HOST”, “localhost” );
    define( “MYSQL_DATABASE”, “fog” );
    define( “MYSQL_USERNAME”, “root” );
    define( “MYSQL_PASSWORD”, “” );
    define( “DB_TYPE”, “mysql” );
    define( “DB_HOST”, MYSQL_HOST );
    define( “DB_NAME”, MYSQL_DATABASE );
    define( “DB_USERNAME”, MYSQL_USERNAME );
    define( “DB_PASSWORD”, MYSQL_PASSWORD );
    define( “DB_PORT”, null );
    define( “USER_MINPASSLENGTH”, 4 );
    define( “USER_VALIDPASSCHARS”, “1234567890ABCDEFGHIJKLMNOPQRSTUVWZXYabcdefghijklmnopqrstuvwxyz_hB()^!” );
    define( “NFS_ETH_MONITOR”, “eth0” );
    define(“UDPCAST_INTERFACE”,“eth0”);
    define(“UDPCAST_STARTINGPORT”, 63100 ); // Must be an even number! recommended between 49152 to 65535
    define(“FOG_MULTICAST_MAX_SESSIONS”, 64 );
    define( “FOG_JPGRAPH_VERSION”, “2.3” );
    define( “FOG_REPORT_DIR”, “./reports/” );
    define( “FOG_THEME”, “blackeye/blackeye.css” );
    define( “FOG_UPLOADIGNOREPAGEHIBER”, “1” );
    define( “FOG_VERSION”, “0.32” );
    define( “FOG_SCHEMA”, 23);
    DEFINE(‘BASEPATH’, rtrim($_SERVER[‘DOCUMENT_ROOT’], ‘/’) . rtrim(WEB_ROOT, ‘/’));
    ?>
    [/CODE]



  • You can always change the password in the Web GUi.
    goto your fog page in the web browser and goto the big “?” icon at the top right. (Other Information)
    Then choose Fog Settings on the right side.
    Scroll down and enter your password there and save it.
    [ATTACH=full]119[/ATTACH]
    Trial and error will win every time, I had to install fog 6 times before I got it right. When in doubt, start over.

    [I]The more difficult something becomes, the more rewarding it is in the end. ~ Big Fish (Movie)[/I]

    [url="/_imported_xf_attachments/0/119_fogtftp.JPG?:"]fogtftp.JPG[/url]



  • I’m new to FOG, but I think your problem is the FTP/TFTP password. This isn’t the password you use to log onto the FOG web UI. FTP and TFTP pass usernames and passwords as clear text. This can be pulled out of a sniffed packet or thru several other means. To prevent this, the password included in the config.php (accessible within the web UI, as well, under Other Information/FOG Settings) is actually the public key string produced from running the password against an encryption algorithm that uses a private key that’s programmed into the FOG system. Should you’re interested, you can change that key to guaranty privacy, but that requires recompiling the FOG system code.

    So to generate the text string to enter into the password field, you have to extract a Windows program and at least one DLL from the FOG tarball. I found it to be incredibly odd that they would included a Windows executable in the LINUX file, and it’s not available in the same place from which the FOG Windows client can be downloaded, but whatever…

    Here are the posted instructions for using the tool - called FOGCrypt.exe - which I didn’t exactly follow:

    [url]http://www.fogproject.org/wiki/index.php/FOGCrypt[/url]

    Instead, I downloaded FOG from the FOG homepage and used 7zip to open the file, then found FOGCrypt and extracted it and the included DLL(s) to some temp dir. I didn’t bother to alter the source code with my own private key - I just used the one they include - for now anyway.

    Run FOGCrypt.exe against your password and store the program’s output in the password field in config.php.

    Jim Graczyk



  • any chance that somebody could post up their config with regards to what their tftp settings are in both:
    /fog/commons/config.php & other seetings.

    things driving me round the bend now. I just can’t see anything wrong.

    [B]my config.php[/B]

    define( “IS_INCLUDED”, true );
    define( “TFTP_HOST”, “192.168.254.11” );
    define( “TFTP_FTP_USERNAME”, “fog” );
    define( “TFTP_FTP_PASSWORD”, “hello123” );
    define( “TFTP_PXE_CONFIG_DIR”, “/tftpboot/pxelinux.cfg/” );
    define( “TFTP_PXE_KERNEL_DIR”, “/tftpboot/fog/kernel/” );
    define( “PXE_KERNEL”, “/tftpboot/fog/kernel/bzImage” );
    define( “PXE_KERNEL_RAMDISK”, 127000 );
    define( “USE_SLOPPY_NAME_LOOKUPS”, “1”);
    define( “MEMTEST_KERNEL”, “/tftpboot/fog/memtest/memtest” );
    define( “PXE_IMAGE”, “/tftpboot/fog/images/init.gz” );
    define( “PXE_IMAGE_DNSADDRESS”, “” );
    define( “STORAGE_HOST”, “192.168.254.11” );
    define( “STORAGE_FTP_USERNAME”, “fog” );
    define( “STORAGE_FTP_PASSWORD”, “hello123” );
    define( “STORAGE_DATADIR”, “/fogimages/” );
    define( “STORAGE_DATADIR_UPLOAD”, “/fogimages/dev/” );
    define( “STORAGE_BANDWIDTHPATH”, “/fog/status/bandwidth.php” );
    define( “CLONEMETHOD”, “ntfsclone” ); // valid values partimage, ntfsclone
    define( “UPLOADRESIZEPCT”, 5 );
    define( “WEB_HOST”, “192.168.254.11” );
    define( “WEB_ROOT”, “/fog/” );
    define( “WOL_HOST”, “192.168.254.11” );
    define( “WOL_PATH”, “/fog/wol/wol.php” );
    define( “WOL_INTERFACE”, “eth0” );
    define( “SNAPINDIR”, “/opt/fog/snapins/” );
    define( “QUEUESIZE”, “10” );
    define( “CHECKIN_TIMEOUT”, 600 );
    define( “MYSQL_HOST”, “localhost” );
    define( “MYSQL_DATABASE”, “fog” );
    define( “MYSQL_USERNAME”, “XXXXXXXX” );
    define( “MYSQL_PASSWORD”, “XXXXXXXXX” );
    define( “DB_TYPE”, “mysql” );
    define( “DB_HOST”, MYSQL_HOST );
    define( “DB_NAME”, MYSQL_DATABASE );
    define( “DB_USERNAME”, MYSQL_USERNAME );
    define( “DB_PASSWORD”, MYSQL_PASSWORD );
    define( “DB_PORT”, null );
    define( “USER_MINPASSLENGTH”, 4 );
    define( “USER_VALIDPASSCHARS”, “1234567890ABCDEFGHIJKLMNOPQRSTUVWZXYabcdefghijklmnopqrstuvwxyz_hB()^!” );
    define( “NFS_ETH_MONITOR”, “eth0” );
    define(“UDPCAST_INTERFACE”,“eth0”);
    define(“UDPCAST_STARTINGPORT”, 63100 ); // Must be an even number! recommended between 49152 to 65535
    define(“FOG_MULTICAST_MAX_SESSIONS”, 64 );
    define( “FOG_JPGRAPH_VERSION”, “2.3” );
    define( “FOG_REPORT_DIR”, “./reports/” );
    define( “FOG_THEME”, “blackeye/blackeye.css” );
    define( “FOG_UPLOADIGNOREPAGEHIBER”, “1” );
    define( “FOG_VERSION”, “0.32” );
    define( “FOG_SCHEMA”, 23 );
    DEFINE(‘BASEPATH’, rtrim($_SERVER[‘DOCUMENT_ROOT’], ‘/’) . rtrim(WEB_ROOT, ‘/’));



  • is there any special requirements for the storage node root or tftp server root? ie any permissions other than fog:fog 775


Log in to reply
 

366
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.