Advanced Menu Issue(s)



  • Okay, here’s another one for you.

    Whenever we try to access the Advanced Menu (Login) or simply Advanced Menu, we received either the following response or are sent straight back to the first boot menu:

    Could not boot: Operation canceled (http://ipxe.org/0b2ce0a0)
    Could not boot: Operation canceled (http://ipxe.org/0b2ce0a0)
    Chainloading failed, hit 's' for the iPXE shell; reboot in 10 seconds
    

    How would one go about even starting to debug something like that?

    OS version: CentOS 7
    Apache version: 2.4.6
    Fog version: trunk via Wiki
    Revision: 7609
    Hardware: VMware / vSphere


  • Developer

    @TreyBentley if you have any trouble with resolving fog kernel panics, just start a new thread and we’ll help you out.



  • @Junkhacker,

    I’m sorry. It is indeed password protected; with and without that checkbox checked, ironically. We’ll live with that for now. Thanks. At least that was that simple. Now, time to go researching kernel panic issues.


  • Developer

    @TreyBentley i’m pretty sure that choosing most of the options on the first menu require logging in anyway



  • @Junkhacker,
    Yes, but I didn’t find that to be password protected…


  • Developer

    @TreyBentley have you tried “Hide Menu” in FOG PXE Boot Menu Configuration ?



  • @Junkhacker, no problem.

    The goal is for the computer to pxe boot to a menu where the only option is to Boot to hard drive. However, if ESC (or other assigned hotkey) is pressed, then the Login Screen appears. After a Tech enters valid credentials, they’ll go to the Advanced Menu, where they can access the other, pre-defined menu items, like Host Registration, Quick Image, etc.


  • Developer

    these features are pretty new and i’m not sure how documented they are. have you checked the wiki? perhaps i could help you if you told me what your goal was.



  • @Junkhacker , Well, yeah, nothing is there; but I didn’t think that would matter when I gave fog.reginput’s “Menu Show with” either Advanced Options or Advanced Login Required. Obviously I’m not understanding the boot menu configurations properly yet. I thought placing those with one of those options would populate the Advanced Menu. If not, where’s me some good documentation on it? ^_^


  • Developer

    @TreyBentley looks like you don’t actually have a menu created. what is listed in your advanced menu field in fog settings?



  • @Sebastian-Roth Ich Idiot ;)… stupid me, copy & paste issue :D




  • Developer

    @x23piracy you need to check the values in your advanced menu settings. there was a field sanitization issue that’s been resolved, but you may have invalid data saved. check what should be your “&” symbols



  • @Junkhacker hmmm no really the same:

    but i tried advanced some hours ago and could remember that i also had error with it, i just thougth its the same.

    alt text


  • Developer

    @Andy-Abplanalp that’s what i wanted to see, if it was the sanitization issue.


  • Developer

    @Junkhacker correct me if I’m wrong but wouldn’t 7671 be after @Tom-Elliott fixed the sanitization fields? I had this issue as well and just went to my Advanced menu and clicked “save” to update it. Cleared out the ampersand issue for me and started working right away.


  • Developer

    @x23piracy Not sure what you are trying to achieve with the first four lines of your menu script. Removing those make the menu work for me instantly!


  • Developer

    @x23piracy are you seeing the exact same error as @TreyBentley ?



  • Hi,

    i have pretty the same issue with 7671, with older trunk versions i could use my old menu, since latest trunk update its broken for me.
    This is my old menu:

    isset ${userID} && goto do_me || goto MENU
    :do_me
    initrd http://${fog-ip}/iso/win7_dialog.iso
    chain memdisk iso raw || goto MENU
    :MENU
    menu
    colour 0
    cpair 0
    colour --rgb 0x004b93 3
    colour --rgb 0xffffff 2
    cpair --foreground 2 --background 4 1
    cpair --foreground 2 --background 3 2
    cpair --foreground 3 --background 4 3
    item --gap -- Verder Scientific - PXE Boot Menu - JOS IT
    item --gap --
    item bootlocal Festplatte booten
    item --gap Betriebssystem installieren
    item --key 7 win7 Windows 7 x64 Vollautomatisch! PE 4.0
    item --key 2 win72 Windows 7 x64 Festplatten-Dialog PE 4.0
    item --key 3 win73 Windows 7 x64 Festplatten-Dialog PE 5.0
    item --gap Partition/Image/Backup
    item --key b acronis2014 Acronis True Image 2014
    item --key c acronis20142 Acronis True Image 2014 PE
    item --key r acronis20143 Acronis True Image 2014 PE RT
    item --key p easeuspms EaseUS Partition Master Server
    item --gap Password/Recovery/Restore/Repair
    item --key e erd2005 ERD Commander Windows XP
    item --key d dart7 DaRT 7.0 Windows 7 Server 2008 R2
    item hostinfo Computer-Informationen
    item shell iPXE Shell
    item --gap --
    item return<---
    choose --default bootlocal --timeout 60000 target && goto ${target}
    :bootlocal
    sanboot --no-describe --drive 0x80 || goto MENU
    :win7
    initrd http://${fog-ip}/iso/win7.iso
    chain memdisk iso raw ||
    goto MENU
    :win72
    initrd http://${fog-ip}/iso/win7_dialog.iso
    chain memdisk iso raw ||
    goto MENU
    :win73
    initrd http://${fog-ip}/iso/win7pe5_dialog.iso
    chain memdisk iso raw ||
    goto MENU
    :win74
    chain -ar ${boot-url}/service/ipxe/advanced.php?login=1 ||
    goto MENU
    :acronis2013
    initrd http://${fog-ip}/iso/acronis2013.iso
    chain memdisk iso raw ||
    goto MENU
    :acronis2014
    initrd http://${fog-ip}/iso/acronis2014.iso
    chain memdisk iso raw ||
    goto MENU
    :acronis20142
    initrd http://${fog-ip}/iso/acronis2014pe.iso
    chain memdisk iso raw ||
    goto MENU
    :acronis20143
    initrd http://${fog-ip}/iso/acronis2014pert.iso
    chain memdisk iso raw ||
    goto MENU
    :easeuspms
    initrd http://${fog-ip}/iso/easeuspms.iso
    chain memdisk iso raw ||
    goto MENU
    :erd2005
    initrd http://${fog-ip}/iso/erd2005.iso
    chain memdisk iso raw ||
    goto MENU
    :dart7
    initrd http://${fog-ip}/iso/dart7.iso
    chain memdisk iso raw ||
    goto MENU
    :shell
    shell ||
    goto MENU
    :hostinfo
    echo ||
    echo ||
    echo This computer : ||
    echo MAC address....${net0/mac} ||
    echo IP address.....${ip} ||
    echo Netmask........${netmask} ||
    echo Serial.........${serial} ||
    echo Asset number...${asset} ||
    echo Manufacturer...${manufacturer} ||
    echo Product........${product} ||
    echo BIOS platform..${platform} ||
    echo ||
    echo Zurueck mit beliebiger Taste ||
    prompt
    goto MENU
    :image1
    kernel bzImage root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns=192.168.178.54 web=${fog-ip}/fog/ consoleblank=0 loglevel=4 type=down img=test ftp=${fog-ip} imgType=n osid=7 storage=${fog-ip}:/images capone=1 imgFormat=2
    imgfetch init.xz
    boot || goto MENU
    :return
    chain http://${fog-ip}/${fog-webroot}/service/ipxe/boot.php?mac=${net0/mac} ||
    prompt
    goto MENU
    autoboot
    

    Whats wrong with it?

    Regards X23


  • Developer

    @Quazz said in Advanced Menu Issue(s):

    This is most likely caused by an invalid formatted advanced menu.

    that is why i wanted to see the output of that url


Log in to reply
 

441
Online

38952
Users

10703
Topics

101543
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.