Error after upgrading to trunk



  • I’m still testing/toying around with FOG, which so far works rather well with just windows being a bit of a jerk at moment. But now I tried upgrading to trunk as it might have resolved an issue. But now it reached the “you still need to install/update your database schema” the <x.x.x.x>/fog/management page only shows a white screen with the text “Error communicating with the database”

    Re-installing won’t be too much of a hassle because it was still a test, but I want to know if there is a way to fix this.


  • Senior Developer

    All should be fixed in latest.



  • @Tom-Elliott

    fog_error_7695.log

    /bin/lsb_release
    /bin/systemctl
    grep: /opt/fog/.fogsettings: No such file or directory
    ln: failed to create symbolic link ‘/usr/lib/systemd/system/mysql.service’: File exists
    ln: failed to create symbolic link ‘/usr/lib/systemd/system/mysqld.service’: File exists
    ln: failed to create symbolic link ‘/etc/systemd/system/mysql.service’: File exists
    ln: failed to create symbolic link ‘/etc/systemd/system/mysqld.service’: File exists
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile

    • base: bay.uchicago.edu
    • epel: mirror.steadfast.net
    • extras: bay.uchicago.edu
    • remi: mirrors.mediatemple.net
    • remi-php56: mirrors.mediatemple.net
    • remi-safe: mirrors.mediatemple.net
    • updates: mirror.umd.edu
      Package epel-release-7-6.noarch already installed and latest version
      Nothing to do
      package remi-release-7 is not installed
      Retrieving http://rpms.remirepo.net/enterprise/remi-release-7.rpm
      Preparing… ########################################
      package remi-release-7.1-3.el7.remi.noarch is already installed
      Loaded plugins: fastestmirror
      ================================== repo: remi ==================================
      [remi]
      async = True
      bandwidth = 0
      base_persistdir = /var/lib/yum/repos/x86_64/7
      baseurl =
      cache = 0
      cachedir = /var/cache/yum/x86_64/7/remi
      check_config_file_age = True
      cost = 1000
      deltarpm_metadata_percentage = 100
      deltarpm_percentage =
      enabled = True
      enablegroups = True
      exclude =
      failovermethod = priority
      gpgcadir = /var/lib/yum/repos/x86_64/7/remi/gpgcadir
      gpgcakey =
      gpgcheck = True
      gpgdir = /var/lib/yum/repos/x86_64/7/remi/gpgdir
      gpgkey = file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
      hdrdir = /var/cache/yum/x86_64/7/remi/headers
      http_caching = all
      includepkgs =
      ip_resolve =
      keepalive = True
      keepcache = False
      mddownloadpolicy = sqlite
      mdpolicy = group:small
      mediaid =
      metadata_expire = 21600
      metadata_expire_filter = read-only:present
      metalink =
      minrate = 0
      mirrorlist = http://rpms.remirepo.net/enterprise/7/remi/mirror
      mirrorlist_expire = 86400
      name = Remi’s RPM repository for Enterprise Linux 7 - x86_64
      old_base_cache_dir =
      password =
      persistdir = /var/lib/yum/repos/x86_64/7/remi

  • Senior Developer

    @RLane It should be under apache error logs. If it’s not getting that far, it should be under installer->bin/error_logs/fog_error_${versionInstalling}.log



  • @Tom-Elliott Am I missing something here? /opt/fog/log is empty.


  • Senior Developer

    Anybody having this issue, please post the log.

    “I’m having this issue” where we don’t know what issue is even occurring doesn’t help anybody.



  • Also having this problem. Clean install on CentOS 7 x64 using the latest git version (7695).



  • @rhekkers The first time I tried to do the upgrade from 1.2.0 but I had the same problem. Currently I installed a fresh system 14.04 but it did not help.

    <edit>
    On 1.2.0 during installation it asks me about setup sql password but on 1.3.0 it won’t ask



  • @lionheart1986 Did you recently install it, upgraded it from a previous trunk version, or upgraded it from 1.2 like I did? Just curious.

    <edit>
    I also pulled it from the git repository



  • @rhekkers @ITSolutions

    I have same issue

    What i tryed:

    I had same problem as you FOG 1.3.0 Ubuntu 14.04 LTS

    1. First i checkd:
      /opt/fog/.fogsettings

    and this positions was blank:
    snmysqluser="";
    snmysqlpass="";
    snmysqlhost="";

    2.Second i setup my sql pass

    sudo dpkg-reconfigure mysql-server-5.5

    and modify /opt/fog/.fogsettings

    snmysqluser=“root”;
    snmysqlpass=“mypassword”;
    snmysqlhost=“p:localhost”;

    1. i checked sql connection:

    mysql -u root -p

    but still have same issue :P



  • @ITSolutions
    They have all been left blank.

    I made a quick backup and tried using root without password in the user and localhost or the ipaddress as host. Neither of those combinations yielded results.

    removed .fogsettings and copied .fogsettings.bak to .fogsettings


  • Testers

    @rhekkers Can you check /opt/fog/.fogsettings and see if the following lines are in it

    snmysqluser="root";
    snmysqlpass="this may contain a password";
    snmysqlhost="p:localhost";

    If you left the password blank then the snmysqlpass should look like this,

    snmysqlpass='';

    If it isn’t try blanking it out and rerunning the installer to see if it fixes the issue.



  • @ITSolutions

    It was running as process 14020, tried restarting it through
    sudo /etc/init.d/mysql restart
    and through
    sudo /etc/init.d/mysql stop
    sudo /etc/init.d/mysql start
    sadly it made no difference.


  • Testers

    @rhekkers Can you check to see if mysql is running?

    sudo /etc/init.d/mysql status

    If not then try starting it, sometimes the installer doesn’t start it correctly

    sudo /etc/init.d/mysql start



  • @ITSolutions I’ve seen them. Tried 16.04 first but has some PHP5 issues, now trying 14.04 which installed fine with 1.2. But now the trunk installation won’t let me install/update my database.

    Reinstalled Ubuntu and fog (14.04.1LTS), but still the Error communicating with the database on a blank screen in Firefox.
    It said it installed anything, but didn’t ask me for a password for the database. I gave the instruction I left the password for the database blank.


  • Testers

    @rhekkers No problem, definitely stick with 14.04, there have been problems reported with 16.04 and some of the packages FOG installs.



  • @ITSolutions It was upgraded from 1.2 yes. Thanks for notifying, then I’ll just reinstall it. I was using Ubuntu 14.04. I used the browsers Vivaldi and firefox to visit /fog/management on windows 8.1 pro. If it helps for future reference. Thank you for your quick response.


  • Testers

    @rhekkers Welcome to the FOG community, Just for future it is best that when you post let us know what OS FOG is on such as Ubuntu, CentOS, Debian, etc. Also the version of FOG, usually found in the cloud on the webUI, and if it has anything to do with the client the version of Windows you are using.


  • Testers

    You say you tried upgrading to trunk, is this from 1.2? For trunk it is a good idea to do a fresh install and not upgrade from 1.2 as it has changed quite a bit


Log in to reply
 

414
Online

39210
Users

10856
Topics

103343
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.