Updated to latest version, now GUI won't load



  • I just updated to the latest trunk version via the instructions, and now the FOG gui is not pulling up. all I get is a white screen.

    If I go to the IP directly, I get the apache is running screen, but when I add the /fog to the end, white screen.

    Do I need to reboot? restart a service? Will provide info as needed.



  • @Tom-Elliott Thank you for your help, Tom! It turns out something failed the first time I tried to update.

    Now I am on 7671 and everything appears to be in order. You guys are very responsive, and that is awesome.


  • Senior Developer

    Update fog as pdodb no longer exists



  • @Tom-Elliott Update PHP? I can do that.


  • Senior Developer

    @Shenanigan88 Please update and try again.



  • [Tue May 17 12:42:27.758726 2016] [:error] [pid 28781] [client 10.0.1.20:50372] PHP Fatal error: Uncaught exception ‘ReflectionException’ with message ‘Class PDODB does not exist’ in /var/www/html/fog/lib/fog/fogbase.class.php:88\nStac$

    [Tue May 17 13:02:56.096079 2016] [autoindex:error] [pid 32620] [client 10.0.3.91:59727] AH01276: Cannot serve directory /var/www/html/: No matching DirectoryIndex (index.html,index.php) found, and server-generated directory index forbi$

    I’m also getting a ton of the top error, along with the 2nd one mixed in here and there.



  • php-mysqlnd-5.6.21-1.el7.remi.x86_64
    php-cli-5.6.21-1.el7.remi.x86_64
    php-pecl-jsonc-1.3.9-1.el7.remi.5.6.x86_64
    php-5.6.21-1.el7.remi.x86_64
    php-fpm-5.6.21-1.el7.remi.x86_64
    php-common-5.6.21-1.el7.remi.x86_64
    php-pdo-5.6.21-1.el7.remi.x86_64
    php-mcrypt-5.6.21-1.el7.remi.x86_64
    php-process-5.6.21-1.el7.remi.x86_64
    php-pecl-zip-1.13.2-1.el7.remi.5.6.x86_64
    php-mbstring-5.6.21-1.el7.remi.x86_64
    php-gd-5.6.21-1.el7.remi.x86_64

    This is on CentOS7 btw.


  • Developer

    @Shenanigan88 PHP version installed? rpm -qa | grep php



  • [y 15 03:16:01.655241 2016] [auth_digest:notice] [pid 5659] AH01757: generating secret for digest authentication …
    [Sun May 15 03:16:01.655928 2016] [lbmethod_heartbeat:notice] [pid 5659] AH02282: No slotmem from mod_heartmonitor
    [Sun May 15 03:16:01.656964 2016] [ssl:warn] [pid 5659] AH02292: Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
    [Sun May 15 03:16:01.854615 2016] [mpm_prefork:notice] [pid 5659] AH00163: Apache/2.4.6 (CentOS) OpenSSL/1.0.1e-fips PHP/5.6.21 configured – resuming normal operations
    [Sun May 15 03:16:01.854630 2016] [core:notice] [pid 5659] AH00094: Command line: ‘/usr/sbin/httpd -D FOREGROUND’
    [Tue May 17 08:26:55.820762 2016] [:error] [pid 3165] [client 10.0.1.136:33228] PHP Fatal error: Call to a member function get() on null in /var/www/html/fog/lib/fog/host.class.php on line 604
    [Tue May 17 09:00:25.179210 2016] [:error] [pid 3161] [client 10.0.3.91:50058] PHP Warning: array_map(): An error occurred while invoking the map callback in /var/www/html/fog/lib/fog/fogcontroller.class.php on line 199, referer: http://10.0.0.13/fog/management/index.php?node=report
    Sun May 15 03:16:01.854615 2016] [mpm_prefork:notice] [pid 5659] AH00163: Apache/2.4.6 (CentOS) OpenSSL/1.0.1e-fips PHP/5.6.21 configured – resuming normal operations


  • Developer

    @Shenanigan88 Usually when you get a white screen instead of the web gui there is an error in the PHP code. Please help us find it by posting what you have in your apache error log file. See the signature below my message on where to find the log file.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.