Windows Fails to Install



  • Specifically on our HP Probook G1 laptops, after deployment I am getting an error on the boot screen that says, “Windows Setup could not configure Windows to run on this computer’s hardware.” The message displays for a only a second, then the machine reboots. I then get the following error, “Windows could not complete the installation. To install Windows on this computer, restart the installation.” This error will stay on screen until I click okay.

    We’ve had this issue happen since we were using Fog .32 and a Windows 7 image. We’ve since upgraded to the newest Trunk version multiple times, and this issue has occurred every time on these laptops. It has yet to happen on any other model of computer.



  • @Wayne-Workman Good to know that the new client works smoother.
    I just upgraded to trunk a few days ago and didn’t have the time to test yet.


  • Moderator

    @michael_f I’ve not heard of the issue with the delayed start for the new client.

    And I’m well aware of the timing issues the Legacy Client had - I had to delay it here at my work too.

    I’ll get the things you’ve stated into the wiki.



  • @Wayne-Workman setupcomlete.cmd has to be placed under C:\Windows\Setup\scripts in the master system.
    As the name indicates, the script is called by windows just after setup has finished.

    Btw. l set the Fog service to delayed start, ie I put
    sc config FOGService start= delayed-auto
    into the script.
    I don’t know, if this is really necessary with the new fogclient, but it doesn’t harm.
    Reason for this is i’ve got some computers which require delayed start with the legacy client (afair network doesn’t come up fast enough)


  • Moderator

    @zpoling Care to provide a screen shot or some steps?



  • @Wayne-Workman I had to look up where to put the script in the first place, and was instructed to use SetupComplete.cmd; that is what worked for me.


  • Moderator

    TO clarify, are you guys putting this in setupcomplete.cmd or setupcomplete.bat ?

    I’ve not done this myself yet, so I’m just going off of what you all say.



  • @Wayne-Workman This fixed my original issue as well. Thanks for the help!



  • Hi,

    do you try to restore to vm? i’ve seen several error for example with virtual box when trying to restore an earlier captures sysprepped image.
    If yes try the same image on real pyhsical hardware please.

    Regards X23


  • Moderator



  • I can confirm its also working for me :).
    But if I was you guys , i would put this on the FOG-WIKI. @Developers

    This is going to be a problem for many of us & maybe they stop earlier with FOG because that and the don’t know it ;)
    But thumbs up for the good work ;)!



  • @Wayne-Workman OK, I thought about installing the fog client after imaging by calling the msi-package from setupcomplete.bat, but this way is even easier.

    I can confirm this working for me.

    Thank you!



  • @Wayne-Workman said in Windows Fails to Install:

    @boeleke All I can say is try it and see.

    To explain the problem in more detail, when your sysprep stuff is happening after deployment, the fog client starts up and does it’s thing too (rename, reboot, etc.), and breaks the unattend.xml and setup complete stuff. The simple answer is just to disable the service before taking the image, and set up your golden machine so that it re-enables the service after all your stuff is done.

    Also - it’s not a bug. The FOG Client is designed to do it’s job.

    But maybe a tip , put it in the wiki.
    i searched like i was crazy last week to all forums. But maybe i’m wrong , i’m just going to try it out. I’ll update this tomorrow when i can test! Thanks!


  • Moderator

    @boeleke All I can say is try it and see.

    To explain the problem in more detail, when your sysprep stuff is happening after deployment, the fog client starts up and does it’s thing too (rename, reboot, etc.), and breaks the unattend.xml and setup complete stuff. The simple answer is just to disable the service before taking the image, and set up your golden machine so that it re-enables the service after all your stuff is done.

    Also - it’s not a bug. The FOG Client is designed to do it’s job.



  • @Wayne-Workman said in Windows Fails to Install:

    sc config FOGService start= auto
    net start FOGService

    Sooo only this 2 lines :

    “sc config FOGService start= auto
    net start FOGService”

    in my setupcomplete.cmd and it will work?
    Oh my!

    Is it possible to remove this bug from the installer?
    Its weird because the old V0.9 fog didn’t gave any problems to me :)


  • Moderator

    Yes, just disable it in service before taking the image.

    Here’s a post that shows how, This particular person was experiencing a particular problem in this post, but these issues have since been resolved in the current FOG Client. What he says about enabling the service is still valid.

    @boeleke @Psycholiquid said in Rename fails but adds client to domain.:

    Ok using SVN 3702 with Client 0.9.0 I am getting the following happening:

    I create the image in Audit mode
    Install all software and updates Install FOG Service software 0.9.0

    In the SetupComplete.bat I have the following commands

    sc config FOGService start= auto
    net start FOGService

    Set windows to OOBE and reboot uploading image to FOG server.

    Once complete I push the image out to one of the hosts I have setup in FOG right now. IT runs through the whole image setup and completes to the Desktop.

    From there is joins the domain without trying to rename the computer at all. This create a problem as there will be multiple computers all trying to join the domain under the same name causing a trust issue in the process.

    Here is the log from the computer I just did. Keep in mind this one is constantly rebooting due to it trying to change the name after it has already joined the domain:

    fog.log

    Source: https://forums.fogproject.org/topic/5490/rename-fails-but-adds-client-to-domain/27



  • @Wayne-Workman

    How do you disable? Just in the “services”?
    What line do you need to add in the XML - file to activate this?

    Crap! I’m searching for a week behind this error and its FOG client grrrr



  • Hi there!
    I’m beeen searching for a sollution since 04/05/2016!
    Didn’t find any solution & now you guys got the same problem as me!
    I also think it is the FOG client. I prepped more images , and after the install from deepfreeze / fog client i get this error to.

    Big big problem ;) Tomorrow is my last day of internship so i can’t image :) ^^


  • Moderator

    @michael_f said in Windows Fails to Install:

    The new fog client, at least v0.10.6 seams to break windows setup. Uninstalling the client in the image solved the problem with the windows setup for me.

    Ah. We’ve seen this before. The answer is to disable the FOG Service before you take the image, and then in your unattend.xml file re-enable the service after the unattend file is done with everything else.



  • @zpoling I think I ran into the same problem:
    As I move fog to a new server I took the chance to upgrade Fog from 1.2 to trunk.

    With Fogserver 1.2 I used to install the legacy fog client in the image which worked without problems.

    The new fog client, at least v0.10.6 seams to break windows setup. Uninstalling the client in the image solved the problem with the windows setup for me.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.