Yet another iPXE question rev 7581



  • Ubuntu: 14.10
    Fog: 7581

    I am sure you all get tired of iPXE questions. I have read this article and that article. But as my wife can attest; I am a terrible ‘looker’.

    I have fog installed; all seems to work. I can snag an image fine (i assume). Now I want to deploy that image. I assume I should go to ‘iPXE New Menu Entry’ and fill out that information? But I do NOT know what to put down in the various fields.

    Does a guide exist to tell me what to put into those fields? Or does anyone know what I should put into those fields? (Not ISO; I feel confident I can do ISO’s all day thanks to the guides)

    I have NOT searched for this yet, but since I am here: when I do multicast or quick images or anything, I do NOT want the user prompted for a password. When I tried to do the multicast deployment, it prompts for a username and password and does not like any user I try.

    Great product. I like the new interface too. I have been spreading the word of Fog to many small bit gov agencies as a better solution than the current multi-million dollar solutions.

    Any and all help is appreciated.

    GGQ


  • Moderator

    @GoodGuyQ My guess is you’re entering the wrong user/password. You can add a new user in the webgui to test that out.

    Here is my quick image item for reference

    set username foglogin
    set password foglogin
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param username ${username}
    param password ${password}
    param qihost 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    

    With foglogin being a valid username and password



  • @Quazz Thanks for that tip. I tried that and I tried without any of the info. Still prompts for username/password and still tells me invalid login. When I take the login info out, shows me my images, when I select an image, it briefly says invalid login again before returning to main menu.

    0_1463063725614_upload-42d13cb6-7869-42de-96e6-1d96fb6987a2

    But, I see this is actually the solution I want. Because the user can select that and then be presented with any image they want.


  • Moderator

    To disable the login prompt try the following:

    Go to iPXE Menu Configuration

    Expand fog.quickimage

    Add

    set username foglogin (replace these with your username and password obviously)
    set password foglogin

    and change

    param username
    param password

    to

    param username ${username}
    param password ${password}


Log in to reply
 

451
Online

38949
Users

10700
Topics

101523
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.