PHP Fatal error



  • Hi I am running a FOG 1.2.0 server with Ubuntu 16.04, PHP 7.0.4-7, Mysql 5.7.12 and Apache/2.4.18 installed. When I open up firefox to configure the database I receive the white screen of death. The Apache error log is as follows:
    [Tue May 10 20:00:05.8 2016] [:error] [pid 1305] [client IP47012] PHP Fatal error: Uncaught Error: Call to undefined function set_magic_quotes_runtime() in /var/www/fog/commons/init.php:97\nStack trace:\n#0 /var/www/fog/commons/init.php(202): Initiator::startInit()\n#1 /var/www/fog/commons/base.inc.php(7): require(’/var/www/fog/co…’)\n#2 /var/www/fog/management/index.php(3): require(’/var/www/fog/co…’)\n#3 {main}\n thrown in /var/www/fog/commons/init.php on line 97. Any help would be appreciated!


  • Senior Developer

    @JGeear There isn’t a call to shutdown the interface. The SIGTERM, Shutting down is the message that is saying it is shutting down.



  • Thanks for the info! When updating the install fails at shutting down the web service. The error generated is as follows:
    [Wed May 11 00:0 2016] [:error] [pid 1448] [client IP:56466] PHP Fatal error: Uncaught Error: Call to undefined function set_magic_quotes_runtime() in /var/www/fog/commons/init.php:97\nStack trace:\n#0 /var/www/fog/commons/init.php(202): Initiator::startInit()\n#1 /var/www/fog/commons/base.inc.php(7): require(’/var/www/fog/co…’)\n#2 /var/www/fog/management/index.php(3): require(’/var/www/fog/co…’)\n#3 {main}\n thrown in /var/www/fog/commons/init.php on line 97
    [Wed May 11 00:06:2016] [mpm_prefork:notice] [pid 1432] AH00169: caught SIGTERM, shutting down


  • Senior Developer

    This is definitely not a bug. Ubuntu 16.04 always installs php 7. FOG 1.2.0 used the function you’re seeing but that function was removed from php 7. Trunk installs support php 7. Maybe you’d have better progress with it?


  • Moderator

    It’s because a function that FOG 1.2.0 used in older PHP was removed from PHP 7.

    This is fixed in FOG Trunk: https://wiki.fogproject.org/wiki/index.php?title=Upgrade_to_trunk

    If you wish to use 1.2.0 (which I would recommend against), you’ll need to install an older version of PHP and then probably re-run the installer.

    –Fixed


Log in to reply
 

347
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.