Dell optiplex 7040 problems



  • Hello,
    I have problems with my last computer (Dell Optiplex 7040 Small tower)
    I updated my server fog (0.32 up to 1.2.0) beause I couldn’t clone .(FOG SERVER ubuntu 64 , 14.04 LTS with 802.3ad protocol : LACP) )
    Now the Fog upgrade is correct because I clone successfully computer (older) (dell latitude 6430, hp elitebook 840 G2)
    The problem is I can’t upload Optiplex to my fog server

    At the beginning (origin kernel) I had errors " tsc: Fast TSC calibration failed " and then errors saying me : Problem with NFS , can’t mount NFS directory (network is unreachable) (the same error with my fog server 0.32)
    I think fog(kernel) doesn’t knew optiplex’s ethernet card
    Tested with kernel - 4.1.2 TomElliott => I had kernel panic .
    So I modified the kernel (Fog -> Kernel update -> Kernel - 4.1.0 TomElliott) and now I have no error any more about NFS but my optiplex freeze on * Processing Hard Disk: / dev / sda

    Any idea ?
    thanks

    sorry for my english



  • Just got mine working with FOG svn destribution. The problem with FOG 1.2.0 is likely the kernel can’t support the hardware. In my case the network card.



  • @Wayne-Workman

    How long are you waiting for? 30 seconds? 5 minutes? 30 minutes?
    I’m still waiting !! (severals hours)



  • Awesome !!!
    Victory… Thank you guys…
    For others users : I booted in debug mode. when I wrote fixparts /dev/sda I had a warning message:

    0_1462807476989_fog.jpg
    I answered Yes
    After I run : lsblk
    0_1462807747253_lsblk.jpg
    and fdisk -l
    0_1462807766769_fog2.jpg

    I guess my partition table was the problem…

    Now the capture is in progress

    Thank you so much


  • Senior Developer

    @Wayne-Workman I think this is the ever known fixparts issue.

    @Jo2220 Please recreate the same tasking but as a debug task. (Create like you normally would but before you confirm the task, check the box for “Schedule as debug”.

    THen boot the client. It will bring you to a prompt. At that prompt type:

    fixparts /dev/sda

    You will likely be told some information, allow the changes and write them. After that, start the upload tasking with: fog

    You will have to press enter a bunch of times, but you should be good after that point.


  • Moderator

    @Jo2220 How long are you waiting for? 30 seconds? 5 minutes? 30 minutes?

    Also, can you schedule the task as a debug task so we can do some testing? You do that the same way you do a regular upload/capture but there’s a checkbox in the confirmation window to make it a debug task.

    Once you’re at the shell prompt (after pressing enter at the informational outputs), please run these commands and give us the results:

    lsblk
    fdisk -l

    Also, anything special about the HDD in this computer?



  • Thanks.
    Latest news :
    I upgraded to trunk version successfully.
    Boot pxe -> ok
    mount NFS - > ok
    But the client freeze on Processing Hard Disk: / dev / sda
    See picture
    0_1462800432779_20160509_151723_resized.jpg


  • Moderator

    Update to FOG Trunk is the best advice, honestly. https://wiki.fogproject.org/wiki/index.php?title=Upgrade_to_trunk


Log in to reply
 

531
Online

39187
Users

10835
Topics

103153
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.