Latest DELL computers won't register/boot on PXE



  • Hi Fog Community,

    Today i received new computers from DELL, Latitude E5470 & E5570.
    I tried to boot it on PXE, they load the pxe menu but when i try to quick register or full host register it stuck on “Attempting to register host”…

    I tried to update to latest kernel on FOG configuration but it wont work too, it download the kernel then stuck on “Download Completed! Moving file to TFTP server” …

    Any ideas?

    Regards

    Arnaud



  • This post is deleted!


  • @Tom-Elliott
    Oh ok.
    I updated the kernel to “Official Published Kernels
    Kernel - 4.1.2 TomElliott” and it works!
    i just don’t see the “TomElliottUSB” on the kernel i selected before…!

    SOLVED :) !


  • Senior Developer

    @arnaudrigole Yes, usb nic would be a NIC that’s plugged into USB. So as you’re in debug, can you get output of ifconfig -a.

    I still suspect it’s not getting network for whatever reason. Possibly DHCP isn’t working OR the nic is not recognized by the init’s.



  • @Tom-Elliott
    Hello Tom. The NIC is integrated on motherboard, what do you mean by USB nic? a network card plugged on USB?

    @george1421
    Hello George, fog is running under version 1.2.0, the same since the initial setup. Kernel version just updated is:

    Official Published Kernels
    Kernel - 3.19.3 TomElliottUSB

    i’ll just try with
    Official Published Kernels
    Kernel - 4.1.2 TomElliott


  • Senior Developer

    @arnaudrigole to me it sounds like the network isn’t starting. Is the NIC a usb NIC?


  • Moderator

    @arnaudrigole What version of FOG are you using (numbers located on the cloud on the GUI management page)? Also what version of the kernel is installed? And last question for now, what version of FOG did you use to capture the 5450 image?



  • after manually register the host and assigned a debug download task with E5450, thats what happens:

    osid=5
    osname=Windows 7
    mbrfile=/usr/share/fog/mbr/win7.mbr
    type=down
    storage=10.1.11.170:/images/
    img=E5450Win7prox64
    hd=/dev/sda
    part=/dev/sda1

    [root @ fogclient /] fog

    –> black screen, with flashing dash in the bottom left hand corner .
    Maybe the 5470 isn’t compatible with the 5450 image… ? yet they are very similar,same disk (ssd 256) just the cpu changing from I5 broadwell to I5 skylake…



  • fresh news.
    i apologize, i just changed the tftp password, kernel update succeeded now.

    i tried to reboot the new dell computers but the issue still present when trying to send inventory. i’ll try with manual host import on fog webui


Log in to reply
 

508
Online

39009
Users

10722
Topics

101856
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.