FOG Errors: tftp & pxe boot



  • Hi everyone,

    I was wondering if anyone could help me as am on the verge of pulling my hair…

    I set up my fog server on a Linux debian vm and I have the linux vm network settings on bridge mode. I can log on to the Web server interface from any machine within the building just by punching in the ip address and I can ping the vm.

    I followed the instructions i.e my windows DHCP option 66 & 67 which is the fog servers ip address and also udionly.kpxe I also made a reservation on my windows DHCP for my vm server.

    When any of my device boots up on network mode it looks at the right ip address but it just times out (pxe-e32) or if I test on a vm that has for example windows 8 os it will show that its looking at the right ip address but would say… udionly.kpxe not found etc

    I did a tftp test on a Windows machine:
    tftp -i x.x.x.x get udionly.kpxe but it either times out or I get error on server.

    *I have disabled the linux server firewall
    *I restarted the tftp server.
    *tftp server status command stated that the server is active.
    *I restarted the apache2 server
    *I tried various Linux distribution

    My fog setup:
    Server ip address: 10.0.21.0
    DHCP: 10.0.21.0
    DNS: 10.0.21.0
    ROUTER/Gateway: 10.0.20.1 (which is also our sophos firewall)
    Fog DHCP: did not setup

    What am I doing wrong? and guys please assume that am a complete newbie on Linux.

    Any ideas?

    Thank you



  • @Wayne-Workman i wasn’t really clever in browsing this forum with my phone, so I thought hey Google may just pop with the answer quicker but I will certainly use that link for my reference for future mishap.

    Thanks bud (Y)


  • Moderator

    @owlz89 That’s great. FYI it is in our Wiki too, in the article I linked. :-)



  • @Wayne-Workman figured it out after asking google, seems as if it’s a common bug on debian.

    You have to change the TFTP_ADDRESS from “0.0.0.0:69” to “:69”
    ( /etc/default/tftp-hpa)

    Now tftp service loads up during boot.



  • @Wayne-Workman

    no problem, I’ll have a look.
    Damn the letter “n” grrr… thank you :D


  • Moderator

    @owlz89

    In this article: https://wiki.fogproject.org/wiki/index.php?title=Troubleshoot_TFTP
    Run through the “Testing” part and see what happens. Be sure to include the n as well ;-)



  • @Wayne-Workman haha these are the moment that you want to start laughing due to stupidity … You was right Wayne my option 67 had the “n” missing.

    However when I loaded up debian the initial boot screen states tftp hpa: failed

    I had to restart the service in order to get it running. Any ideas?

    Thank you also for pointing out my error. I now have a sigh of relief.


  • Moderator

    Well… either your n key isn’t working, or you don’t have the right option 067 set in DHCP. Because you mistyped it many times in your post… so I assume you have misspelled it without knowing you were doing it wrong.

    It’s not udionly.kpxe it’s undionly.kpxe

    Check this and then come back and let us know.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.