Anyone has FOG 1.2 working with Dell Optiplex 7040?



  • I am having problem getting FOG 1.2 working with Dell 7040. Appears the FOG kernel doesn’t support the network card in 7040. Getting “failed to mount NFS” “Network unreachable”. The same FOG setup works fine on Dell 790, 7010 and older PCs for both win7 and win10. Any suggestions?



  • I am actually imaging a bunch of 7040’s. My test deployment went well, but I am also on Trunk. I updated from 7565 to 7671 yesterday, and other than a small installation snafu, it has worked perfectly.



  • yes im VM so snapshot is possible, ill give it a go and start a new thread if it goes pear shaped !
    thanks


  • Developer

    @craigcoulson Installed on bare metal or in a VM. If VM then you can simply take a snapshot before trying to upgrade to trunk. If bare metal you might want to take a normal backup first just to make sure. On the other hand we have a lot of people upgrading to the latest version. Some run into problems but we always help people on short notice to get things up again. To be able to help we just need information on the things you did (exact commands) and the errors you ran into (pictures are best)!



  • Hi - yup i have version 1.2.0 - now with the latest kernels - same problems with the 7040.

    i originally tried to setup FOG as a SVN version but my original installation borked in spectacular fashion - i went back to 1.2 and it all went well. im a bit reluctant to upgrade as suggested as i got bitten the fist time. My FOG is on Ubuntu box 15.10


  • Developer

    @craigcoulson Any chance you can give us some more information? What version of FOG (see in the blue cloud on the webinterface)?

    @snap7B said:

    Set up FOG svn destribution, it worked like a charm. :-)

    Have you tried his suggestion??



  • Hi - same issue here - tried the kernel upgrade but no joy at all.



  • Set up FOG svn destribution, it worked like a charm. :-)


  • Moderator

    While the general recommendations are to update 1.2.0 to the trunk build to get the latest drivers built into the kernel and support for gpt disks, uefi firmware and windows 10…

    You might be able to get it working with 1.2.0 by just updating the kernels to the latest. What version is your kernels on the 1.2.0 installation?

    You can get the very latest kernels (understand there is an equal chance that they will/wont work with 1.2.0) by using the following linux commands
    sudo wget https://fogproject.org/kernels/bzImage
    sudo wget https://fogproject.org/kernels/bzImage32

    You should rename the original kernel files in /var/www/html/fog/service/ipxe and then place these downloaded files in that directory.


Log in to reply
 

380
Online

39.5k
Users

11.1k
Topics

105.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.