No DHCP response when trying to inventory a host {FOG TRUNK}



  • Hi Fog community,

    All is in the title, since i installed FOG trunk, i can’t register, upload, image a computer. It boot on PXE, then when i select “quick inventory” or “full inventory”, it said:

    ~ Starting logging: OK
    ~ Initializing random number generator … done.
    ~ Starting eth0 interface and waiting for the link to come up
    ~ udhcpc (v1.24.1) started
    Sending discover…
    Sending discover…

    then…

    No DHCP response on interface eth0, skipping it.

    EDIT: i tried to manually ad the host to launch an upload task; it boot, told me “DHCP answer received on eth0”, then Input/Output error trying to open http://192.168.253.10/fog/service/ipxe/boot.php

    I don’t understand why the computer catches an ip when it boot on PXE, then it wanna catch another IP when inventory ?!

    EDIT: i just did a clean install of fog trunk on a new virtual machine (debian 8), same problem, "No DHCP response on interface eth0, skipping it. Failed to get an IP via DHCP, tried on interface(s): eth0. Please check your network setup and try again.

    thanks for your help!



  • @Sebastian-Roth
    Yeah, i understand. Trust me i tried to do a lot of times, analyse logs and permissions and work on issues with an unix professor but we don’t found for NFS…
    No problem, still working!


  • Developer

    @arnaudrigole Just keep going! Learning by doing. Soon you will be able to fix all your issues without asking because you know which log file to look at or what command to run to find and fix things. Still we are more than happy to help. Just post the error you see so we can look into it.



  • Ok thanks, i resolved the problem by reinstalling fog 1.2; and so re-encounter my nfs issues…I can not do anything without encountering an error :(!


  • Developer

    @arnaudrigole I am working on a wiki article describing the whole boot process and all the possible problems one can run into (see the link below my message) but it’s not ready yet.

    My guess is that you have spanning tree enabled on your switch but not port-fast settings. Please use a mini switch between the client and your main switch to see if the problem goes away!


Log in to reply
 

429
Online

38953
Users

10704
Topics

101562
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.