• Hi all,

    We are trying to upload a Windows 7 x64 image to Fog (Fog 1.1.2) from a HP 260 G1, however upon pressing F12 and waiting for fog menu to prompt us to register, it doesn’t actually get to the fog menu but just restarts.

    It gets to the point of iPXE Initializing devices … ok

    iPXE 1.0.0+ (1639) etc

    Configuring (net0 mac address). . . . . . and then restarts.

    I’ve read that it could be that the Kernel doesn’t support Realtek PCIE GBE Family Controller Series v2.59 however we have tried to specify different kernels but to no avail.

    Does anyone have any suggestions?

    Any help would be greatly appreciated and thank you in advance.

    Edit FOG works with all other PC’s currently on site and has for years, this is the first time we’ve encountered this problem.


  • Moderator

    Cross linking similar thread where ipxe.pxe solved the issue with the realtek nic.

  • Moderator

    Just for clarification when others are reading this in the future: ipxe.pxe comes with native NIC drivers where undionly.* uses the NIC’s UNDI interface. Seems like the mentioned realtek NIC has a “buggy” PXE implementation which causes the undionly binary to fail…

  • OK we have managed to resolve the issue a different way. But we wouldn’t have got there without your help.

    We tried lots of combinations of DHCP option 67 undionly.*

    The way we resolved the issue was to change DHCP option 67 to ipxe.pxe.

    Many thanks Sebastian.


  • Thanks for the suggestions will certainly give it a go now.

    I noticed something pop up very very quickly before it restarts so recorded on slow-mo and captured the error code.

    Error 0x040ee119.

  • Moderator

    @richardh Is “Configuring (net0 mac address). . .” the last thing you see? Then it’s not the kernel but iPXE not liking the NIC I suppose. You can try using newer iPXE binaries. Here you find those from FOG 1.2.0: https://svn.code.sf.net/p/freeghost/code/tags/1.2.0/packages/tftp/ and here are the most current ones (using a totally different embedded iPXE script that might cause other troubles for you): https://svn.code.sf.net/p/freeghost/code/trunk/packages/tftp/