Can't boot to hard drive after installing dnsmasq

  • Hey Gang,

    I had a working FOG 1.20 server running on ubuntu 14.04 for a while, but then decided to run dhcp from our cisco equipment. I followed the instructions for installing dnsmasq, and got everything to work regarding pxe booting. However, if I didn’t select any pxe boot options (register host, etc), and allowed the system to boot from hard drive, it would fail indicating no startup disk, and would suggest pressing F2 for setup, etc. This was a different behavior from other folks (various posts in the forum) who had a black screen and a flashing cursor in the corner.

    I solved the issue by editing /etc/dnsmasq.d/ltsp.conf and uncommenting the line that reads:

    pxe-service=X86PC, “Boot from local hard disk”, 0

    For the record, I created my ltsp.conf file from the sample provided in the documentation, and just changed the relevant parts (server IP address, etc), and kept everything else as is.

    Anyway - I thought I’d post this in the hope that someone else who may be struggling with this issue will find success with this solution.

    Keep up the good work on this excellent project! FOG is one of the greatest tools I’ve ever used in my 16 years as a sysadmin.



  • @MarcB It’d help a lot if you posted the entire ltsp.conf file.

  • @Wayne-Workman Are you referring to this line:
    pxe-service=X86PC, “Boot from network”, undionly

    I had that line uncommented as well, and still had the issue where my machines were not finding their hard drives. This issue cropped up once I installed dnsmasq. Everything else about FOG process on these very same machines worked flawlessly (and had been since v.28).

    The one change that allowed them to find their hard drives was uncommenting the line:
    pxe-service=X86PC, “Boot from local hard disk”, 0

  • @Tom-Elliott Thanks Tom - yes, that option was commented, and that fixed my dns issue on the fog server (dns broke when I installed dnsmasq, but was restored by commenting out that line). Buy my machines wouldn’t find their hard drives unless I uncommented the line I specified above.

  • Try commenting port=0 in the dnsmasq config file and restarting the service too.

  • When you network boot to fog (no matter the means of delivering the options), FOG handles exiting to HDD just fine. So I’d sugest that you set DNSMASQ to always network boot to fog.