could not pxe boot (input/output error) when do multicast



  • I’m using ver 7202.
    It’s fine with unicast. I use Slack plugin only

    alt text

    Thanks,



  • @Tom-Elliott Yes, it is
    00:0c:29:bf:57:4a
    If you don’t mind, could you teamviewer and check ? Thanks!


  • Senior Developer

    @dvchuyen and this is a mac address who’s waiting for multicast to occur?



  • @Tom-Elliott
    Thanks,

    #!ipxe
    set fog-ip 192.168.1.252
    set fog-webroot fog
    set boot-url http://${fog-ip}/${fog-webroot}
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 keymap= web=192.168.1.252/fog/ consoleblank=0 rootfstype=ext4 rootfstype=ext4 mac=00:0c:29:bf:57:4a ftp=192.168.1.252 storage= storageip= web=192.168.1.252/fog/ osid= consoleblank=0 irqpoll hostname=000c29bf574a isdebug=yes
    imgfetch init_32.xz
    boot```

  • Senior Developer

    @dvchuyen Sorry, after service but before boot.php add /ipxe/

    so 192.168.1.252/fog/service/ipxe/boot.php?mac=macaddresshere



  • @Tom-Elliott
    Of course…
    Am I missing something ?
    alt text


  • Senior Developer

    @dvchuyen Did you change the <mac of relevant host with colons> part?




  • Senior Developer

    @dvchuyen what url?



  • @Tom-Elliott I don’t know how to check port on client, this is my Multicast setting
    alt text

    I got 404 Not Found when access the url. I go to service folder and cannot find boot.php file


  • Senior Developer

    @dvchuyen What port does the client think it’s connecting to?

    In other words, please create your multicast task (and get it running while still staying “on”).

    Go to the URL:

    http://192.168.1.252/fog/service/boot.php?mac=<mac of relevant host with colons>

    What’s the output in the browser?



  • @Sebastian-Roth said in could not pxe boot (input/output error) when do multicast:

    tried
    I got this from server when test with 1 client
    alt text
    and this from client
    alt text


  • Developer

    @dvchuyen Have you tried multicasting by hand as shown in the wiki articles Wayne posted about a week ago (see in the earlier posts here)?



  • @Wayne-Workman Yes, I already cleared the tables then re-runed the installer,

    [04-26-16 1:28:48 pm] | 0 tasks to be cleaned
    [04-26-16 1:28:48 pm] | 1 task found
    [04-26-16 1:28:48 pm] | Task (1) a is new!
    [04-26-16 1:28:48 pm] | Task (1) a has been cleaned.
    Udp-sender 20120424
    Using mcast address 232.168.1.252
    UDP sender for (stdin) at 192.168.1.252 on eno16777984 
    Broadcasting control to 224.0.0.1
    [04-26-16 1:28:48 pm] | Task (1) /images/Win10ESNoDriver image file found.
    [04-26-16 1:28:48 pm] | Task (1) 1 client(s) found.
    [04-26-16 1:28:48 pm] | Task (1) a sending on base port: 63100
    [04-26-16 1:28:48 pm] | CMD: cat /images/Win10ESNoDriver/d1p1.img | /usr/local/sbin/udp-sender --interface eno16777984 --min-receivers 1 --max-wait 600 --portbase 63100 --full-duplex --ttl 32 --nokbd --nopointopoint;cat /images/Win10ESNoDriver/d1p2.img | /usr/local/sbin/udp-sender --interface eno16777984 --min-receivers 1 --max-wait 600 --portbase 63100 --full-duplex --ttl 32 --nokbd --nopointopoint;
    [04-26-16 1:28:48 pm] | Task (1) a has started.
    [04-26-16 1:28:59 pm] | 0 tasks to be cleaned
    [04-26-16 1:28:59 pm] | 1 task found
    [04-26-16 1:28:59 pm] | Task (1) a is already running PID 16550
    [04-26-16 1:29:10 pm] | 0 tasks to be cleaned
    [04-26-16 1:29:10 pm] | 1 task found
    [04-26-16 1:29:10 pm] | Task (1) a is already running PID 16550
    [04-26-16 1:29:21 pm] | 0 tasks to be cleaned```

  • Moderator

    @dvchuyen There are commands in here to clear the tables related to multicast: https://wiki.fogproject.org/wiki/index.php?title=Troubleshoot_Downloading_-_Multicast



  • Update to latest verion, restart the server, now the task is not cancelled but It still stuck at Starting to restore image. :|

    [04-26-16 8:18:42 am]  | 0 tasks to be cleaned
    [04-26-16 8:18:42 am]  | 1 task found
    [04-26-16 8:18:42 am]  | Task (14) a is new!
    [04-26-16 8:18:42 am]  | Task (14) a has been cleaned.
    [04-26-16 8:18:42 am]  | Task (14) /images/Win10ESNoDriver image file found.
    [04-26-16 8:18:42 am]  | Task (14) 1 client(s) found.
    [04-26-16 8:18:42 am]  | Task (14) a sending on base port: 63100
    Udp-sender 20120424
    Using mcast address 232.168.1.252
    UDP sender for (stdin) at 192.168.1.252 on eno16777984
    Broadcasting control to 224.0.0.1
    [04-26-16 8:18:42 am]  | CMD: cat /images/Win10ESNoDriver/d1p1.img | /usr/local/sbin/udp-sender --interface eno16777984 --min-receivers 1 --max-wait 600 --portbase 63100 --full-duplex --ttl 32 --nokbd --nopointopoint;cat /images/Win10ESNoDriver/d1p2.img | /usr/local/sbin/udp-sender --interface eno16777984 --min-receivers 1 --max-wait 600 --portbase 63100 --full-duplex --ttl 32 --nokbd --nopointopoint;
    [04-26-16 8:18:42 am]  | Task (14) a has started.
    [04-26-16 8:18:52 am]  | 0 tasks to be cleaned
    [04-26-16 8:18:52 am]  | 1 task found
    [04-26-16 8:18:52 am]  | Task (14) a is already running PID 3646
    [04-26-16 8:19:03 am]  | 0 tasks to be cleaned
    [04-26-16 8:19:03 am]  | 1 task found
    [04-26-16 8:19:03 am]  | Task (14) a is already running PID 3646
                                                                  5,1```

  • Moderator

    @dvchuyen and that’s about how most of us feel when Tom posts to a thread.



  • @Tom-Elliott said in could not pxe boot (input/output error) when do multicast:

    Th

    It does… so weird

    [root@fog ~]# ifconfig
    eno16777984: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
            inet 192.168.1.252  netmask 255.255.255.0  broadcast 192.168.1.255
            inet6 fe80::20c:29ff:fe8f:977b  prefixlen 64  scopeid 0x20<link>
            ether 00:0c:29:8f:97:7b  txqueuelen 1000  (Ethernet)
            RX packets 93418  bytes 9024294 (8.6 MiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 55970  bytes 124838779 (119.0 MiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    
    eno33557248: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
            inet 172.16.0.3  netmask 255.255.255.0  broadcast 172.16.0.255
            inet6 fe80::20c:29ff:fe8f:9785  prefixlen 64  scopeid 0x20<link>
            ether 00:0c:29:8f:97:85  txqueuelen 1000  (Ethernet)
            RX packets 2044261  bytes 204256783 (194.7 MiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 1839259  bytes 129113712 (123.1 MiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0```

  • Senior Developer

    @dvchuyen And interface eno167777984 is connected to the network expecting handle the Multicast traffic? The fact that it appears to cancel directly after starting leads me to believe the eno16777984 nic is not the nic that’s expected to be running. Either the interface itself doesn’t exist or it doesn’t have an address associated to it when you’re trying to run the multicast task.



  • It seems that the multicast job is cancel automatically. I set timeout 10 minutes

    [04-25-16 5:29:51 pm]  * No tasks found!
    [04-25-16 5:30:02 pm]  * No tasks found!
    [root@fog ~]# tail /opt/fog/log/multicast.log
    [04-25-16 5:30:23 pm]  | Sleeping for 10 seconds to ensure tasks are properly submitted
    [root@fog ~]# tail /opt/fog/log/multicast.log
    [04-25-16 5:30:33 pm]  | Task (13) a sending on base port: 63100
    Udp-sender 20120424
    bind socket to 192.168.1.252:63101 (Address already in use)
    cat: write error: Broken pipe
    [04-25-16 5:30:33 pm]  | CMD: cat /images/Win10ESNoDriver/d1p1.img | /usr/local/sbin/udp-sender --interface eno16777984 --min-receivers 1 --max-wait 600 --portbase 63100 --full-duplex --ttl 32 --nokbd --nopointopoint;cat /images/Win10ESNoDriver/d1p2.img | /usr/local/sbin/udp-sender --interface eno16777984 --min-receivers 1 --max-wait 600 --portbase 63100 --full-duplex --ttl 32 --nokbd --nopointopoint;
    [04-25-16 5:30:33 pm]  | Task (13) a has started.
    [04-25-16 5:30:43 pm]  | 0 tasks to be cleaned
    [04-25-16 5:30:43 pm]  | 1 task found
    [04-25-16 5:30:43 pm]  | Task (13) a is no longer running.
    [04-25-16 5:30:43 pm]  | Task (13) a has been cleaned as cancelled.
    [root@fog ~]# vim /opt/fog/log/multicast.log```

Log in to reply
 

490
Online

39.4k
Users

11.1k
Topics

105.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.