SOLVED TFTP/PXE timeout Linux server to Windows PXE boot

  • I am not sure if there specific forum exists with my specific problem but I have read through tons of posts on multiple websites regarding this same issue, but what’s worked for other doesn’t work for me.

    I have a working FOG server with 4690 installed on a VM that is stored locally in our office on CENTOS7. I just built a new CENTOS7 FOG server but it’s on our Rackspace hypervisors in Dallas.

    I have compared the config files, firewall settings, services DHCP settings on our windows domain controller (Yes I have option 066 and 067 enable and pointing to the server that is running FOG/TFTP as well as the correct bootfile undionly.kpxe). But still the client machine which we have imaged ton of with our working server FOG01, will not get past “TFPT…” portion with out timing out with the error PXE-E32 TFTP open timeout.

    I was able to successfully TFTP the bootfile to my mac via terminal I also tried switching subnet’s from FOG01 to the new FOG02 server and the FOG01 server was able to grab the bootfile and load the image. Which leads me to believe SOMETHING on my new FOG02 server isnt working, but again ive compared all the applicable configs, etc… between FOG01 and FOG02 and it’s all identicle.

    Racking my brain here! Anything helps.


  • @alorsung said in TFTP/PXE timeout Linux server to Windows PXE boot:

    I just pulled the current version, wanted to see what new features, if any, were added.

    well, new features aren’t always the goal. Stability, performance, and bug fixes are the primary goal right now. the developers aren’t really adding any more features to fog trunk. from this point out it’s mostly bug fixes and performance improvements, and making fog handle potential issues and scenarios better.

  • @Wayne-Workman I just pulled the current version, wanted to see what new features, if any, were added.

  • @alorsung Great you figured it out. So… why not just make the versions match?

  • Wasnt selinux… that is disabled by default on our centos 7 templates. Also firewalld has tftp service allowed as well as corresponding ports.

    I found the issue and its kind of silly, but FOG02 has version 7180, which is slightly newer than the version on FOG01 and so, in the tftp config i added:


    to the end of “server_args” setting, restarted the xinetd service and it worked. End result:

    server_args = -v -s /tftpboot -r blksize

    I chalked it up to being an issue with versions of FOG or possibly the TFTP server running on the two VM’s because the configs were identical before I made that adjustment.

    Hope this helps anyone else facing this problem.

  • SELinux or Firewall probably.

    systemctl status firewalld

    also -

    in the end, your absolute-ultimate-secret-mega-weapon is wireshark. See what DHCP is saying, see what the FOG Server hears, see how it responds.

    Please do ask more questions if you need to.