• @Tom-Elliott Hi,
    Can you help me please, im on ubuntu 16.04 server lts , i run the script of FOG but i have the same error that 30000MONKEYS
    and when you say edit /lib/ubuntu/config.sh i cant find the folder !
    “/lib” exist but “ubuntu” not in the list

  • @Quazz I’ve done what I can with the schema to make the corrections as needed. The only part I haven’t done yet is set the native password to blank for 5.7 yet. As that’s only one step I don’t think it’s too much to do it by hand.

  • Moderator

    @Tom-Elliott It seems like mysql 5.7 broke a few things, but I’m guessing not enough to bother with this?

  • @Quazz what do you mean?

  • Moderator

    @Tom-Elliott On this note, would it be possible to add something similar for mysql or would it be wiser/simpler to simply fix the issues at hand instead?

  • @Tom-Elliott Sorry, I phrased that wrong. I meant to say that instead of just typing “./installfog.sh”, I typed what you have in the second post.

  • @iyoung You shouldn’t have to replace the installfog.sh file at all, especially now that it did install.

    Once it’s installed successfully once, the php_ver and php_verAdds variables are stored in the /opt/fog/.fogsettings file. Even the packages variable is stored there.

  • Not sure if this is the post we should be using to talk about testing FOG on 16.04 but anyway…

    I was able to install FOG’s latest, as of today, trunk 7468 without issue. I just substituted the regular installfog.sh with Tom’s suggestion and the install ran without issue. It didn’t ask me for a password for MySQL and choose left password blank.

    I get to the first time schema setup, I clicked the button on the webpage, the page loads to say the process was successful. I completed the install, however when I go to log into the web portal at host/fog/management it keeps redirecting to the Schema Installation upgrade page. After click the button and getting the complete page a few times, I restarted the server.

    After restart, I ran the install/update schema button again and that time I was able to get to the login screen. I’ll spin up another vm to see if that always happens or was just a one time quirk.

    P.S. I like the new menu icons

  • Moderator

    @30000MONKEYS We are working on it. Seems like 16.04 is a huge mess: https://wiki.fogproject.org/wiki/index.php?title=Ubuntu_16.04

  • @Wayne-Workman Well, without setting a password it didn’t work at all, and the apache logs don’t show authentification problems as far as I can see…

  • @30000MONKEYS Unless you have set a MySQL password previously, there is no mysql password. Typing in a password when there ins’t one would only cause more complications.

  • @Tom-Elliott Thanks for the quick reply. I tried your first suggestion, which seems to install php7.0 just fine. However, I am facing another problem now. The installer stops at ‘Updating Database’:

     * Resetting SSL Permissions...................................OK
     * Setting up SSL FOG Server...................................OK
     * Restarting Apache2 for fog vhost............................OK
     * Changing permissions on apache log files....................OK
     * Backing up database.........................................OK
     * Updating Database...........................................Failed!

    This is the Error Log:

    The ‘-y’ option was the problem, because it didn’t ask for the MySQL Password. Without the option we did the following:

    • Follow the installer to the point where it asks for the MySQL-Password

    • Manually set the root password via MySQL

    • Enter the password in the FOG installation process

    Now we’re stuck at Updating the database. When we click ‘Update’ in the web management, it leads to an Error 500.

    Apache Log:

    [Tue Apr 12 10:53:43.790626 2016] [mpm_prefork:notice] [pid 31869] AH00163: Apache/2.4.18 (Ubuntu) OpenSSL/1.0.2g configured -- resuming normal operations
    [Tue Apr 12 10:53:43.854389 2016] [core:notice] [pid 31869] AH00094: Command line: '/usr/sbin/apache2'
    [Tue Apr 12 10:54:38.980451 2016] [:error] [pid 31875] [client] PHP Fatal error:  Uncaught Error: Call to a member function save() on null in /var/www/fog/lib/pages/schemaupdaterpage.class.php:51\nStack trace:\n#0 /var/www/fog/lib/fog/fogpagemanager.class.php(73): SchemaUpdaterPage->index_post()\n#1 /var/www/fog/management/index.php(24): FOGPageManager->render()\n#2 {main}\n  thrown in /var/www/fog/lib/pages/schemaupdaterpage.class.php on line 51, referer:

    PHP Info File:

    Any ideas?

  • Because it failed, you haven’t successfully installed yet, I think you could run the installer with:

    php_ver='7.0' php_verAdds='-7.0' ./installfog.sh -y

    Not 100% on the syntax, but should be pretty straight forward. In the case that doesn’t work, you can edit the trunk/lib/ubuntu/config.sh and look for php_ver= and php_verAdds= and make then read as: ‘7.0’ and ‘-7.0’ respectively.

    Then rerun the installer and it should all work.