Snapin client Failed to find snapin file



  • Hello,
    fog svn 6971
    I have problems with deploying snapins.

    ---------------------------------SnapinClient---------------------------------
    ------------------------------------------------------------------------------
     2016-03-29 08:47 Client-Info Version: 0.9.12
     2016-03-29 08:47 SnapinClient Running...
     2016-03-29 08:47 Middleware::Communication URL: http://fog-server/fog/service/servicemodule-active.php?moduleid=snapinclient&mac=08:00:27:86:B7:05||00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0&newService=1
     2016-03-29 08:47 Middleware::Communication Response: Success
     2016-03-29 08:47 Middleware::Communication URL: http://fog-server/fog/service/snapins.checkin.php?mac=08:00:27:86:B7:05||00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0&newService=1
     2016-03-29 08:47 Middleware::Communication Unknown Response: Failed to find snapin file
    
    

    My fog ftp pass is correct (and there is no “/” character in pass), I can log in to ftp server but problem is that fog user logs to /home/fog instead /opt/fog/snapins
    0_1459234779050_fogftp.png
    My question how to force fog user to log to directory where are stored snapins?
    Any help appreciated.
    Regards



  • @Sebastian-Roth thanks for suggestion, there was a problem with snapin configuration. In field “Snapin File (exists)” was "Please select an option"
    Thanks once again
    Regards



  • @Tom-Elliott Tom I’ve checked on different snapin, and this one was installed without issues.


  • Developer

    @robza And maybe show us a screenshot of the snapin configuration that fails (if it’s just one particular!).


  • Senior Developer

    @robza Is it only a problem on specific files? Or all your snapins are having the same issue?



  • @Sebastian-Roth I can get to /opt/fog/snapins and listing, below screen:
    0_1459247644103_fogsnapins.png
    Permissions:
    1000-fog
    48-apache
    Regards


  • Developer

    @robza Please try ftp via command line client again and get a directory listing:

    230 Login successful.
    Remote system type is UNIX.
    Using binary mode to transfer files.
    ftp> cd /opt/fog/snapins
    250 Directory successfully changed.
    ftp> ls
    200 PORT command successful. Consider using PASV.
    150 Here comes the directory listing.
    -rwxrwxr-x    1 1001     33            431 Mar 22 11:03 lbe.bat
    drwxrwxr-x    3 1001     33           4096 Feb 25 13:00 ssl
    226 Directory send OK.
    ftp> 
    


  • Hi,
    in storage management path is set to /opt/fog/snapins
    0_1459238526986_fogstorage.png


  • Moderator

    Hi, there should be a field at your Storage Node that asks you to specify the snapin folder location.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.