Login with USER first



  • Hi,

    Capture works fine but when we want to deply an image, we have this error :

    TYPE 2: file : /var/www/fog/lib/fog/fogftp.class.php, line : 104, message: FTP_login():login with USER first

    Version of fog 6909, debian 8.3

    Thanks.


  • Senior Developer

    @MagicLink Correct, they are compressed.



  • @Sebastian-Roth yes the deployment feature works !
    One question : the image are compressed when saved on Fog ? Our image size (on client) is about 5 Gib and on the dashboard, it’s about 3 Gib


  • Developer

    @MagicLink Please report back if things are working for you… Thanks!



  • It’ OK now, it works better :) i understand now. On our first install, we changed the password of the default storage node. So it’s not the best way, isn’t it ?
    On our second install, we have understood that the password was generated automatically. And we finally understood that it’s not the same as the fog GUI.

    Thank you very much, we 'll try to deploy.

    @Sebastian-Roth We are on test and i remember having some issue with login FTP at the end of the capture. But we saw the image with it’s size on the GUI so we didn’t look for as we installed a second server to be sure of the automatic generation of the password’s storage node.

    Sorry for my bad english, we continue our tests


  • Developer

    @MagicLink Better use the user ‘fog’ for FTP login because that is used by the scripts as well. The ‘fog’ FTP user password is not the same as the ‘fog’ web gui user password! As Tom just said the FTP password you find in .fogsettings (storageftppass) and/or in the Storage Node Management Password area of the GUI. Please try again with the console ftp command to see if login is successful using the correct credentials.

    Re-reading you first post I am wondering about something. You said capture is working find but deploy is not!!! Usually people have FTP issues on capture…


  • Senior Developer

    @MagicLink What?

    When you sign in you set the username to FOG. The password for this user in FTP is usually what’s in the Storage Node Management Password area of the GUI. Another place it’s stored is in /opt/fog/.fogsettings.



  • On localhost, I have root instead of user :

    root@debian:~# ftp 10.22.10.252
    Connected to 10.22.10.252.
    220 (vsFTPd 3.0.2)
    Name (10.22.10.252:root):

    and if i enter root or fog, with the good password, i have this :

    root@debian:~# ftp 10.22.10.252
    Connected to 10.22.10.252.
    220 (vsFTPd 3.0.2)
    Name (10.22.10.252:root): root
    331 Please specify the password.
    Password:
    530 Login incorrect.
    Login failed.
    ftp>


  • Developer

    @MagicLink Please try connection using the command line client (localhost on the FOG server and remote from another linux PC if possible:

    ftp 192.168.1.1
    Connected to 192.168.1.1.
    220 (vsFTPd 3.0.2)
    Name (192.168.1.1:user): fog
    331 Please specify the password.
    Password:
    230 Login successful.
    Remote system type is UNIX.
    Using binary mode to transfer files.
    ftp> 
    


  • root@debian:~# cat /etc/vsftpd.conf
    anonymous_enable=NO
    local_enable=YES
    write_enable=YES
    local_umask=022
    dirmessage_enable=YES
    xferlog_enable=YES
    connect_from_port_20=YES
    xferlog_std_format=YES
    listen=YES
    pam_service_name=vsftpd
    userlist_enable=NO
    tcp_wrappers=YES
    seccomp_sandbox=NO
    

  • Moderator

    @MagicLink It’s seem to be good, can you post the result of : cat /etc/vsftpd.conf



  • root@debian:~# service vsftpd status
    ● vsftpd.service - vsftpd FTP server
       Loaded: loaded (/lib/systemd/system/vsftpd.service; enabled)
       Active: active (running) since jeu. 2016-03-24 10:33:22 CET; 14min ago
      Process: 407 ExecStartPre=/bin/mkdir -p /var/run/vsftpd/empty (code=exited, st     atus=0/SUCCESS)
     Main PID: 430 (vsftpd)
       CGroup: /system.slice/vsftpd.service
               └─430 /usr/sbin/vsftpd /etc/vsftpd.conf
    
    mars 24 10:34:00 debian vsftpd[1208]: pam_listfile(vsftpd:auth): Refused us...pd
    mars 24 10:34:24 debian vsftpd[1216]: pam_unix(vsftpd:auth): authentication...og
    mars 24 10:34:35 debian vsftpd[1221]: pam_unix(vsftpd:auth): authentication...og
    Hint: Some lines were ellipsized, use -l to show in full.
    

  • Moderator

    @MagicLink said:

    i try with Filezilla and can’t connect with root or fog user (“LOGIN incorrect”). Winscp/putty works.

    Can you post the result of : service vsftpd status



  • i try with Filezilla and can’t connect with root or fog user (“LOGIN incorrect”). Winscp/putty works.


  • Moderator

    @MagicLink Hi, can you connect a FTP client to the FOG server ?


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.