Hang during deploy



  • I’m running 6751 on Lubuntu 14.04 32 bit. I imaged a Windows 10 machine with 4 partitions, then deployed that image back to two machines - first using unicast, then using multicast. All went well, so I attempted to deploy at my target location, a small non-profit with 10 workstations, using the same server and image.

    First, I tried multicast and the process hung within a couple of minutes. All machines stuck on a slightly different block with ‘time remaining’ counting up. I had read of problems with various switches, etc using multicast, so I set up a group deploy task using unicast and left the workstations to image over night. On my return 12 hours later the workstations were once again all stuck on a slightly different block with ‘time remaining’ counting up.

    I didn’t know whether it might be possible to recover from the problem and continue from that point in the deploy. Not knowing any better, I rebooted the fog server and restarted one of the hosts. It appeared to start at the biginning of the large partition where the hang happened previously. When I rebooted a second host, however, it gave a repeating error of ‘no slots left’.

    I have removed half of the machines from the network, put them on the small switch I used for my successful home tests, and started a new unicast deploy on those machines. They are currently running the deploy task.

    So, my questions are:

    Any guesses on what might have caused my hangs? I was surprised that all hosts hung during a unicast deploy.
    Any tips on where to look for further debugging information?
    In the case of a hang such as this, might I be able to restart one or more services in hopes of getting the deploy to continue?

    Any help is appreciated.

    Jerry


  • Moderator

    Marking as solved (not directly a FOG issue)



  • Unicast deploy completed succesfully when I isolated the hosts on a known good switch, so likely network problems.

    Thanks again for the help.



  • Thanks for the reply.

    It’s a consumer, unmanaged switch. That was kind of my guess too. Current deploy is at 80% and still running.

    Jerry


  • Moderator

    I’m going to suspect the network in this target location has issues. It will be interesting to see if the small switch performs better.

    The cloning process is not restartable. So once the connection is interrupted then the download fails. You can not pickup where it left off. Does this target location have an enterprise managed switch or is this a consumer (home) switch?


Log in to reply
 

521
Online

39.4k
Users

11.1k
Topics

105.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.