FOG install Centos 6.2 as VHD - tftp error



  • Few problems have made me feel like such an idiot as this ([COLOR=#ff0000]just read the red perhaps, to cut out details you may not care about while skimming a forum).[/COLOR]

    I’ve searched the wiki and followed the advice. I searched this forum and found a number of tftp related items that make it all sound SO simple…

    If I can solve this, I’ll write up a step by step ‘guide for idiots’, honest. I mean, someone needs to do it, who recently fought the good fight.

    I’d love to regale you with stories of the 5 day battle, and the 8 fresh install attempts, but… to the point:

    1.[COLOR=#ff0000] Installed fresh CentOS 6.2 in a HyperV VM on server 2008 R2[/COLOR]. Got it to network (who KNEW it installed without networking enabled! Learned much about eth0 and such).

    2 [COLOR=#ff0000]Installed FOG .32, but had to remove php, htmldoc, and clamav before it would install.[/COLOR] I seem to HAVE php 5.3 already installed, so that part is fine, and one set of instructions says to delete htmldoc, so I assume that’s okay. WHY it can’t find clamav, I don’t know, except I imagine I need to look up how to add servers to yum’s list… when I try to manually install clamav manually, well, it says it doesn’t exist and ‘there is nothing to do’.

    1. All that aside, it SEEMS TO HAVE INSTALLED AND WORK up to the point where I try to ‘upload’ a host to an image file. At that point I get the infamous can’t connect to the tftp server.

    2. This is where it gets weird to me… granted, I run linux just to enjoy an OS that works… and last time I dug into any depths was 20 years ago, with Xenix (don’t pick on me, I’m old) at work.

    [COLOR=#ff0000]Supposedly this is simple. The fog user password is wrong.[/COLOR] It needs to be the same as within fog gui, under info (the question mark icon)/fog settings: FOG_TFTP_FTP_PASSWORD.

    This is where I ‘thought I tried everything possible’, but to not keep writing a book…

    [COLOR=#ff0000]I log into the FOG Gui on the VM as ‘fog’, and ‘password’.[/COLOR] I am logged in as root (seemed harmless to not do the sudo thing constantly).
    [COLOR=#ff0000]I naturally tried to log into linux as fog, but that also failed with the same tftp error.[/COLOR]

    1. I set the fog user login password to ‘password’, and changed fog FOG_TFTP_FTP_PASSWORD to ‘password’.

    2. On another install (exported a base VHD so I could keep installing fog) attempt,[COLOR=#ff0000] I tried changing the fog user password to "a crazy long number I cut and pasted from FOG_TFTP_FTP_PASSWORD[/COLOR], figuring it was some magic number. That also gave me the same error.

    3. [COLOR=#ff0000]I think what I need, if anyone has the patience, is a blow by blow CHANGING OF THE PASSWORD for both user fog, and fog server. [/COLOR]

    [B]MAYBE THERE IS SOMETHING BIG I’M MISSING THERE… maybe there is more to it all…[/B][COLOR=#ff0000][/COLOR]

    This much I know: passwd fog and setting it to ‘password’, and then setting FOG_TFTP_FTP_PASSWORD to password, fails.

    There must be more to it. That magical long number must mean something special, and copy/paste doesn’t work.

    I’ve installed this at least 8 times… on Ubuntu (which is flakey cause in HyperV the nic is unstable), and finally settled on Centos because both MS supports in in a VM, and FOG supports it as an install base for the sw.

    To whoever gives me a fix, a HUGE thank you in advance, and a surprise weird gift in the mail if you give me an address privately (gotta have fun, right?)

    Thank you,

    David



  • I should add that I can use putty (ssh) to connect to the server, and log in with ‘fog’ and ‘password’.


Log in to reply
 

425
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.