Are Fog trunk server + 1.2.0 Storage Nodes compatible?



  • Greetings,

    Just a quick inquiry if I can run FOG trunk on default master but 1.2.0 on SNs. Downsides? Does upgrading to trunk on SNs bring any other gains? I ask because I like some of the features in trunk but plan on having 4 SNs globally and upgrading them poses a number of logistical issues (unrelated to FOG).

    –bw


  • Moderator

    @BardWood I don’t think it will work. The FOG Trunk methods involved with synchronizing storage nodes with their masters has greatly changed, along with the ability to now cross-share images with storage groups. I would not advise mixing versions as you would like, I think it’ll only lead to disaster. The location plugin has also been modified to cause remote nodes at a remote location to PXE boot directly from their local node. Also, the 1.2.0 nodes probably can’t support this functionality

    You’d be better off just updating everything to fog trunk, OR just staying at 1.2.0 till 1.3.0 is released.


Log in to reply
 

422
Online

38953
Users

10704
Topics

101564
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.