Unable to get PXE menu?



  • Hello,

    I’m brand new to FOG. I setup a Linux machine using Ubuntu 12.04 and the latest version of FOG. I’m using the same machine for DHCP and I believe that is setup correctly. It has a static IP address. I’m using an old Cisco switch (not sure of the config on it, should be blank.) When I boot a machine to PXE it looks like it’s getting an IP address…screen goes away and says iPXE initialising devices…ok some iPXE 1.0.0 open source network…blah blah
    Then it says Configuring net (mac address) after that though the machine reboots. Any suggestions? Did I miss something in the config? Does the switch need to be setup with IP helper addresses or anything even though its all on the same switch ? The only things on the switch are the 1 PC and the FOG server…

    Thanks for the help!

    TL;DR – Ended up disabling spanning-tree on the switch and adding an IP helper address and this seemed to resolve the issue.



  • @Tom-Elliott Okay, I’ll look into all this. Just happy to be able to get PXE to work! Again, thanks.


  • Senior Developer

    @mikepel I don’t know how you installed Ubuntu, but I’m going to guess you installed it with a GUI?

    http://askubuntu.com/questions/157629/how-to-prevent-computer-from-automatically-sleeping-and-or-hibernating

    The link should give you some info on how to prevent complete standby. I don’t think display sleep is a problem, but if the system goes out, when it comes back the services are likely not able to see the network (which would cause them to fail).



  • @Tom-Elliott Will Ubuntu go into sleep mode like Windows does? I haven’t touched it in about an hour and it looks like it may have shutdown? Could be why it wasn’t working after the iP helper command…I restart the Ubuntu server, started TFTP and DHCP and I booted the PC and I finally have the FOG menu! WOOHOO Tom, Thank you so much for the help today. Literally so happy to get to this point, now just need to learn how to capture and deploy images! So the things I changed today were the netmask (don’t think this mattered), added an IP helper address and disabled spanning tree. Is the IP helper/spanning tree documented in tutorials anywhere? I don’t think the one I followed mentioned any of that. Anyways, thanks so F’ing much for the help!


  • Senior Developer

    @mikepel All looks to be right, but can you just run another (sudo service tftpd-hpa stop; sleep 2; sudo service tftpd-hpa start) again? It appears dhcp is working now, but tftp literally is not working at this point.



  • ImageServerSwitch>enable
    Password:
    Password:
    ImageServerSwitch#show run
    Building configuration...
    
    Current configuration : 1151 bytes
    !
    version 12.1
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname ImageServerSwitch
    !
    enable secret 5 $1$ggg
    enable password pass1
    !
    ip subnet-zero
    !
    ip ssh time-out 120
    ip ssh authentication-retries 3
    vtp domain westover
    vtp mode transparent
    !
    !
    spanning-tree mode pvst
    no spanning-tree optimize bpdu transmission
    spanning-tree extend system-id
    no spanning-tree vlan 1
    !
    !
    !
    !
    interface FastEthernet0/1
    !
    interface FastEthernet0/2
    !
    interface FastEthernet0/3
    !
    interface FastEthernet0/4
    !
    interface FastEthernet0/5
    !
    interface FastEthernet0/6
    !
    interface FastEthernet0/7
    !
    interface FastEthernet0/8
    !
    interface FastEthernet0/9
    !
    interface FastEthernet0/10
    !
    interface FastEthernet0/11
    !
    interface FastEthernet0/12
    !
    interface GigabitEthernet0/1
    !
    interface GigabitEthernet0/2
    !
    interface Vlan1
     no ip address
     ip helper-address 10.10.73.65
     no ip route-cache
     shutdown
    !
    interface Vlan10
     no ip address
     no ip route-cache
    !
    ip http server
    !
    line con 0
     exec-timeout 0 0
    line vty 0 4
     password pass1
     login
    line vty 5 15
     password pass1
     login
    !
    !
    end
    

    VLANS

    ImageServerSwitch#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                    Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                    Fa0/9, Fa0/10, Fa0/11, Fa0/12
                                                    Gi0/1, Gi0/2
    1002 fddi-default                     act/unsup
    1003 token-ring-default               act/unsup
    1004 fddinet-default                  act/unsup
    1005 trnet-default                    act/unsup
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        0      0
    1002 fddi  101002     1500  -      -      -        -    -        0      0
    1003 tr    101003     1500  -      -      -        -    -        0      0
    1004 fdnet 101004     1500  -      -      -        ieee -        0      0
    1005 trnet 101005     1500  -      -      -        ibm  -        0      0
    
    Remote SPAN VLANs
    ------------------------------------------------------------------------------
    
    
    Primary Secondary Type              Ports
    ------- --------- ----------------- ------------------------------------------
    
    


  • That PXE-E32 error happened after i setup the IP-Helper (and before). I’m only a help desk tech, I very rarely deal with network switch configs so it might not be configured right. I set it for VLAN 1 and all switch ports are on VLAN 1. Is that okay? I will get a copy of the config in a few minutes…

    https://drive.google.com/file/d/19b8JnbScEJ0SC7Nks5z-qFmX4s5nA5DmwQ/view?usp=sharing


  • Senior Developer

    @mikepel Yep, then we need the ip-helper setup.



  • @Tom-Elliott PXE-E32 error.


  • Senior Developer

    @mikepel Correct, but I’m still wanting to know WHERE the tftp timeout is coming from. Is it coming from iPXE (initializing) or is it coming from PXE with a PXE-E32 error?



  • ip address helper should point to the DHCP server (in my case the same server where FOG is running)?



  • @mikepel said:

    helper

    I will in a minute. Setting the IP helper and will try



  • @Tom-Elliott …that was in my OP! I know on SCCM we had to do that which is why I asked.


  • Senior Developer

    @mikepel please try to post a photo of where the tftp timeout is occurring. If it’s during PXE it’s the iphelper thing, if it’s from iPXE it’s something else.


  • Senior Developer

    @mikepel as you’re on a switch you need to enable an ip-helper to tell the switch to redirect dhcp requests to your fog server.



  • Okay spanning-tree is disabled now…now I’m getting something different! TFTP timeout…
    Here is the switch config…

    ImageServerSwitch#show run
    Building configuration...
    
    Current configuration : 1067 bytes
    !
    version 12.1
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname ImageServerSwitch
    !
    enable secret 5 asd
    enable password asd
    !
    ip subnet-zero
    !
    ip ssh time-out 120
    ip ssh authentication-retries 3
    vtp domain westover
    vtp mode transparent
    !
    !
    spanning-tree mode pvst
    no spanning-tree optimize bpdu transmission
    spanning-tree extend system-id
    no spanning-tree vlan 1
    !
    !
    !
    !
    interface FastEthernet0/1
    !
    interface FastEthernet0/2
    !
    interface FastEthernet0/3
    !
    interface FastEthernet0/4
    !
    interface FastEthernet0/5
    !
    interface FastEthernet0/6
    !
    interface FastEthernet0/7
    !
    interface FastEthernet0/8
    !
    interface FastEthernet0/9
    !
    interface FastEthernet0/10
    !
    interface FastEthernet0/11
    !
    interface FastEthernet0/12
    !
    interface GigabitEthernet0/1
    !
    interface GigabitEthernet0/2
    !
    interface Vlan1
     no ip address
     no ip route-cache
     shutdown
    !
    ip http server
    !
    line con 0
     exec-timeout 0 0
    line vty 0 4
     password asd
     login
    line vty 5 15
     password asd
     login
    !
    !
    end
    


  • @Tom-Elliott haha ugh. okay I just put all the console cable stuff away. I did find a USB to console cable so I can use my main PC now at least. I’ll disable it if it’s on by default.


  • Senior Developer

    @mikepel I don’t have the manual for that switch, but MANY cisco switches automatically enable stp by default.



  • It looked like it was a clean config, just to be sure I wiped it again. I don’t think its anything with the switch config…Maybe I should try to rebuild the FOG server from scratch again.



  • @Tom-Elliott Still working on getting into the config. Had to use an old XP laptop, only thing I could find with a serial port.


Log in to reply
 

464
Online

39183
Users

10832
Topics

103076
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.