Deploy image to Hyper V VM



  • Hi,

    I’m having problems deploying a windows image to a hyperv vm

    Hyper-V Version : 6.1.7601.17514
    Fog Version : 1.2.0
    Source PC - Windows 7 32 bit

    I’m sure I’ve done this successfully before but I’m getting the following in the log now…

    tsc: Fast TSC calibration failed

    piix4_smbbus 0000:00:07.3: SMBus base address uninitialized - upgrade BIOS or use force_addr=0xaddr

    BUG: using smp_processor_id() in preemptible [00000000] code: fdisk/2287

    Looking for Hard Disks…BUG: using smp_processor_id() in preemptible [00000000] code: fogpartinfo/2428******

    After that it says Task Completed and reboots, this all takes just a few seconds. I can deploy images I’ve captured previously to this VM so I suspect I’ve done something wrong when capturing this latest image.


  • Developer

    @kevin-buckley said:

    Do I need to add the HyperV VM drivers to the original PC before trying to restore to a hyper V VM?

    I have to admit that I haven’t done this before but I’d guess you need to, yes!



  • ok, I managed to deploy the image…

    Before attempting to update the kernal I noticed I could no longer deploy the old image I had restored yesterday. I deleted the Hyper V VM, recreated it then deployed my latest image and it worked.

    All those errors from before are still visible over the blue and red progress screen. Howver, the newly restored vm won’t start.

    Do I need to add the HyperV VM drivers to the original PC before trying to restore to a hyper V VM?



  • I have another image I took a while back that will deploy to the VM so somethings changed between than and yesterday when i took this latest image.

    If I update the kernel I’ll have to capture the image again?


  • Developer

    @kevin-buckley Interesting… we had the same messages long ago here. It seams like this was not a show stopper back than. Seams like it is not a real show stopper in your case either as you see messages like “Looking for Hard Disks” and “Task Complete”. But from what I can read between the lines here the kernel does not like running tools like fdisk and fogpartinfo which are both absolutely essential!

    You could try upgrading to trunk to see if this is making things better. Or as a first simple step you can just update to a newer kernel version (Web GUI -> FOG Configuration -> Kernel Update). But I still wonder what has changed? Why did it work before…?


Log in to reply
 

380
Online

38719
Users

10547
Topics

99847
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.