Storage nodes failing at creating ssl certificate SVN 6505 and 6507



  • My storage nodes are randomly failing at creating ssl certificate during install.

    /bin/errorlogs/6505 & 6507 show this line at the end.

    /opt/fog/snapins/ssl//fog.csr: No such file or directory
    

    on 6505 only 1 failed, now with 6507 two more are failing.

     * Updating packages as needed.................................OK
    
     * Confirming package installation
    
    
     * Configuring services
    
     * Stopping web service........................................OK
     * Setting up Apache and PHP files.............................OK
     * Testing and removing symbolic links if found................OK
     * Backing up old data.........................................OK
     * Copying back old web folder as is...........................OK
     * Ensuring all classes are lowercased.........................OK
     * Copying new files to web folder.............................OK
     * Creating config file........................................OK
     * Getting checksum files for kernels and inits................OK
     * Downloading inits, kernels, and the fog client..............OK
     * Comparing checksums of kernels and inits....................Failed init_32.xz
     * Attempting to redownload init_32.xz.........................OK
    Done
     * Enabling apache and fpm services on boot....................OK
     * Creating SSL Certificate....................................Failed!
    [bcs@ramage bin]$ 
    

    sometimes the checksum fails and sometimes passes but now, Creating SSL Certificate always fails.



  • @Tom-Elliott Installation worked, but I’m getting

    Type: 2, File:/var/www/html/fog/lib/fog/fogftp.class.php, Line:104, Message: ftp_login():Login incorrect.
    

    This is what I see for both nodes when going into log viewer.

    I checked the .fogsettings file and password in GUI under storage mgmt with no luck.

    UPDATENevermind I forgot to change the password for the fog user as well.


  • Senior Developer

    @Hanz The ; has nothing to do with it. I had it there from old times only because it was familiarity between switching different languages. Bash scripts (as this is kind of related) don’t require a ; to end the line.



  • @Tom-Elliott After looking at my .fogsettings file I’ve noticed that all the " have been replaced with ’ and without any “;” at the end of the lines.

    ## Start of FOG Settings
    ## Created by the FOG Installer
    ## Version: 6513
    ## Install time: Tue 01 Mar 2016 08:12:13 AM EST
    ipaddress='10.72.216.50'
    interface='enp0s25'
    submask='255.255.252.0'
    routeraddress=''
    plainrouter=''
    dnsaddress=''
    dnsbootimage=''
    password='5N9FeRCq5ySs'
    osid='1'
    osname='Redhat'
    dodhcp=''
    bldhcp=''
    blexports='1'
    installtype='S'
    snmysqluser='fogstorage'
    snmysqlpass='fs9694191133'
    snmysqlhost='10.72.3.50'
    installlang=''
    donate=''
    storageLocation='/images'
    fogupdateloaded=1
    storageftpuser='fog'
    storageftppass='5N9FeRCq5ySs'
    docroot='/var/www/html/'
    webroot='fog/'
    caCreated='yes'
    startrange=''
    endrange=''
    


  • @Tom-Elliott apart from doing the update to 6505 I’m not sure what could’ve happened. I did the exact same procedure to other nodes that failed, and they created the CA just fine. I honestly wouldn’t really know how to re-create this, but if you give me some suggestions I will try them.


  • Senior Developer

    @Hanz If possible, can you try to re-replicate the issue so we may maybe make a more proper fix for the issue?



  • @Hanz This can be closed…I removed /var/www/fog, and /opt/fog, and userdel fog…Re-ran installer and it went through on 6511.



  • @Wayne-Workman lol I’ve tried removing that ssl path line from .fogsettings too @Wayne-Workman


  • Moderator

    Double forward slashes?

    /opt/fog/snapins/ssl//fog.csr: No such file or directory
    


  • @Tom-Elliott space is plenty



  • @Tom-Elliott

    /bin/lsb_release
    /bin/systemctl
    /bin/dnf
    ln: failed to create symbolic link ‘/usr/lib/systemd/system/mysql.service’: File exists
    ln: failed to create symbolic link ‘/usr/lib/systemd/system/mysqld.service’: File exists
    ln: failed to create symbolic link ‘/etc/systemd/system/mysql.service’: File exists
    ln: failed to create symbolic link ‘/etc/systemd/system/mysqld.service’: File exists
    /opt/fog/.fogsettings
    Last metadata expiration check performed 0:08:35 ago on Mon Feb 29 18:33:09 2016.
    No package epel-release available.
    Error: Unable to find a match.
    package http://rpms.remirepo.net/fedora/remi-release-22.rpm is not installed
    Last metadata expiration check performed 0:08:36 ago on Mon Feb 29 18:33:09 2016.
    Package remi-release-22-3.fc22.remi.noarch is already installed, skipping.
    Dependencies resolved.
    Nothing to do.
    Complete!
    Last metadata expiration check performed 0:08:37 ago on Mon Feb 29 18:33:09 2016.
    Last metadata expiration check performed 0:08:38 ago on Mon Feb 29 18:33:09 2016.
    Dependencies resolved.
    Nothing to do.
    Complete!
    /opt/fog/snapins/ssl//fog.csr: No such file or directory
    

    This is actually from 6509 now, but same as 6505 & 6507



  • @Tom-Elliott it’s a scripted install with sudo ./installfog.sh -y so I can know every node is done the same, and with all fedora updates first


  • Senior Developer

    Can you get say the last 10-15 lines of the current error file for install?

    The create ssl certificate function hasn’t changed so if it worked before it should work now.

    Is it also possible the disk space is full and simply can’t create the csr?


  • Senior Developer

    @Hanz I only ask because I see bcs on the screen.

    I do try to ensure sudo is running during install, however sudo does not mean you can automatically run all commands.




  • Senior Developer

    Are you running as root?


Log in to reply
 

439
Online

38952
Users

10703
Topics

101542
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.