Issue with capturing DELL Inspiron 24



  • Hello,

    I’m trying to capture and deploy the Win7 image of a Dell Inspiron 24 all in one pc. First I tried my old Fog 0.32 server and always got the failure “can not move to /images/…”, any other pc works without any problems. So I decided to set up a new Fog 1.3 server on CentOS 7. Every machine works fine, but the Dell is issuing again - the host registration works fine, everyhting is
    "Done" but when I pull the image from it it will always hang at “processing hard disk…” (this model also has problems with nearly every Linux live CD, secureboot is disabled, AHCI mode is enabled and can not be changed, also tried single disk/multiple partition/… modes)

    Is there any known Kernel Problem with those Dells? Does anybody have a suggestion what it could be?

    I have a batch of 60 of these Inspirons in need to be imaged and no solution :(

    Can you help me?

    Best regards
    fatfox511



  • Thank you guys! It seems to be that GPT Problem. After doing the fixparts command and deleting the GPT entries now I can upload the machine :-)

    Hopefully deploying them will work in the usual way ;-)

    THANK YOU!



  • Thanks for the replies, I’ll try to answer the questions :)

    It is the Trunk 6371 version i have running here.

    I followed the hint with a brand new ubuntu 15 cd an I could start it (yeeha), this is what the commands give us back:

    http://postimg.org/image/xzk65pwq9/
    http://postimg.org/image/7306xedwx/
    http://postimg.org/image/p39e1s641/

    It is a Dell Inspiron 24 5459 and there is no M2 drive, just a 1TB HDD.

    @Tom I’ve run the fixpart command with that Ubuntu live cd and it told me that there would be some GPT fragments on sda, i let it clean the disk, maybe that could be the problem, as i read that GPT could cause those issues.


  • Senior Developer

    Most often, “can not move to /images/…” Is a problem with FTP, but seeing as other machines work fine, I’m leaning more that the HDD is in GPT format when it’s expected to be in MBR (based on the – it is hanging).

    As you’re trying to capture the image, can you give running through “fixparts” a try?

    Boot the client machine in an Upload - Debug (Choose normal upload tasking and before confirming the task select “Schedule as debug” or open Advanced and select Upload - Debug from that listing) and start the system you’re trying to upload from. Instead of immediately starting the upload it will drop you into a shell of the FOS (FOG Operating System) and you can run your own commands (linux commands).

    At the prompt type:

    fixparts /dev/sda

    It may give you some warnings, confirm and write those changes. After that, run the command
    fog

    It will step through all the steps that normally run while waiting for you to press enter so as to obtain more information about what’s going on in the process.

    Can you also, please, let us know exactly what version of FOG you’re running.

    1.3.0 has not released, and to just say 1.3.0 makes no sense to me (seeing as it’s quite literally a moving target at this point.)

    In the cloud you should see the version/revision number.


  • Developer

    There are a LOT of different "DELL Inspiron 24"s out there. Please tell us more about the specs of your machines. Most important disk (as George said lsblk from a live CD might help) and NIC (lspci -nn | grep Ethernet while you have it live booted anyway).

    Please take a picture of the screen where FOG hangs or shows an error. Usually there is some more information that we see and which is very useful to find and fix things. Especially what do you see after the “Processing Hard Disk” - still on the same line, does it say /dev/sda??


  • Moderator

    Lets get a little bit of back ground information first.

    1. You say that you have 1.3.0 installed, be aware that 1.3.0 has not been released yet. Are you using 1.2.0 or a trunk version (pre 1.3.0)? If you are running a trunk version, what is the number on the blue cloud on the FOG management page?

    2. You say that this model has problems with almost every live linux cd. Can you get this system to boot using ubuntu 15 (or what ever is the latest) desktop live? If so there are some disk commands we need run like getting the output of lsblk

    3. Its interesting that host registration works but imaging fails. Is there anything special about the hard drives in this system, are they the M.2 drives?


Log in to reply
 

405
Online

38993
Users

10713
Topics

101700
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.