Surface Pro 4 not able to image, no network device



  • By default, we are using kernel 4.4.0 on SVN 6124. When we try to capture an image, we get an error that states “No Network Interfaces Found (verifynetworkconnection).”

    We have successfully imaged Surface Pro 3s in our environment.

    I have tried several kernels (including the latest 4.4.1) and different boot files (ipxe.efi, snp.efi, snponly.efi, etc.) with no luck.

    When I run a FOG compatibility check, it fails on network and tells me to try a newer kernel
    I am using the certified Microsoft Surface Ethernet adapter. Any advice? It’s got to be a kernel issue.


  • Developer

    @Scott-Adams And there is another thread where we got past the “No Network Interface Found” issue I think. Try adding has_usb_nic=1 the host’s kernel parameter (host settings)! But it depends on the USB NIC used. We have pretty much every USB NIC driver included in the kernel but I guess there are devices out there for which the kernel does not have a driver (yet). Just give it a try and let us know.

    And please see exactly which USB NIC you have. Read through this interesting discussion on Surface 3. The first couple if posts (page 3) we talk a lot about the two different MS surface adapters and the NIC chip they have.

    As well make sure to update to the very latest trunk version. There have been a lot of fixes!!

    Edit: Re-reading the surface3 posts I remembered that we needed to add the PCI IDs for the MS USB NICs to the kernel. As far as I know those should work if you upgrade to the latest trunk!



  • Cool. Thanks. Will do!


  • Moderator

    @Scott-Adams I would watch this active thread: https://forums.fogproject.org/topic/6752/surface-4-network-boot-and-image/8

    Just sit tight the developers are working on this issue.


 

506
Online

41.9k
Users

12.5k
Topics

117.6k
Posts