which kernel version to update?



  • I have FOG 0.32 on Ubuntu 64bit.
    I would like to update kernel from web console.

    I see 32bit and 64bit of
    Date : July 22, 2015 Version : 3.19.3 FOG Type: TomElliottUSB
    Date : July 22, 2015 Version : 4.1.2 FOG Type: TomElliott

    How do I check what my current kernel version is?
    How can I tell which update is the right update for my FOG server.
    Thanks

    note: uname -r command from ubuntu server shows 3.8.0-35-geneic
    arch command from ubuntu server shows x86_64


  • Developer

    @KJ-You I am marking this as solved as the initial question about kernel update/version is… Feel free to post again and open a new thread if you have another issue.



  • @Sebastian-Roth yes, error shows right when I reboot for the first time after cloning. I will answer rest of your question later. this images from a POS touch terminal with windows embeded from a manufacturer we pulled image out of . Thanks


  • Developer

    @KJ-You When do you see the error? After deploying to that machine and booting the system for the first time? If yes I guess a kernel update won’t help you!

    The error “Missing MBR-helper” seams to come from Grub4Dos. Do you intentionally use it? Can you please describe your setup (OS installed on the client you pull the image from, partition layout, boot loader, make and model - as well as make and model of the destination machine)!

    Just as a reference, here is an interesting post about this error: http://reboot.pro/topic/19651-missing-mbr-helper-when-restoring-a-full-clone-with-grub4dos-mbr/



  • @Sebastian-Roth I am getting “missing mbr-helper” on one particular terminal model

    file /tftpboot/fog/kernel/bzImage shows 3.14.2


  • Developer

    @KJ-You Why do you want to update the kernel but keep your very very dated version of FOG (0.32)?

    To see your current kernel version try this command on the FOG server (hope the paths were the same back in 0.32 - I don’t really know): file /tftpboot/fog/kernel/bzImage

    Cannot suggest a kernel version if I don’t know why you want to update at all. Do you have new clients that won’t boot with the old kernel?


 

324
Online

41.4k
Users

11.8k
Topics

112.0k
Posts