net0 links at slow 10Mb -- causes boot loop



  • I found several other issues talking about configuration of net0, but did not see this particular error mentioned.

    After having upgraded our FOG server (from the ancient .32) to a more recent release (build # 5688) and using it for awhile, I’ve noted that machines when booting to FOG link at a very low 10Mb. It seems to be all computers. This happens across many different computer models. It also appears that this causes the net0 configuration step to fail on occasion, making the computer boot-loop 3 or 4 times before it gets in. This is not a limitation of the computer because once the OS has loaded, the computer will link at 1 Gb.

    Why is it linking at such a slow speed? How can I get it to link at a faster 100Mb or 1Gb speed?



  • Thanks for the reply Sebastian and sorry for the super long delay.

    I am observing this behavior when using “ipxe.pxe” – I have not used any other one binary (not since I switched it to a production server a couple months ago).

    Also, to clarify, the transfer rate is good once the transfer begins, it is only when it is “configuring net0” that it seems to be a slow link. However, I assume it is some hardware dependent issue as I just tried a random computer model and saw it was configuring at the expected 1Gb link speed.

    So I guess the tl;dr is that this isn’t really a problem.


  • Developer

    @mrayzies Seams like you are not the only one seeing some kind of auto-negotiation issue. Read through this: http://forum.ipxe.org/showthread.php?tid=6796 (gets more and more interesting to the end!)

    Which iPXE binary do you use to boot the clients? undionly.kpxe, ipxe.pxe (give that a try!), ipxe.efi, intel.pxe or maybe still pxelinux.0 as you are coming from 0.32??


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.