SOLVED Partclone Not Launching

  • I’m attempting to deploy an image. All looks good until the point at which Partclone is supposed to launch; I see the “Attempting to download image using Partclone” text, but nothing happens and the script continues after a second.

    Any ideas how I can troubleshoot this? I tried a debug deployment with the same result. The hardware is an Intel NUC DCCP847DYE running the latest BIOS. I am booting with ipxe.efi. I can confirm that the deployment did work to a Hyper-V virtual machine.


  • Moderator

    @Tom-Elliott Anything we can do to prevent this kind of issue. Probably not easy to do some magic checks after restoring the MBR to see if the partitions actually fit on the disk. Hmm?!

  • I figured out the root of my problem 🙂

    I created the virtual disk at 64GB, however the target physical disk that I am deploying to only shows up as a little less than 60GB due to the 1,000 vs 1,024 MB discrepancy. My solution was to go back to my virtual machine, shrink the Windows partition slightly and recapture the image. After that the NUC was able to successfully download.

    Thanks for the suggestions

  • @gox777 Please try running system in debug (upload would be best) then when at the prompt run:

    fixparts /dev/sda and confirm and write the changes.

    Then run:

    You are in debug, but it will work I’m almost fully certain.

  • Hi Sebastian,

    I ran gdisk -l /dev/sda and got the following results:


    I wonder why it’s reported as damaged. Let me back up and explain my steps leading up to this:

    • Created a Hyper-V (Gen 2) machine and installed Windows 8.1 x64 OEM using default settings. (I believe Win 8.1 installs using GPT unless otherwise specified, correct?)
    • Installed all updates and applications on Win 8.1.
    • Ran sysprep
    • Registered VM as a host to the Fog server
    • Specified image to be made with the following settings:
      Image Type: Multiple Partition Image - Single Disk (Not Resizable)
      Partition: Everything
      (I originally tried Single Disk Resizable but realized this wasn’t working because Win 8.1 creates additional partitions)
    • Ran upload task for the VM host. Appears that upload was successful.
    • Did a quick register for the Intel NUC and attempted to deploy (download) image which resulted in the issue I’m having

    d1.mbr is attached.
    FOG version is 6315.

    Full disclosure, I’m somewhat new to imaging of this sort so this has been a learning experience.

    Thanks for helping.


  • Moderator

    @gox777 As I see in the picture (thanks for posting!) it is trying to restore a GPT partition table. Is this what you expect it to do? Is your partition schema GPT or MBR?

    Can you please boot this client now in debug mode (just another task like upload or deploy) and run gdisk -l /dev/sda. As well please upload /images/WIN81_DIAGNOSTIC_001/d1.mbr here and I’ll have a look if something seams wrong with it.

    Does it say GPT on the VM in Hyper-V as well??

    Edit: Which version of FOG do you use (see in the blue cloud on the web interface)?