The following errors occured --Database Error IN FOG



  • Database Schema Installer / UpdaterUpdate/Install Failed!

    The following errors occured
    Update ID: 1 - 0

    Database Error:

    Database SQL:

    CREATE DATABASE fog


    Update ID: 1 - 1

    Database Error:

    Database SQL:

    CREATE TABLE fog.groupMembers (
    gmID int(11) NOT NULL auto_increment,
    gmHostID int(11) NOT NULL,
    gmGroupID int(11) NOT NULL,
    PRIMARY KEY (gmID),
    KEY new_index (gmHostID),
    KEY new_index1 (gmGroupID)
    ) ENGINE=MyISAM AUTO_INCREMENT=1 DEFAULT CHARSET=latin1 ROW_FORMAT=DYNAMIC


    Update ID: 1 - 2

    Database Error:

    Database SQL:

    CREATE TABLE fog.groups (
    groupID int(11) NOT NULL auto_increment,
    groupName varchar(50) NOT NULL,
    groupDesc longtext NOT NULL,
    groupDateTime datetime NOT NULL,
    groupCreateBy varchar(50) NOT NULL,
    groupBuilding int(11) NOT NULL,
    PRIMARY KEY (groupID),
    KEY new_index (groupName)
    ) ENGINE=MyISAM AUTO_INCREMENT=1 DEFAULT CHARSET=latin1

    aboushard, 1 minute ago Edit Report

    #1

    1 2

  • Developer

    Please try restarting the mysql service with this command: sudo service mysql restart and see if you can run the Database Update on the web interface directly after that.



  • @Sebastian-Roth
    Dear Sir,
    Thanking you for giving me reply, Thank you Sir…

    I am trying over here To make a Success , But Some Trouble I am Facing about Editing of ‘ROOT’ , ‘PasswordIfYouHaveOne’, ‘Localhost’ in /opt/fog/.fogsettings

    I have opened this file using gedit /var/www/fog/lib/fog/Config.class.php

    It is showing programs like script, So I did not understand that What to check in this file and what to select in this file.

    Please Do help STEP BY STEP, Sincerely it’s my gratitude to you Sir.

    Thanking you,
    Basavaraj


  • Developer

    @BasavarajC Did you get this solved? Please let us know.


  • Developer

    You are welcome! Thanks for the details. Please take a look at this guide and follow the steps to see what your database is up to: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_MySQL

    As well you might want to check this out: https://github.com/fogproject/fogproject/issues/1



  • Dear Sir,
    I am heartily Thankful to you for giving me immediate Reply. Here I am trying to install Fog On My Ubuntu Desktop Edition. Installation Process Completed Successfully. But When I put Link On Browser, It Showed The Previous Error.

    My System Configuration is as below

    Is this a new install or upgrade?
    YES , This is New Installation On Ubuntu 14.04.3 LTS i686 i686 i686 GNU/Linux
    ( First Time I am Trying this FOG Software On Ubuntu Computer and After Watching Many Videos On YOUTUB Site)

    Which version are you trying to install?
    Downloaded the FOG SOFTWARE From This https://sourceforge.net/projects/freeghost/files/latest/download
    Version is fog_1.2.0.tar.gz

    What system/OS on?
    root@vivekanand:~# sudo lsb_release -a
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu 14.04.3 LTS
    Release: 14.04
    Codename: trusty

    root@vivekanand:~# uname -a
    Linux vivekanand 3.19.0-25-generic #26~14.04.1-Ubuntu SMP Fri Jul 24 21:18:00 UTC 2015 i686 i686 i686 GNU/Linux



  • This post is deleted!

  • Developer

    Is this a new install or upgrade? Which version are you trying to install? What system/OS on?


 

503
Online

5.4k
Users

12.6k
Topics

118.9k
Posts